WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Cannot Install TC10 on Hyper-V  (Read 2963 times)

Offline JOSHSKORN

  • WikiUser
  • *
  • Posts: 4
Cannot Install TC10 on Hyper-V
« on: January 22, 2019, 03:21:47 AM »
With Hyper-V, basically I set up TC 9, copied (via export and import) it and started making changes to the copy.  I then decided I wanted to try to install TC10.  During the install process, 'sda' was not present.  Deleting my other VMs, uninstalling/reinstalling Hyper-V did not help.  After uninstalling Hyper-V, I was able to "set-up" TC10 on Virtualbox, and in the first screen of the TC-install, sda was present, but otherwise, Virtualbox was conflicting with Hyper-V during the set-up of the VM.

Anyways, what happened to sda?  Why does it not show?  How can I get it back?  In the install GUI, where sda should be, I can click on the choice as if there's a choice there, but it's blank.

Offline andyj

  • Hero Member
  • *****
  • Posts: 748
Re: Cannot Install TC10 on Hyper-V
« Reply #1 on: January 22, 2019, 08:21:21 AM »
Usually if TC doesn't see a disk it's because it can't talk to the controller. Try changing the controller type to SATA or IDE.

Offline JOSHSKORN

  • WikiUser
  • *
  • Posts: 4
Re: Cannot Install TC10 on Hyper-V
« Reply #2 on: January 23, 2019, 03:49:07 AM »
Usually if TC doesn't see a disk it's because it can't talk to the controller. Try changing the controller type to SATA or IDE.
It defaults to IDE so I tried SCSI, adding a hard drive.  No luck.

I went ahead and found a copy of Tiny Core 9 in the archives, re-installed it and didn't have this problem with Tiny Core 9.  Could Tiny Core 10 be bugged somehow?

EDIT:  I literally just installed another Hyper-V VM of Tiny Core 9.  'sda' appeared as it should, whereas in the Tiny Core 10 installer, it did not.
« Last Edit: January 23, 2019, 03:54:51 AM by JOSHSKORN »

Offline neonix

  • Full Member
  • ***
  • Posts: 197
Re: Cannot Install TC10 on Hyper-V
« Reply #3 on: January 23, 2019, 11:25:38 AM »
I tried to run TC v10.0 x86 on Qemu 3.1.0 but the Internet connection doesn't work. i don't know is it problem with dhcp or e1000 module.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11023
Re: Cannot Install TC10 on Hyper-V
« Reply #4 on: January 23, 2019, 10:22:52 PM »
I just tested with a tc-10.x x86 host using:
Code: [Select]
qemu-system-x86_64 -hda vdisk.img -m 1G -cdrom /mnt/sdb1/tmp/TinyCorePure64-9.0.iso -boot d
..and I'm able to download fifth in the guest and browse the tcl website...
« Last Edit: January 23, 2019, 10:28:26 PM by Juanito »

Offline neonix

  • Full Member
  • ***
  • Posts: 197
Re: Cannot Install TC10 on Hyper-V
« Reply #5 on: January 26, 2019, 08:29:31 AM »
/mnt/sdb1/tmp/TinyCorePure64-9.0.iso -boot d

You mean 9.0 or 10.0 ? Because I tested
http://tinycorelinux.net/10.x/x86/release/Core-10.0.iso
And it works perfect with VirtualBox, but in TC 9 x86 and TC 10 x86 Qemu shows "udevd timeout killing"
I also tested
http://tinycorelinux.net/10.x/x86_64/release/CorePure64-10.0.iso
with the  same result. It looks like the problem is not in iso file but in Qemu 3.1.0 In Qemu 2.5.0 it works without problem.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11023
Re: Cannot Install TC10 on Hyper-V
« Reply #6 on: January 26, 2019, 09:10:21 PM »
Code: [Select]
$ version
10.0
$ qemu-system-i386 -version
QEMU emulator version 3.1.0

$ qemu-img create -f qcow2 vdisk.img 1G
Formatting 'vdisk.img', fmt=qcow2 size=1073741824 cluster_size=65536 lazy_refcounts=off refcount_bits=16
$ qemu-system-i386 -hda vdisk.img -m 1G -cdrom /tmp/Core-10.0.iso -boot d
[works fine]
$ qemu-system-x86_64 -hda vdisk.img -m 1G -cdrom /tmp/CorePure64-10.0.iso -boot d
[works fine]

Offline imtiazsp

  • WikiUser
  • *
  • Posts: 3
Re: Cannot Install TC10 on Hyper-V
« Reply #7 on: February 14, 2019, 11:09:02 PM »
I have the same problem with Hyper-V and TinyCore10, disk not recognised.  I think the module hv_storvsc is needed.  It can be obtained from scsi-4.19.10.tcz.  However hv_storvsc depends on scsi_transport_fc.ko.gz which is missing in this version of the scci extension.  How can we get the scsi_transport_fc.ko.gz for this version? Or how can hyper-v detects TinyCore10 disks?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11023
Re: Cannot Install TC10 on Hyper-V
« Reply #8 on: February 14, 2019, 11:53:17 PM »
I get this:
Code: [Select]
$ modinfo hv_storvsc | grep depends
depends:        hv_vmbus,scsi_transport_fc
$ sudo modprobe hv_storvsc
modprobe: can't load module hv_vmbus (kernel/drivers/hv/hv_vmbus.ko.gz): No such device

..the lack of error regarding scsi_transport_fc might mean that it is compiled into the kernel?

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10040
Re: Cannot Install TC10 on Hyper-V
« Reply #9 on: February 15, 2019, 12:57:44 AM »
I see there was a bug in sorter.sh about scsi_transport_fc. That module is supposed to be in the base, but the script bug resulted in it disappearing instead. It should be enough to build the modules with the config and copy scsi_transport_fc to base, but I don't have time to do so right now. Juanito, do you think you could do it?
The only barriers that can stop you are the ones you create yourself.

Offline imtiazsp

  • WikiUser
  • *
  • Posts: 3
Re: Cannot Install TC10 on Hyper-V
« Reply #10 on: February 15, 2019, 12:59:26 AM »
I have no problem with vm_bus.ko.gz.  When I do 'sudo modprobe hv_storvsc' I get the following line:
'modprobe:can't load module hv_storvsc (kernel/drivers/scsi/hv_storvsc.ko.gz): unknown symbol in module, or unknown parameter'..  Maybe scsi_transport_fc is missing?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11023
Re: Cannot Install TC10 on Hyper-V
« Reply #11 on: February 15, 2019, 04:12:21 AM »
scsi_transport_fc.ko.gz added to modules{,64}.gz and iso's reposted

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10040
Re: Cannot Install TC10 on Hyper-V
« Reply #12 on: February 15, 2019, 09:50:10 AM »
Thanks!

edit: the included depmod data also needs to be updated, otherwise it will only become accessible after e.g. loading an extension with modules, which calls depmod.
« Last Edit: February 15, 2019, 10:04:35 AM by curaga »
The only barriers that can stop you are the ones you create yourself.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11023
Re: Cannot Install TC10 on Hyper-V
« Reply #13 on: February 15, 2019, 10:31:22 PM »
oops - reposted

Offline imtiazsp

  • WikiUser
  • *
  • Posts: 3
Re: Cannot Install TC10 on Hyper-V
« Reply #14 on: February 17, 2019, 09:57:00 PM »
Can you provide me the link to the the iso that have the scsi_transport_fc added?  I am not sure if I  am taking the correct one..