WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Crash on launching X when Xorg-7.7-3d is loaded  (Read 860 times)

Offline rightsknot

  • WikiUser
  • *
  • Posts: 5
Crash on launching X when Xorg-7.7-3d is loaded
« on: January 18, 2019, 05:21:08 AM »
When Xorg-7.7-3d.tcz is loaded, X crashes.  I'm using the Intel i915 driver, on an Intel Atom CPU.

These are the xorg drivers installed:

/dev/loop48 on /tmp/tcloop/xf86-input-evdev type squashfs (ro,relatime)
/dev/loop49 on /tmp/tcloop/xf86-input-synaptics type squashfs (ro,relatime)
/dev/loop53 on /tmp/tcloop/xf86-video-intel type squashfs (ro,relatime)
/dev/loop59 on /tmp/tcloop/xf86-video-vesa type squashfs (ro,relatime)

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6966
Re: Crash on launching X when Xorg-7.7-3d is loaded
« Reply #1 on: January 18, 2019, 05:55:37 AM »
Hi rightsknot
Though probably not related to your problem, your  Xorg.0.log  file shows:
Code: [Select]
[   149.482] Kernel command line: vga=577 loglevel=3 cde showapps lst=duo.lst base host=duo tz=CST laptop noembed multivt utc desktop=openboxThe  cde  code is for non writable media only (CDROM). A standard install should use a  tce  directory.
The  base  command instructs the system not to load any of your extensions.

More information on these and other items can be found here:
http://tinycorelinux.net/corebook.pdf
and here:
http://tinycorelinux.net/faq.html

Offline rightsknot

  • WikiUser
  • *
  • Posts: 5
Re: Crash on launching X when Xorg-7.7-3d is loaded
« Reply #2 on: January 18, 2019, 06:34:45 AM »
Pretty sure it isn't related, but thanks for the heads up.  I'll see about switching off cde and moving my tcz's to the tce directory probably this weekend.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11116
Re: Crash on launching X when Xorg-7.7-3d is loaded
« Reply #3 on: January 18, 2019, 09:10:24 PM »
From your Xorg.0.log, this is where the problem lies:
Code: [Select]
[   151.268] (EE) Illegal instruction at address 0x7f1b4b9724a1
CorePure64 extensions are compiled with "-mtune=generic", perhaps there is something that your "Intel(R) Atom(TM) CPU N570" doesn't like?

Does Core (32-bit) work with Xorg-7.7-3d?