WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: tce-load failing  (Read 541 times)

Offline christully

  • WikiUser
  • *
  • Posts: 28
tce-load failing
« on: January 11, 2019, 08:13:39 AM »
I am developing a custom boot stick based on TC so I am rebooting it A LOT.

It seems like every time I boot into TC and want to run tce-load it fails silently. Then I begin poking around and pinging different servers and eventually I do something that convinces tce-load to work.

But I have not found a consistent trick that makes this happen. Does any one have any suggestions?

Here is ifconfig:

Code: [Select]
tc@box:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:0D:B9:49:55:84
          inet addr:192.168.140.103  Bcast:192.168.140.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:21275 errors:0 dropped:1649 overruns:0 frame:0
          TX packets:127 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2565383 (2.4 MiB)  TX bytes:9548 (9.3 KiB)
          Memory:fe500000-fe51ffff

and here are my current ping results:

Code: [Select]
tc@box:~$ ping repo.tinycorelinux.net
PING repo.tinycorelinux.net (89.22.99.37): 56 data bytes
^C
--- repo.tinycorelinux.net ping statistics ---
19 packets transmitted, 0 packets received, 100% packet loss
tc@box:~$ ping distro.ibiblio.org
PING distro.ibiblio.org (152.19.134.43): 56 data bytes
64 bytes from 152.19.134.43: seq=0 ttl=54 time=34.561 ms
64 bytes from 152.19.134.43: seq=1 ttl=54 time=35.059 ms
64 bytes from 152.19.134.43: seq=2 ttl=54 time=35.273 ms
64 bytes from 152.19.134.43: seq=3 ttl=54 time=33.183 ms
64 bytes from 152.19.134.43: seq=4 ttl=54 time=32.965 ms
64 bytes from 152.19.134.43: seq=5 ttl=54 time=33.040 ms
^C
--- distro.ibiblio.org ping statistics ---
6 packets transmitted, 6 packets received, 0% packet loss
round-trip min/avg/max = 32.965/34.013/35.273 ms
tc@box:~$

I have replaced http://repo.tinycorelinux.net in my /opt/tcemirror file with http://distro.ibiblio.org/tinycorelinux/ because today repo.tinycorelinux.net appears to be down.

Offline christully

  • WikiUser
  • *
  • Posts: 28
Re: tce-load failing
« Reply #1 on: January 11, 2019, 08:27:55 AM »
Oops - I forgot that I had had to wipe and reformat my USB stick, so it's UUID changed...  :-[

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 9971
Re: tce-load failing
« Reply #2 on: January 11, 2019, 10:52:36 AM »
The main repo blocks pings as part of the port scanning protection. It likely marked you as an intruder and blocked your connections for a minute or two.
The only barriers that can stop you are the ones you create yourself.

Offline christully

  • WikiUser
  • *
  • Posts: 28
Re: tce-load failing
« Reply #3 on: January 23, 2019, 11:57:45 AM »
So, if I'm having trouble reaching the repo, is there a better way to check it if is alive?

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6483
Re: tce-load failing
« Reply #4 on: January 23, 2019, 12:17:23 PM »
Hi christully
So, if I'm having trouble reaching the repo, is there a better way to check it if is alive?
The Welcome page, FAQs page, etc. seem to go down at the same time as the repo, so they are probably on the same server. This
forum seems to stay up when the repo goes down so it's probably on a different server.