WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: load TC.tcz  (Read 7535 times)

Offline kp

  • WikiUser
  • *
  • Posts: 42
Re: load TC.tcz
« Reply #30 on: January 12, 2019, 05:47:34 AM »
where do I fetch the libopenssl for 9.x?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13997
Re: load TC.tcz
« Reply #31 on: January 12, 2019, 06:02:19 AM »
/usr/local/lib/libssl.so and /usr/local/lib/libcrypto.so are provided by the openssl extension at:

repo.tinycorelinux.net/9.x/armv6/tcz/openssl.tcz

Offline kp

  • WikiUser
  • *
  • Posts: 42
Re: load TC.tcz
« Reply #32 on: January 12, 2019, 06:26:56 AM »
i already have libel.so and lib crypto.so in my /usr/local/lib. after removing libopenssl-27 , how do i get the tc for libopenssl.so.1.0.0? openssl.tcz does not have it.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13997
Re: load TC.tcz
« Reply #33 on: January 12, 2019, 06:43:17 AM »
Are you sure it's libopenssl.so.1.0.0 and not libssl.so.1.0.0 you're looking for?

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 10363
Re: load TC.tcz
« Reply #34 on: January 12, 2019, 06:47:05 AM »
Hi kp
i already have libel.so and lib crypto.so in my /usr/local/lib. after removing libopenssl-27 , how do i get the tc for libopenssl.so.1.0.0? openssl.tcz does not have it.
You said:
Quote
Thanks. when fifth is run, it complains that libssl.1.0.0 and  lib crypto.so.1.0.0 ...
If you look at the list file for openssl you'll see it provides those libraries:
http://tinycorelinux.net/9.x/armv6/tcz/openssl.tcz.list
Where are you getting this  libopenssl.so.1.0.0  file name from?

Offline kp

  • WikiUser
  • *
  • Posts: 42
Re: load TC.tcz
« Reply #35 on: January 12, 2019, 07:06:57 AM »
it does nt show libopenssl.1.0.0 but shows libssl.1.0.0. is that what you meant?

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 10363
Re: load TC.tcz
« Reply #36 on: January 12, 2019, 07:17:02 AM »
Hi kp
Yes, that's what I meant.

Offline kp

  • WikiUser
  • *
  • Posts: 42
Re: load TC.tcz
« Reply #37 on: January 12, 2019, 07:45:48 AM »
when I created a symlink
# ln -s /usr/local/lib/libssl.so.1.0.0 /usr/local/lib/libopenssl.so.1.0.0
and execute, I get this error
# fifth
fifth: /usr/local/lib/libssl.1.0.0: OPENSSL_1.0.0 not found (required by fifth)
fifth: /usr/local/lib/libcrypto.so.1.0.0: OPENSSL_1.0.0 not found (required by fifth)

Offline NinjaCowboy

  • WikiUser
  • *
  • Posts: 36
Re: load TC.tcz
« Reply #38 on: January 12, 2019, 08:08:33 AM »
If you want to find what package contains a file, you can (with a working internet connection), run tce, and press P to search for extensions that provide the file, type the name of the file, and press Enter.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13997
Re: load TC.tcz
« Reply #39 on: January 12, 2019, 11:48:36 PM »
fifth depends on the openssl extension from piCore-9.x - this is openssl-1.0.1j, which contains libssl.so.1.0.0
Code: [Select]
$ ldd `which fifth` | grep ssl
        libssl.so.1.0.0 => /usr/local/lib/libssl.so.1.0.0 (0x00007f985e39c000)

The openssl extension was updated in piCore-10.x - this is openssl-1.1.0.h, which contains libssl.so.1.1

In order for fifth to work in piCore-10.x, you need to:

* download the openssl extension from piCore-9.x
* rename the openssl extension from piCore-9.x to openssl_old
* load the openssl_old extension in piCore-10.x

Offline kp

  • WikiUser
  • *
  • Posts: 42
Re: load TC.tcz
« Reply #40 on: January 13, 2019, 06:25:58 AM »
I installed openssl from 9.x and fifth gets installed. but when I execute, I get this error
# fifth
limpng warning: iCCP: known incorrect sRGB profile
<3 times>

when I type url google, com or any other url, it exits with sig 11 segmentation fault. Maybe you can try if it works for you and let me know.

Offline NinjaCowboy

  • WikiUser
  • *
  • Posts: 36
Re: load TC.tcz
« Reply #41 on: January 13, 2019, 06:32:04 PM »
Google works fine for me with Fifth, but going to Wikipedia or Facebook results in an immediate Segmentation Fault.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13997
Re: load TC.tcz
« Reply #42 on: January 13, 2019, 10:04:13 PM »
limpng warning: iCCP: known incorrect sRGB profile
<3 times>

This warning can be ignored.

If you start fifth from a terminal window, does it give any error messages when it crashes?

Offline NinjaCowboy

  • WikiUser
  • *
  • Posts: 36
Re: load TC.tcz
« Reply #43 on: January 19, 2019, 09:24:23 AM »
I just get a segmentation fault. For example:
Code: [Select]
$ fifth www.wikipedia.org
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: profile 'Photoshop ICC profile': 'RGB ': RGB color space not permitted on grayscale PNG
Opening remote URL www.wikipedia.org
Crashing with signal Segmentation fault (11)
It also crashes frequently when scrolling on this forum. Disabling CSS can help if you don't mind the page looking awful.