WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Epiphany doesn't work  (Read 717 times)

Offline neonix

  • Full Member
  • ***
  • Posts: 115
Epiphany doesn't work
« on: January 07, 2019, 11:37:04 AM »
I got something like this in Tc 9.x (x86)
Code: [Select]
tc@box:~$ /usr/local/bin/epiphany

(epiphany:16978): Gtk-WARNING **: Could not find the icon 'ephy-bookmarks-symbolic-ltr'. The 'hicolor' theme
was not found either, perhaps you need to install it.
You can get a copy from:
        http://icon-theme.freedesktop.org/releases

(epiphany:16978): Gdk-ERROR **: The program 'epiphany' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
  (Details: serial 517 error_code 2 request_code 139 (RENDER) minor_code 34)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Trace/breakpoint trap
tc@box:~$

i also have problem with Epiphany in Tc 8.x (x86) with TSL. Is it possible that error in Tc 8 will be fixed? One of my thin client does't work with Tc 9.x and I have to use Tc 8.x

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6353
Re: Epiphany doesn't work
« Reply #1 on: January 07, 2019, 12:26:27 PM »
Hi neonix
I got something like this in Tc 9.x (x86)
Code: [Select]
tc@box:~$ /usr/local/bin/epiphany

(epiphany:16978): Gtk-WARNING **: Could not find the icon 'ephy-bookmarks-symbolic-ltr'. The 'hicolor' theme
was not found either, perhaps you need to install it.
You can get a copy from:
        http://icon-theme.freedesktop.org/releases ...
Did you try installing  hicolor-icon-theme.tcz ?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10562
Re: Epiphany doesn't work
« Reply #2 on: January 07, 2019, 08:27:05 PM »
It looks like you need Xorg-7.7

Offline neonix

  • Full Member
  • ***
  • Posts: 115
Re: Epiphany doesn't work
« Reply #3 on: January 09, 2019, 10:50:45 AM »
I installed Xorg with vesa driver.
Then I instaled hicolor-icon-theme.tcz

And gdb gave me:
Code: [Select]
tc@box:~$ gdb epiphany
GNU gdb (GDB) 8.1
Copyright (C) 2018 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i486-pc-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from epiphany...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/local/bin/epiphany
warning: File "/tmp/tcloop/glibc_add_lib/lib/libthread_db-1.0.so" auto-loading has been declined by your `auto-load safe-path' set to "$debugdir:$datadir/auto-load".
To enable execution of this file add
        add-auto-load-safe-path /tmp/tcloop/glibc_add_lib/lib/libthread_db-1.0.so
line to your configuration file "/home/tc/.gdbinit".
To completely disable this security protection add
        set auto-load safe-path /
line to your configuration file "/home/tc/.gdbinit".
For more information about this security protection see the
"Auto-loading safe path" section in the GDB manual.  E.g., run from the shell:
        info "(gdb)Auto-loading safe path"
warning: Unable to find libthread_db matching inferior's thread library, thread debugging will not be available.
libnettle.so.4: cannot open shared object file: No such file or directory
Failed to load module: /usr/local/lib/gio/modules/libgiognutls.so
[New LWP 25814]
[New LWP 25815]
[New LWP 25817]
[New LWP 25818]
[New LWP 25819]
[New LWP 25820]
[New LWP 25821]
[New LWP 25822]
[New LWP 25825]
[New LWP 25826]
[New LWP 25827]
libnettle.so.4: cannot open shared object file: No such file or directory
Failed to load module: /usr/local/lib/gio/modules/libgiognutls.so
[New LWP 25842]
[LWP 25842 exited]
[New LWP 25843]

** (epiphany:25810): WARNING **: Error retrieving filter https://easylist.to/easylist/easylist.txt: TLS/SSL support not available; install glib-networking


** (epiphany:25810): WARNING **: Error retrieving filter https://easylist.to/easylist/easyprivacy.txt: TLS/SSL support not available; install glib-networking

libnettle.so.4: cannot open shared object file: No such file or directory
Failed to load module: /usr/local/lib/gio/modules/libgiognutls.so

** (WebKitWebProcess:25841): WARNING **: Failed to search secrets in password schema: Error calling StartServiceByName for org.freedesktop.secrets: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.freedesktop.secrets exited with status 127

(WebKitWebProcess:25841): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
[LWP 25825 exited]
[New LWP 25864]
[New LWP 25865]
[New LWP 25866]
[LWP 25865 exited]
libnettle.so.4: cannot open shared object file: No such file or directory
Failed to load module: /usr/local/lib/gio/modules/libgiognutls.so
[New LWP 25879]

** (WebKitWebProcess:25863): WARNING **: Failed to search secrets in password schema: Error calling StartServiceByName for org.freedesktop.secrets: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.freedesktop.secrets exited with status 127

(WebKitWebProcess:25863): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
[LWP 25879 exited]

Thread 1 "epiphany" received signal SIGSEGV, Segmentation fault.
0xb7ee5a08 in ?? () from /lib/libc.so.6
(gdb)

I put "serial 517 error_code 2 request_code" into the google and got this:
https://bugzilla.redhat.com/show_bug.cgi?id=1661305

I reported very similar problem here:
https://forum.tinycorelinux.net/index.php/topic,22025.msg137884.html#msg137884

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6353
Re: Epiphany doesn't work
« Reply #4 on: January 09, 2019, 12:31:44 PM »
Hi neonix
Quote
Code: [Select]
** (epiphany:25810): WARNING **: Error retrieving filter https://easylist.to/easylist/easyprivacy.txt: TLS/SSL support not available; install glib-networking

libnettle.so.4: cannot open shared object file: No such file or directory
Failed to load module: /usr/local/lib/gio/modules/libgiognutls.so

** (WebKitWebProcess:25841): WARNING **: Failed to search secrets in password schema: Error calling StartServiceByName for org.freedesktop.secrets: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.freedesktop.secrets exited with status 127

(WebKitWebProcess:25841): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
Did you install  glib-networking.tcz ?

You may also want to do one of the following to allow gdb to trace any threads:
Quote
warning: File "/tmp/tcloop/glibc_add_lib/lib/libthread_db-1.0.so" auto-loading has been declined by your `auto-load safe-path' set to "$debugdir:$datadir/auto-load".
To enable execution of this file add
        add-auto-load-safe-path /tmp/tcloop/glibc_add_lib/lib/libthread_db-1.0.so
line to your configuration file "/home/tc/.gdbinit".
To completely disable this security protection add
        set auto-load safe-path /
line to your configuration file "/home/tc/.gdbinit".

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10562
Re: Epiphany doesn't work
« Reply #5 on: January 10, 2019, 09:47:24 PM »
Note that epiphany was recently updated in tc-9.x x86 (15 Dec 2018) and tested working with html5.

There are no plans to update the version in tc-8.x.

Offline neonix

  • Full Member
  • ***
  • Posts: 115
Re: Epiphany doesn't work
« Reply #6 on: January 11, 2019, 09:26:23 AM »
In TC 7 Epiphany works with Xfbdev
In TC 8 Epiphany works only with Xorg (vesa driver)
In TC 9 Epiphany works only with Xorg (vesa driver) but then, after loading a webpage, it crush maybe because libEGL. I'm not sure.

Code: [Select]
libEGL warning: DRI2: failed to authenticate
libEGL warning: DRI2: failed to open swrast (search paths /usr/local/lib/dri)
libEGL warning: DRI2: failed to open swrast (search paths /usr/local/lib/dri)
EGLDisplay Initialization failed: EGL_NOT_INITIALIZED
Cannot create EGL sharing context: invalid display (last error: EGL_SUCCESS)

Conclusion:
1) TinyX is going out of use.
2) Both in TC 7 and TC 8 there is the same version 3.8.2 of Epiphany but it behaves differently.
3) There are other more interesting web browsers.
« Last Edit: January 11, 2019, 09:29:19 AM by neonix »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10562
Re: Epiphany doesn't work
« Reply #7 on: January 12, 2019, 12:10:38 AM »
It looks like Xorg-7.7-3d is required for epiphany-3.28

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10562
Re: Epiphany doesn't work
« Reply #8 on: January 19, 2019, 02:33:48 AM »
glib-networking recompiled so that it depends on the latest version of nettle - that might have prevented epiphany from working.