WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Desktop goes black when setting a background image  (Read 1949 times)

Offline Criteria

  • WikiUser
  • *
  • Posts: 7
Desktop goes black when setting a background image
« on: December 29, 2018, 09:41:01 PM »
Hello, so I'm pretty new to Tiny Core and this is my first look into it. As I was setting the desktop with Openbox, I tried to set a background image on ControlPanel > Wallpaper, then from a solid blue, it turned into a black bg. The only background I could get are colors.

After some research, I installed others WM and nothing worked out. By now I'm using JWM and edited .jwmrc,  yet when adding a bg image for the desktop, some kind of gray background appears.

I've some experience with linux, but I try to not go further from what I know.

Thank you, and sorry for my english~

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11006
Re: Desktop goes black when setting a background image
« Reply #1 on: December 29, 2018, 09:46:18 PM »
Using flwm, if you copy a jpeg image into /opt/backgrounds and then use control panel/wallpaper you can set a background image.

Offline Criteria

  • WikiUser
  • *
  • Posts: 7
Re: Desktop goes black when setting a background image
« Reply #2 on: December 30, 2018, 01:48:47 PM »
Using flwm, if you copy a jpeg image into /opt/backgrounds and then use control panel/wallpaper you can set a background image.

Background is still black, not even the logo appears, maybe need some libs?

I can see all images using flviewer or the browser.
« Last Edit: December 30, 2018, 01:55:13 PM by Criteria »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11006
Re: Desktop goes black when setting a background image
« Reply #3 on: December 30, 2018, 10:42:19 PM »
Are you using Xvesa, Xorg-7.7 or Xfbdev?

Which window manager are you using? It might be better to use flwm for troubleshooting the wallpaper problem.

Offline Criteria

  • WikiUser
  • *
  • Posts: 7
Re: Desktop goes black when setting a background image
« Reply #4 on: December 30, 2018, 11:07:32 PM »
I'm using Xvesa, for wm I installed flwm but the background keeps going black. Any suggestions?

Update: I noticed the .setbackground file, where it puts "hsetroot -tile /opt/backgrounds/bg.jpg", So when I run the same code on the terminal, it says:

Code: [Select]
tc@box:~$ hsetroot -tile /opt/backgrounds/bg.jpg
sh: xrandr: not found

Is xrandr a missing dependency?
« Last Edit: December 30, 2018, 11:21:22 PM by Criteria »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11006
Re: Desktop goes black when setting a background image
« Reply #5 on: December 30, 2018, 11:44:01 PM »
apparently so - xrandr is supplied by Xorg-7.7-bin, but this still doesn't make things work with Xvesa although it does work with Xorg-7.7.

I'm pretty sure that "wallpaper" used to work with Xvesa  ???

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11006
Re: Desktop goes black when setting a background image
« Reply #6 on: December 31, 2018, 12:42:05 AM »
hsetroot reverted to previous version in Xlibs extension and reposted in x86/x86_64 repos.

Things seem to work now without xrandr/libXrandr.
« Last Edit: December 31, 2018, 12:50:03 AM by Juanito »

Offline Criteria

  • WikiUser
  • *
  • Posts: 7
Re: Desktop goes black when setting a background image
« Reply #7 on: December 31, 2018, 02:21:07 AM »
Updated Xlibs and the wallpaper is visible now, thanks a lot for the support! :D