WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: libffi.so.5 needed by bluetooth  (Read 218 times)

Offline tcFan

  • WikiUser
  • *
  • Posts: 34
libffi.so.5 needed by bluetooth
« on: December 03, 2018, 11:30:09 AM »
.. but system has libffi.so.6.

-- tried to follow the instructions as per the sticky in this forum (update  .deps etc), didnt work.

-- tried to use LD_LIBRARY_PATH with a symlink from .5 to .6, didnt work either. (the variable doesnt exist btw, is that how TC does things?)

using Tinycore Plus 9.0 iso.

any suggestions?

thanks.

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6004
Re: libffi.so.5 needed by bluetooth
« Reply #1 on: December 03, 2018, 11:49:44 AM »
Hi tcFan
Did you try loading  libffi5.tcz?


Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10199
Re: libffi.so.5 needed by bluetooth
« Reply #2 on: December 04, 2018, 10:19:48 PM »
I cannot find anything in the bluez extension that depends on libffi.so.5

What command are you using when you get the error?

Edit: I just used the tc-9.x x86 blueman extension to scan for bluetooth devices and it worked without libffi5..
« Last Edit: December 04, 2018, 11:04:21 PM by Juanito »

Offline tcFan

  • WikiUser
  • *
  • Posts: 34
Re: bluetooth needs libffi.so.5 , dbus
« Reply #3 on: December 05, 2018, 06:32:41 AM »
hi
it worked but now it cannot connect to dbus (G_IS_DBUS_CONNECTION)

the command is bluetooth-wizard .. sounds like im missing some update for pkg listings or the right repo?

I was using gnome-bluetooth 'cause that's what showed up when searching for bluetooth. Trying blueman shortly...

Blueman has same dBus issue now. IIRC, when Firefox moved to pulseaudio, this also occured. (Cant remember the solution though

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10199
Re: libffi.so.5 needed by bluetooth
« Reply #4 on: December 05, 2018, 09:01:55 PM »
gnome-bluetooth was missing a dep on libffi5 - now added.

gnome-bluetooth works, but as it is old and it is not possible to update it (recent versions require a newer version of udev than that in tinycore), I would suggest using blueman instead.