WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: error building ecrire  (Read 781 times)

Offline jls

  • Hero Member
  • *****
  • Posts: 2133
error building ecrire
« on: January 12, 2019, 03:53:05 AM »
Hi
I'mtriyng to buold ecrire from the following git:
https://github.com/Obsidian-StudiosInc/ecrire
but I got error:
Code: [Select]
jls@pc1:/tmp/ecrire$ cmake .
cmake: /usr/lib/x86_64-linux-gnu/libcurl.so.4: version `CURL_OPENSSL_4' not found (required by cmake)
dCore user

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9659
Re: error building ecrire
« Reply #1 on: January 12, 2019, 06:22:44 PM »
Here is what I did on dCore-bionic64.  I added the below repo in /opt/debextra:

sce-import sce-ppa-add
sce-load sce-ppa-add
sce-ppa-add ppa:niko2040/e19

also:
sce-import libefl-dev

I have the basic build-essential and cmake packages and probably some other development packages.


Then I downloaded the tar.gz from the github website for ecrire:

https://github.com/Obsidian-StudiosInc/ecrire

I untarred the tar.gz, then entered it's base directory then:

cmake .
make package

It created an *.rpm and *.deb file of the results.  I took the results of the .deb file and copied it to the filesystem and ecrire worked.






« Last Edit: January 13, 2019, 07:16:46 AM by Jason W »

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9659
Re: error building ecrire
« Reply #2 on: January 12, 2019, 07:10:36 PM »
I did a reboot with only the below SCEs installed instead of my full desktop with the repo ppa:niko2040/e19 available and the build of ecrire went as expected:

build-essential
cmake
emelfm2
firefox
graphics-4.14.10-tinycore64
libefl-dev
nvidia-340.106-4.14.10-tinycore64
rpm
sce-ppa-add
wireless
wireless-4.14.10-tinycore64
xfce4
xorg-all

Hope this helps. 

« Last Edit: January 12, 2019, 07:16:01 PM by Jason W »

Offline Pats

  • Sr. Member
  • ****
  • Posts: 313
Re: error building ecrire
« Reply #3 on: January 13, 2019, 12:05:39 AM »
While on the subject of .rpm and .deb , ... would like to remind many new members about a nice small script by the great script guy  jason w , which easily  converts  .deb2tcz  and  maybe .rpm2tcz .
... Since not used recently, not sure if it still works with newer versions of .deb files. Interested members can check the link of that topic :
Quick hack to convert Debian packages at link :
->  forum.tinycorelinux.net/index.php?topic=2325.0

.... Also a nice info can be found in this book :
http://tinycorelinux.net/corebook.pdf

... Into the Core: A look at Tiny Core Linux. By Lauri Kasanen ( with curaga touch ) ! :)