WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Upgrade samba to latest version for TCL x86  (Read 628 times)

Offline bonbob

  • Jr. Member
  • **
  • Posts: 82
Upgrade samba to latest version for TCL x86
« on: October 04, 2018, 11:25:54 PM »
Can anyone upgrade SAMBA extension for TCL x86?
For corepure64 it ver. 4.6.3 and 3.6.25 for TCL x86.

Offline bonbob

  • Jr. Member
  • **
  • Posts: 82
Re: Upgrade samba to latest version for TCL x86
« Reply #1 on: October 05, 2018, 09:38:22 PM »
samba3 not working. In Log-file:
Code: [Select]
samba regdb_init: unknown registry versionGoogle says i need upgrade samba to newest version 4.x. I said "OK GOOGLE" and download samba latest source files ver 4.9.1.
But compilation was not successful.
I've got an error
Code: [Select]
rpcgen: not foundGoogle helps me again:
Quote
In order to support NIS and NFS we need to use libtirpc, libnsl2 and rpcsvc-proto
So i stuck again. There is no rpcsvc-proto.tcz in repository.

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6000
Re: Upgrade samba to latest version for TCL x86
« Reply #2 on: October 05, 2018, 09:58:20 PM »
Hi bonbob
Quote
So i stuck again. There is no rpcsvc-proto.tcz in repository.
Try installing  glibc_base-dev.tcz.  I believe it provides the needed files.

Offline bonbob

  • Jr. Member
  • **
  • Posts: 82
Re: Upgrade samba to latest version for TCL x86
« Reply #3 on: October 06, 2018, 08:40:19 AM »
i have installed glibc_base-dev.tcz, but compiler still searching rpcgen  :-[

maybe someone knows how to make samba3 working on TCL 9.0? I remembrer it was fine on TCL 8.x
« Last Edit: October 06, 2018, 08:42:42 AM by bonbob »

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6000
Re: Upgrade samba to latest version for TCL x86
« Reply #4 on: October 06, 2018, 09:12:07 AM »
Hi bonbob
It's supposed to be in  glibc_apps.tcz,  but the TC9 version of  glibc_apps.tcz  is missing that program. The 64 bit TC9
version of  glibc_apps.tcz  does contain the  rpcgen  program. Both 32 and 64 bit versions in TC8 have  rpcgen  included
in  glibc_apps.tcz,  so this was probably just an oversight. I think Juanito might have to fix this.

Offline bonbob

  • Jr. Member
  • **
  • Posts: 82
Re: Upgrade samba to latest version for TCL x86
« Reply #5 on: October 06, 2018, 09:21:24 AM »
Now it is not necessary. I deleted all files in /var/lib/samba an restarted samba3. After that
error regdb_init: unknown registry version 3 (code version = 2) has gone and samba3-server launched succesfully.  :)
Maybe later someone upgrade samba for x86, but now my problem solved

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6000
Re: Upgrade samba to latest version for TCL x86
« Reply #6 on: October 06, 2018, 09:25:37 AM »
Hi bonbob
So it sounds like you are saying you got the 64 bit version running, is that correct?

Offline bonbob

  • Jr. Member
  • **
  • Posts: 82
Re: Upgrade samba to latest version for TCL x86
« Reply #7 on: October 06, 2018, 10:05:09 AM »
Recently i got a thin client with VIA Eden processor on board. It is i686 cpu and it do not work with CorePure64. Before it i used CorePure64 on broken notebook as a home mediaserver. I have migrated with all shell scripts and config files in mydata.tgz from CorePure64 то TCLx86. So all *.tdb files for samba4 was copied too.  Error message contains answer, that tdb version is 3, but samba3 need version 2. Another question that SMB1 protocol is deprecated in windows 10 by security reasons, and disabled by default . It better to upgrade samba to SMB2 or even SMB3. 

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10196
Re: Upgrade samba to latest version for TCL x86
« Reply #8 on: October 19, 2018, 05:28:20 AM »
Hi bonbob
It's supposed to be in  glibc_apps.tcz,  but the TC9 version of  glibc_apps.tcz  is missing that program.

In fact the list file was missing rpcgen, but the extension contains rpcgen - list file updated