WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: thumbnailing not working  (Read 1465 times)

Offline jls

  • Hero Member
  • *****
  • Posts: 2133
thumbnailing not working
« on: September 29, 2018, 07:14:49 AM »
Hi
I've switched from niko2040 ppa to
https://launchpad.net/~torkvemada/+archive/ubuntu/e22?field.series_filter=bionic
on ubuntu the file manager shows the preview on pdf, libreoffice, I mean thumbailing, and also svg files are displayed, for example pidgin icon, here on dCore those thinghs not work.
Thanks
dCore user

Offline jls

  • Hero Member
  • *****
  • Posts: 2133
Re: thumbnailing not working
« Reply #1 on: September 29, 2018, 08:38:14 AM »
/tmp/wm_errors show the following:
Code: [Select]
ERR<4991>:eina_file lib/eina/eina_file_common.c:1097 eina_file_shutdown() File [/mnt/sda1/home/jls/Video/Raster and Hermet dance Gangnam Style in Korean E Meeting.mp4] still open 1 times !
## Copy & Paste the below (until EOF) into a terminal, then hit Enter

eina_btlog << EOF
/usr/lib/x86_64-linux-gnu/libeina.so.1   0x7f5f073b8cfc 0x7f5f07394000
/usr/lib/x86_64-linux-gnu/libeina.so.1   0x7f5f073b9a21 0x7f5f07394000
/usr/lib/x86_64-linux-gnu/libeina.so.1   0x7f5f073badf3 0x7f5f07394000
/usr/lib/x86_64-linux-gnu/libeina.so.1   0x7f5f073aef8d 0x7f5f07394000
/usr/lib/x86_64-linux-gnu/libeina.so.1   0x7f5f073bc59c 0x7f5f07394000
/usr/lib/x86_64-linux-gnu/libeina.so.1   0x7f5f073bc86b 0x7f5f07394000
/usr/lib/x86_64-linux-gnu/libecore.so.1  0x7f5f06ab4af9 0x7f5f06aa5000
/usr/lib/x86_64-linux-gnu/enlightenment/utils/enlightenment_thumb        0x562e2bbc4c33 0x562e2bbc2000
/lib/x86_64-linux-gnu/libc.so.6  0x7f5f0595db97 0x7f5f0593c000
/usr/lib/x86_64-linux-gnu/enlightenment/utils/enlightenment_thumb        0x562e2bbc4c8a 0x562e2bbc2000
EOF
dCore user

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9660
Re: thumbnailing not working
« Reply #2 on: September 30, 2018, 01:28:11 PM »
By file manager I assume you mean the Enlightenment file manager.  I see it is a dependency issue as when I load my full desktop SCE thumbnailing works.  I will see if I can locate which dep is missing. 

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9660
Re: thumbnailing not working
« Reply #3 on: October 01, 2018, 05:47:24 PM »
I made a list file of the packages of a Ubuntu Bionic install that included enlightenment, about 1300 packages, and with them installed as one large SCE in dCore-bionic, pdf file preview in the enlightenment file manager and things like that worked like on Ubuntu.  I did spend some time trying to locate the needed dependencies, but with that many packages it is not possible.  But with the needed deps installed, things work fully.