WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Can't get Wifi working with a custom driver  (Read 194 times)

Offline Scorp1us

  • WikiUser
  • *
  • Posts: 34
Can't get Wifi working with a custom driver
« on: September 05, 2018, 03:20:51 PM »
So the rl8723bu driver is supported by linux and I compiled and got it working on the 32bit version of tinycore. ( http://forum.tinycorelinux.net/index.php/topic,22183.0.html )

I tried to compile it uner CP64 and it complies and installs fine.
But when I modprobe, it says unknown symbols.

After reading many things online, it seems I need 'wifi' and 'wireless-<somekernelversion>' but those aren't in the Pure64 repo.

The unknown symbols are:
cfg80211_* [scan_done, get_bss, put_bss, etc]
wiphy_* [free, etc]
ieee80211_* [frequency_to_channel, etc]

After I get that working, the question would be how do I get it to take the new kernel module and load it automatically on boot?



Offline Scorp1us

  • WikiUser
  • *
  • Posts: 34
Re: Can't get Wifi working with a custom driver
« Reply #1 on: September 05, 2018, 03:31:52 PM »
Nah, I'm an idiot.


I got this working... turns out the tce-ab doesn't know the real size of the display. After installing some intel 915 driver, I get really small text, and as a result tce-ab cuts off the list prematurely... I thought it was done listing results to my keyword search, but there was another page to go!

The question remains... what do I have to to to skip the
sudo depmod -a
sudo make install
sudo modprobe 8723bu

on every reboot?

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 2732
Re: Can't get Wifi working with a custom driver
« Reply #2 on: September 05, 2018, 03:49:46 PM »
...
The question remains... what do I have to to to skip the
sudo depmod -a
sudo make install
sudo modprobe 8723bu

on every reboot?
Already answered on your other thread of similar issue
http://forum.tinycorelinux.net/index.php/topic,22183.msg138933.html#msg138933