WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Install instructions are bad  (Read 1275 times)

Offline Scorp1us

  • WikiUser
  • *
  • Posts: 34
Install instructions are bad
« on: August 31, 2018, 04:47:46 PM »
After downloading, writing and booting from CorePlus-current.iso,

Following along at:
https://distro.ibiblio.org/tinycorelinux/install.html
0. I boot to tinycore with install
1. I choose to download the 64 bit version.
And it goes fine until step 5.
Sometimes I see step 5, sometimes I don't - despite always using the CorePlus image.  It seems to vary on if I download the core or if I select it off the stick.
Of note, there is no 64bit kernel on the image.

6. I set the directory to /mnt/sdb/cde
7. This goes well, when I have network, otherwise it fails and I can't next, back or retry and I have to start from 1 again in a new invocation.
Also, it seems the primary mirror is down ( get a MD5 validation error) , I have to launch Apps and select fastest mirror, then go through the whole process again.

Then when I reboot off the HD (64bit) I get:
/usr/bin/startx: line 12 mcookie: not found
failed in wairforX
tc@bocx:~$

But it seems to work in 32bit.

How is this supposed to work? I used TCE like 10 years ago and it was wonderful. This is... not working as wonderfully.

How can I get a 64it TCE install?
« Last Edit: August 31, 2018, 05:05:06 PM by Scorp1us »

Offline Scorp1us

  • WikiUser
  • *
  • Posts: 34
Re: Install instructions are bad
« Reply #1 on: August 31, 2018, 05:45:37 PM »
UPDATE:

in TinyCorePure64-8.0.iso,

the mcookie error is happening because /usr/bin/mcookie links to /tmp/tcloop/Xlibs/usr/bin/mcookie

but that is not a valid binary. the `file` command is missing, but when I run ldd on it I get:
$ldd mcookie
/mcookie: error while loading shared libraries: ./mcookie: wrong elf class: ELFCLASS32

Update, I also tried v9.0...

I'm on a Intel® Celeron® Processor G3900, so it is 64bit.


« Last Edit: August 31, 2018, 05:59:40 PM by Scorp1us »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10202
Re: Install instructions are bad
« Reply #2 on: August 31, 2018, 11:08:34 PM »
You need a separate set of extensions for CorePure64 - are you sure that you're not loading the 32-bit Xlibs extension instead of the 64-bit Xlibs extension?

Offline Scorp1us

  • WikiUser
  • *
  • Posts: 34
Re: Install instructions are bad
« Reply #3 on: September 01, 2018, 05:46:24 AM »
Absolutely. The TinyCorePure64 boot iso won't even start X.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10202
Re: Install instructions are bad
« Reply #4 on: September 01, 2018, 05:57:26 AM »
My point was that having used the 32-bit CorePlus to install the 64-bit CorePure64 - once you've booted CorePure64, you will need to ensure that you are using a /tce folder containing 64-bit extensions, which is usually done (for example) by having a /tce and a /tce64 folder.

The fact that ldd showed mcookie was 32-bit means that you have the 32-bit Xlibs extension loaded instead of the 64-bit Xlibs extension

Note also that TinyCorePure64 uses Xfbdev by default, but it might be easier to use Xorg-7.7

Offline polikuo

  • Sr. Member
  • ****
  • Posts: 353
Re: Install instructions are bad
« Reply #5 on: September 03, 2018, 03:32:07 AM »
The "Download From Internet" checkbox is a test function,
which downloads the latest kernel & initrd (vmlinuz{64}, core{pure64}.gz)

Since you cross install a different architecture, you'll need a different set of extensions.
The "Install Extensions from this TCE/CDE Directory" options is for those people, who have many different installations on their hard drive, to choose their local source.

BTW, most extensions in the iso are usually outdated, it's best to run "tce-update" right after an installation.

Offline Scorp1us

  • WikiUser
  • *
  • Posts: 34
Re: Install instructions are bad
« Reply #6 on: September 04, 2018, 08:22:13 AM »
Thanks all! I'm still at a loss though why the TinyCorePure64 iso image (that I downloaded to install with) won't boot into X. Version 8 and 9 didn't work so I am wondering what is going on?

Also, it is confusing to in one instance, select a tgz for the core, and then a directory for extensions. I think I'm thrown off by two things:
1) why the cde directory does not list files as confirmation that I'm in the right forectory or
2) whyt he cde directory is empty?

If someone could tell me how to get Pure64 working (burn XXX.iso, boot off it, installer boot menu item, etc) That'd be great. as it stands now the Pure64 iso doesn't go into X and crashes with the mcookie error. Since versions 8 and 9 do this, I'm left to assume something is wrong with either the images or my system?



Offline NewUser

  • Jr. Member
  • **
  • Posts: 65
Re: Install instructions are bad
« Reply #7 on: September 04, 2018, 08:28:44 PM »
When you boot CorePlus do you choose the waitusb=5 entry?

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 9879
Re: Install instructions are bad
« Reply #8 on: September 05, 2018, 02:08:11 AM »
If you have an installation on a disk or usb stick, the CD will find it and use it over the extensions on the CD.
The only barriers that can stop you are the ones you create yourself.

Offline Scorp1us

  • WikiUser
  • *
  • Posts: 34
Re: Install instructions are bad
« Reply #9 on: September 05, 2018, 07:05:21 AM »
When you boot CorePlus do you choose the waitusb=5 entry?

No, but per http://forum.tinycorelinux.net/index.php?topic=20984.0 I shouldn't have to?

Online coreplayer2

  • Hero Member
  • *****
  • Posts: 2759
Re: Install instructions are bad
« Reply #10 on: September 05, 2018, 08:39:07 AM »
Thanks all! I'm still at a loss though why the TinyCorePure64 iso image (that I downloaded to install with) won't boot into X. Version 8 and 9 didn't work so I am wondering what is going on?
More likely the issue stems from a misunderstanding and technique.
As explained earlier “TinyCorePure64” when booted from a CD will boot into Xfbdev not not Xvesa, if for some rare reason Xfbdev will not perform as expected try installing to a USB thumb drive and don’t forget to use the waitusb boot code or some variation of this boot code (see the Core Book fir more info).


Quote
Also, it is confusing to in one instance, select a tgz for the core, and then a directory for extensions. I think I'm thrown off by two things:
1) why the cde directory does not list files as confirmation that I'm in the right forectory or
2) why the cde directory is empty?
CDE directory is used only when booting from a CD.  TCE directory is used for all other installations.  If (as Curaga has suggested earlier) you have installed TinyCore to a USB be absolutely sure the CD player draw is empty when booting from another source like a USB, otherwise the extensions from the CD will be found and used regardless of a TCE directory installed on your USB thumb drive or HDD.

Quote
...as it stands now the Pure64 iso doesn't go into X and crashes with the mcookie error. Since versions 8 and 9 do this, I'm left to assume something is wrong with either the images or my system?
You know...   the system will never boot as expected if you continue to mix up x86 & x86_64 directories and/or files incorrectly.





Sent from my iPhone using Tapatalk

Online coreplayer2

  • Hero Member
  • *****
  • Posts: 2759
Re: Install instructions are bad
« Reply #11 on: September 05, 2018, 08:48:53 AM »
When you boot CorePlus do you choose the waitusb=5 entry?

No, but per http://forum.tinycorelinux.net/index.php?topic=20984.0 I shouldn't have to?
Please understand this, all USB installations should use the waitusb bootcode or some variation of this depending on your specific setup.   To be sure your system is booting using the correct TCE directory I would use the drive's UUID code and specify the TCE directory path as well.  see http://tinycorelinux.net/book.html for more..
« Last Edit: September 05, 2018, 08:51:58 AM by coreplayer2 »

Offline Scorp1us

  • WikiUser
  • *
  • Posts: 34
Re: Install instructions are bad
« Reply #12 on: September 05, 2018, 09:08:46 AM »
Thanks for that info.

So I was going to video my process, in that, I got a different result today than previously, but I'm still lost.

1. I used Etcher to write TinyCorePure64-9.0.iso to a USB stick
2. It actually booted into X GUI time. (previously I would get an mcookie error)
3. I loaded the GUI installer and installed TCE. (See Screenshots)
4. I rebooted off the HD.
5. I only got a command line.

Which still leaves me with the question: How do I get a 64bit version of TinyCoreLinux to boot into X after installation?

I *think* my problem with mcookie previously was because I originally installed a 32 bit version of TCL. What I did differently was that I formatted I for ubuntu for the weekend, and when I installed it this morning, it had no TCL directories? Could that be it? Why wouldn't the 64 installer overwrite the 32 stuff?



Online coreplayer2

  • Hero Member
  • *****
  • Posts: 2759
Re: Install instructions are bad
« Reply #13 on: September 05, 2018, 12:14:58 PM »
Thanks for that info.

So I was going to video my process, in that, I got a different result today than previously, but I'm still lost.
No need..  But allow me to remind you to please read the Corebook so you have a better understanding of Tinycore's features, I guarantee you'll learn a lot and find answers to most of your questions..  http://tinycorelinux.net/book.html   

reading the book might also help learning the appropriate nomenclature, just saying as it might be easier to help you when correct terms are used is all..
Quote
1. I used Etcher to write TinyCorePure64-9.0.iso to a USB stick
What is Etcher?
Quote
2. It actually booted into X GUI time. (previously I would get an mcookie error)
Of course..
Quote
3. I loaded the GUI installer and installed TCE. (See Screenshots)
By TCE I assume you mean tinycore x86_64.  Because TCE means Tiny Core Extensions
Quote
4. I rebooted off the HD.
HD. Do you mean new USB install ?
Quote
5. I only got a command line.

Quote
Which still leaves me with the question: How do I get a 64bit version of TinyCoreLinux to boot into X after installation?
First, show here output of
Code: [Select]
showbootcodes


Quote
I *think* my problem with mcookie previously was because I originally installed a 32 bit version of TCL. What I did differently was that I formatted I for ubuntu for the weekend, and when I installed it this morning, it had no TCL directories? Could that be it? Why wouldn't the 64 installer overwrite the 32 stuff?
This is common problem not using proper boot codes and having various installations present on same pc.  eg: booting USB install with a tinycore cd in the cd drive, etc. etc.


« Last Edit: September 05, 2018, 12:41:13 PM by coreplayer2 »

Offline polikuo

  • Sr. Member
  • ****
  • Posts: 353
Re: Install instructions are bad
« Reply #14 on: September 06, 2018, 01:20:01 AM »
Which still leaves me with the question: How do I get a 64bit version of TinyCoreLinux to boot into X after installation?
Quote
The latest version is 9.0
Downloading corepure64.gz
Downloading vmlinuz64
...
You choose to download the latest build from the internet.
By default, that means you'll get a KERNEL (vmlinuz64) and an INITRD (corepure64.gz).
You have to choose a path to a TCE/CDE directory if you want to copy the packages.
Otherwise you get a "base" installation.
Since you somehow set your CDE directory to /mnt/sdb/cde/..,
which actually points to /mnt/sdb/
The installer couldn't find any tczs there, thus ignoring the request.