WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Mouse pointer isn't shown while rdesktop connection to windows  (Read 332 times)

Offline Hampelmann91

  • WikiUser
  • *
  • Posts: 25
Hello,
if I set up remote desktop connection to windows then there is no mouse pointer to be seen.
It is there but not visible.
I can make mouse pointer visible by setting registry entry in windows (HKCU\Control Panel\Desktop\UserPreferencesMask Value 9E1E078012000000).

Is there a way to make mouse pointer visible without changing registry?   

Offline polikuo

  • Sr. Member
  • ****
  • Posts: 350
Re: Mouse pointer isn't shown while rdesktop connection to windows
« Reply #1 on: August 24, 2018, 01:17:41 AM »
Which TC / windows are you using ?
What's the full command you type ?

Those extensions are old and probably need to be recompiled.
You can try my old build script for x86_64 here.
BTW, you might wanna read the wiki:creating_extensions.

Since I don't have a working PC for testing at the moment.
You can takeover the management of the extension if you'd like to.

Offline Hampelmann91

  • WikiUser
  • *
  • Posts: 25
Re: Mouse pointer isn't shown while rdesktop connection to windows
« Reply #2 on: August 24, 2018, 04:29:39 AM »
Hello,
I use TC versions 6,7,8 and 9.
Windows version is Windows Server 2012 r2 terminal Server.
I use command
Code: [Select]
rdesktop -f serverIPBut I tried out other parameters with same result.

I will try to recompile it...
« Last Edit: August 24, 2018, 04:35:38 AM by Hampelmann91 »

Offline Hampelmann91

  • WikiUser
  • *
  • Posts: 25
Re: Mouse pointer isn't shown while rdesktop connection to windows
« Reply #3 on: August 27, 2018, 05:09:38 AM »
I successful recompiled from your script.
But I get error "Retrying with plain RDP", Core(error): locale_to_utf16().....
It's to difficult for me to solve that problem.

In meantime I find out problem doesn't exist with other Windows server 2012 r2 (I don't know why).
So I will set up all connections in future to new server.

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5935
Re: Mouse pointer isn't shown while rdesktop connection to windows
« Reply #4 on: August 27, 2018, 06:51:38 AM »
Hi Hampelmann91
Have you tried disabling the mouse shadow on your Server 2012 machine?

1. Go to  Control Panel  and open  Mouse Options.
2. Click on the  Pointers  tab.
3. Uncheck the  Enable Pointer Shadow  option at the bottom of that tab.
4. Click  Apply  and then  OK.

Offline polikuo

  • Sr. Member
  • ****
  • Posts: 350
Re: Mouse pointer isn't shown while rdesktop connection to windows
« Reply #5 on: August 27, 2018, 06:52:51 AM »
In meantime I find out problem doesn't exist with other Windows server 2012 r2 (I don't know why).

Perhaps it has something to do with "windows update".
I found this issue on FreeRDP, which is a similar program to rdesktop.
I also found a similar issue reported on rdesktop.
Since you've already recompiled with "./bootstrap && configure  && make", I guess the bug has not been solved by the developers yet.

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5935
Re: Mouse pointer isn't shown while rdesktop connection to windows
« Reply #6 on: August 27, 2018, 07:15:15 AM »
Hi polikuo
If you follow this link:
https://www.paperstreetonline.com/2015/04/09/server-2012-rdesktop-fix-disappearing-mouse-cursor-with-group-policy/

Skip down to the last 2 paragraphs above the  New Registry Properties  image. The author initially fixed it through the
control panel and then tracked down the effected registry key. Hampelmann91 already has a registry fix but wants a
fix that doesn't require editing the registry.

Offline polikuo

  • Sr. Member
  • ****
  • Posts: 350
Re: Mouse pointer isn't shown while rdesktop connection to windows
« Reply #7 on: August 27, 2018, 09:57:29 PM »
Hi, Rich
The author initially fixed it through the
control panel and then tracked down the effected registry key. Hampelmann91 already has a registry fix but wants a
fix that doesn't require editing the registry.

I know that, but I also state
Those extensions are old and probably need to be recompiled.
Most RDP softwares share the same libraries, the problem may has already been dealt with.

I successful recompiled from your script.
But I get error "Retrying with plain RDP", Core(error): locale_to_utf16().....
It's to difficult for me to solve that problem.

In meantime I find out problem doesn't exist with other Windows server 2012 r2 (I don't know why).
So I will set up all connections in future to new server.
After recompiling, Hampelmann91 stated that he got another error, "Retrying with plain RDP"
He also says that not every server has the new error.
The only reason I could think of is the windows updates differences between the servers.

Anyway
Hampelmann91
Have you tried out Rich's solution yet ? (with the old working extension)
I found the illustrations to uncheck the Enable Pointer Shadow checkbox.
To enable desktop background, try appending "-x b" to your commands.