WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: uk.kmap  (Read 526 times)

Offline core-user

  • Full Member
  • ***
  • Posts: 143
  • Linux since 1999
uk.kmap
« on: August 21, 2018, 09:56:33 AM »
I used to try to use TC 5 & 6, but gave up because there was no uk.kmap, the one in kmap.tcz is a copy of the us.kmap.

Having had another try with Tiny Core, (version 9), I find that the uk.kmap is still a copy of the us.kmap - after all these intervening years!?

Where can I get a proper uk.kmap that actually configures to a UK QWERTY keyboard?
AMD, ARM, & Intel.

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 9862
Re: uk.kmap
« Reply #1 on: August 21, 2018, 10:01:47 AM »
It was script-generated from the kbd package's keymap; the info file also says the last update was in 2010. So it's likely that whatever is wrong was/is also wrong in the kbd keymap.

The md5sums show they're not the exact same:
Code: [Select]
$ md5sum uk.kmap us.kmap
f382207ec4ae389e22b706ba5872bad5  uk.kmap
212fd6afbb3e68258ba3013adb268ad2  us.kmap

Patches welcome - if you have a better uk.kmap, please send it so we can put it in. Nobody else has complained about uk.kmap, this is the first time.

edit: Google says the uk and us keyboards mainly differ in " and @ being swapped. Testing this, they are indeed swapped, so it looks correct.
« Last Edit: August 21, 2018, 10:03:50 AM by curaga »
The only barriers that can stop you are the ones you create yourself.

Offline Nathan_SR

  • Jr. Member
  • **
  • Posts: 82
    • Quick-Save-Live
Re: uk.kmap
« Reply #2 on: August 21, 2018, 11:20:26 AM »
The kbd package's latest source releases are listed on this page : https://github.com/legionus/kbd/releases
and the corresponding Arch Linux Binary Package contains many uk. keymap files, as listed on this page : https://www.archlinux.org/packages/core/x86_64/kbd/files/  ( Please do Ctrl+F for uk. )

Hope this info serves some purpose.

Offline core-user

  • Full Member
  • ***
  • Posts: 143
  • Linux since 1999
Re: uk.kmap
« Reply #3 on: August 21, 2018, 01:32:01 PM »
I reported the same problem in these forums back when I was trying to use versions 5 & 6, several years ago.

I am very surprised that no one else has mentioned it, because i quit trying to use Tiny Core back then because of it.

I would have expected it to have been reported quite a few times in the intervening years.

The @ & " are reversed, # is where the correct pound sign should be, there are others, \ is where the # should be., etc

So, no one has a true uk.kmap available to download & install?

Edit: I've downloaded the source files to have a look to see if there might be something I may be able to do.
« Last Edit: August 21, 2018, 01:45:34 PM by core-user »
AMD, ARM, & Intel.

Offline Nathan_SR

  • Jr. Member
  • **
  • Posts: 82
    • Quick-Save-Live
Re: uk.kmap
« Reply #4 on: August 21, 2018, 07:18:49 PM »

Hi core-user,

I have extracted the UK Keymap files from the Arch Linux kbd Binary Package and enclosed it as a zip file here. Please check, if this works at your end.

Regards,

Nathan SR

Offline Nathan_SR

  • Jr. Member
  • **
  • Posts: 82
    • Quick-Save-Live
Re: uk.kmap
« Reply #5 on: August 21, 2018, 08:27:10 PM »

in continuation, of my previous post :

As specified in the FAQ, we can easily load our own latest custom keymap, as follows : ( please change the path/file name, to where you have extracted the zip file, from above )

--------------------------------------------------------------------------
My keyboard is not US. How to add a keymap?

The extension "kmaps.tcz" was created just for this. It includes all keymaps from the kbd package. Keymaps have to be changed in the console, not in X.

So, for a quick test, load the extension, exit to prompt, and type:

sudo loadkmap < /usr/share/kmap/qwerty/fi-latin9.kmap

To make this permanent, add the extension kmaps.tcz to your persistent tce directory, and then either use the bootcode kmap=qwerty/fi-latin9, or add the command to /opt/bootlocal.sh (missing the sudo, since bootlocal is executed as root):

loadkmap < /usr/share/kmap/qwerty/fi-latin9.kmap
--------------------------------------------------------------------------

Offline core-user

  • Full Member
  • ***
  • Posts: 143
  • Linux since 1999
Re: uk.kmap
« Reply #6 on: August 22, 2018, 01:17:39 AM »

Hi core-user,

I have extracted the UK Keymap files from the Arch Linux kbd Binary Package and enclosed it as a zip file here. Please check, if this works at your end.

Regards,

Nathan SR
Many thanks, have just downloaded it & will try it out ASAP.

Edit: Yesterday, I installed kmaps.tcz, & put it in /opt/bootlocal.sh (loadkmap < /usr/share/kmap/qwerty/uk.kmap).
Today, I just exited the GUI to a terminal, & ran sudo loadkmap < /usr/share/kmap/qwerty/uk.kmap - restarted the GUI, & it worked correctly in a terminal, so I shutdown, with backup enabled, then started up again. - Wrong keymap again. :(

I must be doing something wrong, then, as the correct keymap did install when i went to a VT & used sudo to install it - before shuting down & restarting.
« Last Edit: August 22, 2018, 01:41:32 AM by core-user »
AMD, ARM, & Intel.

Offline core-user

  • Full Member
  • ***
  • Posts: 143
  • Linux since 1999
Re: uk.kmap
« Reply #7 on: August 22, 2018, 01:52:46 AM »
So, I tried adding it into my .profile, & restarting, but that didn't work either. Seems the system just isn't loading the right kmap when it starts up.  :-\

Edit: Added sudo loadkmap < /usr/share/kmap/qwerty/uk.kmap to my .profile - & it booted up with the right keymap!

Dare I shut down & restart....... :)
« Last Edit: August 22, 2018, 02:01:20 AM by core-user »
AMD, ARM, & Intel.

Offline core-user

  • Full Member
  • ***
  • Posts: 143
  • Linux since 1999
Re: uk.kmap
« Reply #8 on: August 22, 2018, 02:12:29 AM »
Well, almost perfect, I get a ? where I should get a pound sign, I can live with that.  ;D

So, for any other Brit having problems this seems to be the solution for us.  ::)

~~~~~~
Maybe one of the developers wants to investigate this problem(?).
~~~~~~

Thanks for your help, a good nights sleep seems to have let the brain mull this over.  ;)
AMD, ARM, & Intel.

Offline core-user

  • Full Member
  • ***
  • Posts: 143
  • Linux since 1999
Re: uk.kmap
« Reply #9 on: August 22, 2018, 02:35:30 AM »
Sorry, forgot to say - add it to the line before startx in your .profile.  8)
AMD, ARM, & Intel.

Offline Nathan_SR

  • Jr. Member
  • **
  • Posts: 82
    • Quick-Save-Live
Re: uk.kmap
« Reply #10 on: August 22, 2018, 04:19:35 AM »

Hi core-user,

Your efforts will certainly help others too, who are viewing this thread. Thanks.

Just out of curiosity :

1. Was the new keymap, that I enclosed in the zip file, any better than the earlier one ?

2. For pound symbol, solution given on the internet:

---------------------------------------------------------------------------------------
I managed to fix this same problem by setting the LC_CTYPE variable as follows:

echo $LC_CTYPE

export LC_CTYPE=en_GB.ISO8859-15

This was previously set to en_US.UTF-8

If this does not work to get the pound symbol, then try:

export LC_CTYPE=en_GB.UTF-8
---------------------------------------------------------------------------------------

3. While I was searching for a keymap solution on the net, I came across this discussion, which talks about Swapping Keys easily : https://superuser.com/questions/290115/how-to-change-console-keymap-in-linux

Will this help you to get back the Pound sign and also share the improved keymap file with us ?

Regards,

Nathan SR
« Last Edit: August 22, 2018, 04:53:08 AM by Nathan_SR »

aus9

  • Guest
Re: uk.kmap
« Reply #11 on: August 22, 2018, 06:00:47 AM »
On 64 bit XFCE, with the loading of xfce4-xkb-plugin and after reading the info to set up
your compose key (and optionally your layout key) you could try

compose-key (then) l (then)   (minus symbol)........for me I changed compose key to right alt

so its right alt l -

ref
https://www.x.org/releases/X11R7.7/doc/libX11/i18n/compose/en_US.UTF-8.html

this outputs the pound symbol for me on an US keyboard layout

and I can display it in FF or leafpad

£ 

2) I just noticed that the locale for that kb package provides
en_GB let me see if that makes a diff

ahh £ is above the 3....but now I have loaded the locale. Will have to reboot to see if I need that locale or not


EDIT
reboot without loading the locale package.....
swap the layout....as per the info......£ works
« Last Edit: August 22, 2018, 06:17:18 AM by aus9 »

Offline core-user

  • Full Member
  • ***
  • Posts: 143
  • Linux since 1999
Re: uk.kmap
« Reply #12 on: August 22, 2018, 06:30:15 AM »
OK, I've been experimenting this morning, sorry I hadn't seen the above posts until now.

I was experimenting with the already installed kmap file, so, no, sorry, I haven't tried your one.

Whilst it was working from my .profile OK, if no one else has reported problems, it had to be something I wasn't doing right - & I found the proper solution - setting kmap=uk in the boot loader line was wrong, it should be kmap=qwerty/uk. Now it works from the off. :)

(Seemed strange that the /opt/bootlocal.sh entry didn't work though, maybe it does need sudo in the kmap line.)

Anyway, I'm going to have another read of the above to see if I can indeed get my pound sign.  8)
AMD, ARM, & Intel.

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5935
Re: uk.kmap
« Reply #13 on: August 22, 2018, 07:04:51 AM »
Hi core-user
... (Seemed strange that the /opt/bootlocal.sh entry didn't work though, maybe it does need sudo in the kmap line.) ...
Since  /opt/bootlocal.sh  runs as  root  you don't need  sudo  there. Maybe it's because it's running asynchronously in the
background. You could try putting the command in  /opt/bootsync.sh  before it calls  /opt/bootlocal.sh.

Offline core-user

  • Full Member
  • ***
  • Posts: 143
  • Linux since 1999
Re: uk.kmap
« Reply #14 on: August 22, 2018, 07:18:37 AM »
Thanks Rich, it was just a thought, I have my keyboard set up OK from the boot loader line in extlinux.

@Nathan_SR - Just had a go at loading the keymap out of your .zip file, but loadkmap doesn't recognise its format.

As I am set up OK, & I've also found an alternative way, to use the supplied uk.kmap, I'll call it a day on the experimentation.  ;)

Thanks for your help & your time.

I need to go & re read my Into The Core book again, to get things back into my brain.

I've already remastered TC for my other laptop, installed nicely, just had this little problem, & we found out that it was down to me - again thanks for your time.  8)
AMD, ARM, & Intel.