WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Getting Huawei E3131 G4 Mobile Modem working with TinyCore x86  (Read 151 times)

Offline cybervegan

  • WikiUser
  • *
  • Posts: 2
I've just got hold of one of these beasties for a project, and I'm now trying to get it running. Tested OK with Debian, but I want to use it on an old laptop without a hard disk for this project, so TinyCore is the obvious choice.

I've followed through several threads about getting it working with PiCore, but I just can't seem to get it to change to USB Ethernet mode.

lsusb reports the device as:

Quote
12d1:1f01 Huawei Technologies Co., Ltd. E353/E3131 (Mass storage mode)

On Debian, when running, it is reported by lsusb as:

Quote
12d1:14db Huawei Technologies Co., Ltd. E353/E3131
12d1:1f1e Huawei Technologies Co., Ltd.

If i understand correctly, i need to use usb_modeswitch to change the mode from "Installer" mode to Ethernet mode. I've tried various permutations fo this command (transcribed by hand as I haven't got internet access on the project machine).

Quote
usb_modeswitch -v 12d1 -p 1f01 -V 12d1 -P 1442 -M "55534243123456780000000000000011062000000100000000000000000000"

Substituting "-P 1442" with: various numbers gleaned from google, including the sub-id's found on Debian (14db, 1f1e), to no avail: lsusb still lists the device as 12d1:1f01, and no /dev/ttyUSB devices are showing up.

I've also tried various parameters for -M, also gleaned from google. Still no beans.

As I understand it, once it's in the right mode, I should be able to run "ifconfig eth1" and get an IP, then I should be able to communicate with the modem via curl on 192.168.1.1 to send and receive SMS messages, as well as normal networking.

Any hints? Have I missed something obvious (quite likely) or do I need to provide more detail?

Thanks in advance.

Offline cybervegan

  • WikiUser
  • *
  • Posts: 2
Re: Getting Huawei E3131 G4 Mobile Modem working with TinyCore x86
« Reply #1 on: August 16, 2018, 01:15:14 PM »
Just like it - "just one more google search" after I posted, and I found this:

newbielink:https://etherarp.net/building-a-sms-gateway-from-a-huawei-usb-modem/ [nonactive]

After executing:

Quote
usb_modeswitch -v 12d1 -p 1f01 "55534243123456780000000000000011062000000101000100000000000000"

...the modem is now showing up in lsusb as 12d1:14db so this *might* mean it's in Ethernet mode now.

After that, I was able to bring up the ethernet interface with:

Code: newbielink:javascript:void(0); [nonactive]
sudo ifconfig eth1 192.168.1.2 netmask 255.255.255.252 broadcast 192.168.1.3 up
And now I can communicate with the modem to send SMS messages!

Hope this might help anyone who is looking to do the same. I haven't yet worked out how to send/receive network packets over the dongle (that's for another day!)