WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: 64 bit wterm 256color fail so not submitting  (Read 145 times)

aus9

  • Guest
64 bit wterm 256color fail so not submitting
« on: July 26, 2018, 07:11:42 PM »
Hi
I have attempted to post here rather than in the official channels for a number of reasons. One, I may have mislead Juanito into thinking I might have a new terminal purpose built for Wayland ....as a running dep of Sway....but I am now not going to submit it as it fails the 256 color (colour) test.

so for anyone....there is a perl script I found on the net that tests 256color here
http://www.robmeerman.co.uk/_media/unix/256colors2.pl

then load perl5 and your target terminal and inside that terminal run
Code: [Select]
perl 256colors2.pl
and he has a web page showing good and poor results as
http://www.robmeerman.co.uk/unix/256colours

################################################

On Wayland I did above test for weston-terminal and it passes.

On Sway, wterm show visual glitches. wterm is a kind of fork of st that runs on X while wterm runs on Wayland.

no need to click on image but it shows its not a full pass.  Also I cheated and used a hand held camera to take the screenshot as I don't yet have a good screenie app for it working.

https://imgur.com/a/379MXev

Reason 2.....someone may know how to build 256 color terminals and might help?

thanks for reading

ahh forgot to mention.....urxvt on Sway passes this test so it will be the dep of Sway

« Last Edit: July 26, 2018, 07:14:36 PM by aus9 »