WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Screen rotate - can't deal  (Read 3169 times)

Offline Pats

  • Sr. Member
  • ****
  • Posts: 266
Re: Screen rotate - can't deal
« Reply #75 on: July 05, 2018, 06:39:30 PM »
In corebook.pdf , on page 3 - 2nd para , why other (Rest)  contributors are "Rosted"  ? :)

 Hope it a typo and already known to the author !

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5993
Re: Screen rotate - can't deal
« Reply #76 on: July 05, 2018, 07:01:41 PM »
Hi Pats
Is this the paragraph you are referring to?
Quote
I would like to thank Andyj, Coreplayer2 and Richard A. Rost for
helpful comments and suggestions.
The section I highlighted in bold is my name.

Offline Pats

  • Sr. Member
  • ****
  • Posts: 266
Re: Screen rotate - can't deal
« Reply #77 on: July 05, 2018, 08:13:08 PM »
Quote
The section I highlighted in bold is my name.


Hi Rich - aka - Rost ...Yah , I was refering same , and sorry I was NOT knowing your name , 'Cause since from many years , I know you as "Rich" !
If the said line would have been in next para ... or like "And Rost for .... " , then it would have been better !

Thanks for clearing confusion !
Sorry for off-topic discusion !
« Last Edit: July 05, 2018, 08:20:30 PM by Pats »

Offline Pats

  • Sr. Member
  • ****
  • Posts: 266
Re: Screen rotate - can't deal
« Reply #78 on: July 05, 2018, 08:26:40 PM »
... ~ snip ~ ... Yesterday evening it worked, and today I did not manage to turn the screen even once.
I do not remember that I did anything yesterday other than today.

Horribly annoying.


If  you were successful to rotate the screen prvsly , then I am sure , by trying hard with diffetent combinations of the command , you would be successful again.
... Best Luck !

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5993
Re: Screen rotate - can't deal
« Reply #79 on: July 05, 2018, 08:27:40 PM »
Hi Pats
Rost  is my last name and  A.  is my middle initial.

Offline Pats

  • Sr. Member
  • ****
  • Posts: 266
Re: Screen rotate - can't deal
« Reply #80 on: July 05, 2018, 09:29:10 PM »
Hi Rich, Many thanks to you and all others including Curaga for your great contribution to  a great book like "Corebook" !
... Actually I was silently wishing for such a book on Tinycore , 2 years before it's actuall launch !
Thanks again !

Offline Johnson9

  • WikiUser
  • *
  • Posts: 48
Re: Screen rotate - can't deal
« Reply #81 on: July 17, 2018, 05:30:03 AM »
Hi,

(...)If  you were successful to rotate the screen prvsly , then I am sure , by trying hard with diffetent combinations of the command , you would be successful again.
... Best Luck !
Finally I found the combinations of the commands. Here it is

Install clear system,
Quote
Shutdown -> Exit to Prompt
Code: [Select]
tce-load -wi Xorg-7.7 graphics-KERNEL xf86-video-geode
next
Code: [Select]
filetool.sh -b
next
Code: [Select]
sudo restart
After restart computer show error
Quote
Failed in WaitforX

so I put
Code: [Select]
Xorg -nolisten tcp

This command shows error about msr

The error was that it couldn't open MSR. Try "sudo modprobe msr" before starting X.

so next I'm entering the command

Code: [Select]
sudo modprobe msr as curaga advised

and
Code: [Select]
startx
When I tried
Code: [Select]
Xorg -nolisten tcp after
Code: [Select]
sudo modprobe msr the screen go black and nothing happen.

After
Code: [Select]
startx the desktop loaded and in terminal I put
Code: [Select]
xrandr -o left and it works.

I will be grateful for advice on what to do now to achieve my destination.

I been fighting with this for a few days and I do not have any ideas.
From what I've tried, nothing works.
Best regards

« Last Edit: July 17, 2018, 05:38:53 AM by Johnson9 »

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10189
Re: Screen rotate - can't deal
« Reply #82 on: July 17, 2018, 06:24:18 AM »
..so it appears you need to:

* set the following "onboot": Xorg-7.7 graphics-KERNEL xf86-video-geode flwm aterm wbar
* add "sudo modprobe msr" to bootlocal.sh
* add the text below to /usr/local/share/X11/xorg.conf.d/10-rotate-left.conf

Section "Monitor"
   Identifier "<defaultmonitor>"
   Option "Rotate" "left"
EndSection

* make a backup

Offline Johnson9

  • WikiUser
  • *
  • Posts: 48
Re: Screen rotate - can't deal
« Reply #83 on: July 17, 2018, 07:42:21 AM »
Tomorrow morning i will try that and I will let you know about effects.

Offline Pats

  • Sr. Member
  • ****
  • Posts: 266
Re: Screen rotate - can't deal
« Reply #84 on: July 17, 2018, 07:50:05 PM »
Quote
....I will be grateful for advice on what to do now to achieve my destination.


From your message , following steps seems to be working for you :
1) Install TC fresh .
2) tce-load -wi Xorg-7.7 graphics-KERNEL xf86-video-geode
3) filetool.sh -b
4) sudo modprobe msr
5) Xorg -nolisten tcp
6) Exit to command prompt : startx
7) In DT terminal:  xrandr -o left

Juanito has alteady shown , how to make changes persistent for every boot with backup . He has already helped by providing *geode* extension.

 By the way, you have to create a .conf file yourself , if not exists already !

Offline Johnson9

  • WikiUser
  • *
  • Posts: 48
Re: Screen rotate - can't deal
« Reply #85 on: July 18, 2018, 01:39:33 AM »
..so it appears you need to:

* set the following "onboot": Xorg-7.7 graphics-KERNEL xf86-video-geode flwm aterm wbar
* add "sudo modprobe msr" to bootlocal.sh
* add the text below to /usr/local/share/X11/xorg.conf.d/10-rotate-left.conf

Section "Monitor"
   Identifier "<defaultmonitor>"
   Option "Rotate" "left"
EndSection

* make a backup

I added entry "usr" in file ".filetool.lst" in opt folder and after that created file named "10-rotate-left.conf" in /usr/local/share/X11/xorg.conf.d/ and restarted the computer to test if file was backuped.

I had to created the "10-rotate-left.conf" file because it not exist.

When I maded sure that the file was backuped I added this text

Quote
Section "Monitor"
   Identifier "<defaultmonitor>"
   Option "Rotate" "left"
EndSection

to it and I restarted the computer - after restarted the result was only black screen.

Maybe in file "10-rotate-left.conf" I need to added something more?

I will try make this one more time but this time I will start from installed a fresh system.


Quote
....I will be grateful for advice on what to do now to achieve my destination.


From your message , following steps seems to be working for you :
1) Install TC fresh .
2) tce-load -wi Xorg-7.7 graphics-KERNEL xf86-video-geode
3) filetool.sh -b
4) sudo modprobe msr
5) Xorg -nolisten tcp
6) Exit to command prompt : startx
7) In DT terminal:  xrandr -o left

Juanito has alteady shown , how to make changes persistent for every boot with backup . He has already helped by providing *geode* extension.

 By the way, you have to create a .conf file yourself , if not exists already !

Close but it is a slight difference

1) YES
2) YES
3) YES
4) YES
5) NO - when I tried "Xorg -nolisten tcp" then the screen go black. 
In this step i entry command "startx"
6) NO - I exit to prompt after install system and steps (2,3,4,5) I type in prompt
7) If "DT terminal" is terminal in graphics windows then YES, because after startx the desktop loads



I am very grateful to all of you for help and without you I would not have been able to go as far as I am now
« Last Edit: July 18, 2018, 01:44:04 AM by Johnson9 »

Offline Pats

  • Sr. Member
  • ****
  • Posts: 266
Re: Screen rotate - can't deal
« Reply #86 on: July 18, 2018, 03:30:24 AM »
Quote
...5) NO - when I tried "Xorg -nolisten tcp" then the screen go black. 


Just for the knowledge  - if I am not wrong :

"Exit to Prompt", is achieved , either via Exit menu or via CTRL+ALT+BACKSPACE key combination .
... Whether this key combo works in your black screen or not , I dont know !

But overall , good going !

Offline Pats

  • Sr. Member
  • ****
  • Posts: 266
Re: Screen rotate - can't deal
« Reply #87 on: July 18, 2018, 04:14:46 AM »
Forgot to add : Ctrl-Alt-Backspace may result in data loss , since it returns to login prompt. Useful ifX-Server freezes and if there is no other alternative.

.. ctrl-alt-delete combo is the preferred mechanism, as unlike ctrl-alt-backspace they are designed to shut down apps nicely and give the user several options on how to logout (hibernate, suspend, etc.)

Just for info !

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5993
Re: Screen rotate - can't deal
« Reply #88 on: July 18, 2018, 04:36:57 AM »
Hi Johnson9
I added entry "usr" in file ".filetool.lst" in opt folder and after that created file named "10-rotate-left.conf" in /usr/local/share/X11/xorg.conf.d/ and restarted the computer to test if file was backuped.

I had to created the "10-rotate-left.conf" file because it not exist.

When I maded sure that the file was backuped I added this text

Quote
Section "Monitor"
   Identifier "<defaultmonitor>"
   Option "Rotate" "left"
EndSection

to it and I restarted the computer - after restarted the result was only black screen. ...
NO NO NO. You do not want to backup the entire  /usr  directory, ever.  The  usr  line you have in  filetool.lst  should be:
Code: [Select]
usr/local/share/X11/xorg.conf.d/10-rotate-left.conf

Offline Johnson9

  • WikiUser
  • *
  • Posts: 48
Re: Screen rotate - can't deal
« Reply #89 on: July 18, 2018, 06:15:11 AM »
Quote
...5) NO - when I tried "Xorg -nolisten tcp" then the screen go black. 


Just for the knowledge  - if I am not wrong :

"Exit to Prompt", is achieved , either via Exit menu or via CTRL+ALT+BACKSPACE key combination .
... Whether this key combo works in your black screen or not , I dont know !

But overall , good going !


I'm not sure if I understand correctly, so I took a photo https://imgur.com/a/dZ7xhoY - https://postimg.cc/image/poq6xdif1/

I don't used keyboard shortcuts because I do not know them - I have too little experience with linux



NO NO NO. You do not want to backup the entire  /usr  directory, ever.  The  usr  line you have in  filetool.lst  should be:
Code: [Select]
usr/local/share/X11/xorg.conf.d/10-rotate-left.conf

I've made a second attempt - of course this time I have followed your attention and add to file ".filetool.lst" full path
Code: [Select]
usr/local/share/X11/xorg.conf.d/10-rotate-left.conf

After added text
Quote
Section "Monitor"
   Identifier "<defaultmonitor>"
   Option "Rotate" "left"
EndSection

to file "10-rotate-left.conf"

and restarted the computer - screen go black as before.

https://imgur.com/a/N7FspZu - https://postimg.cc/gallery/liq4ihzi/

Maybe I must add something more to file "10-rotate-left.conf" ?

Video of starting computer after added text to file "10-rotate-left.conf"

https://www.dropbox.com/s/njklzmlhi4u1bm6/20180718_152220.mp4?dl=0
https://streamable.com/6zniw
https://ufile.io/tt989


Before I added text to file "10-rotate-left.conf" but after added
* add "sudo modprobe msr" to bootlocal.sh

and restart the computer, desktop environment loads perfectly and from terminal with command "xrandr -o left" I can rotate screen
« Last Edit: July 18, 2018, 06:34:29 AM by Johnson9 »