WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Vivaldi 1.15 doesn't work with TC 9.0  (Read 433 times)

Offline neonix

  • Jr. Member
  • **
  • Posts: 65
Vivaldi 1.15 doesn't work with TC 9.0
« on: June 20, 2018, 08:06:51 PM »
After installing Vivaldi 1.15 in TC 9.0 x86 using this:

tce-load -iw libXcursor
tce-load -iw atk
tce-load -iw at-spi2-atk
tce-load -iw libXcomposite
tce-load -iw libXtst
tce-load -iw libcups
tce-load -iw nss
tce-load -iw gtk3
tce-load -iw libXss
tce-load -iw gst-ffmpeg.tcz
tce-load -iw ffmpeg.tcz

wget http://downloads.vivaldi.com/stable/vivaldi-stable_1.15.1147.36-1_i386.deb

I get this:
tc@box:/opt/vivaldi$ ./vivaldi-bin
Xlib:  extension "XInputExtension" missing on display ":0.0".
Fontconfig error: Cannot load default config file
Xlib:  extension "XInputExtension" missing on display ":0.0".
Xlib:  extension "XInputExtension" missing on display ":0.0".
[14114:14154:0621/045853.203073:ERROR:bus.cc(394)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
Xlib:  extension "XInputExtension" missing on display ":0.0".
[14152:14152:0621/045853.285613:ERROR:gl_surface_glx.cc(423)] glxQueryVersion failed
[14152:14152:0621/045853.285841:ERROR:gl_initializer_x11.cc(157)] GLSurfaceGLX::InitializeOneOff failed.
[14152:14152:0621/045853.294682:ERROR:viz_main_impl.cc(197)] Exiting GPU process due to errors during initialization
Trace/breakpoint trap
tc@box:/opt/vivaldi$ [1:1:0100/000000.459348:FATAL:zygote_linux.cc(465)] Failed to synchronise with parent zygote process
Xlib:  extension "XInputExtension" missing on display ":0.0".
[14168:14168:0621/045853.576492:ERROR:gl_surface_glx.cc(423)] glxQueryVersion failed
[14168:14168:0621/045853.576596:ERROR:gl_initializer_x11.cc(157)] GLSurfaceGLX::InitializeOneOff failed.

Offline polikuo

  • Sr. Member
  • ****
  • Posts: 352
Re: Vivaldi 1.15 doesn't work with TC 9.0
« Reply #1 on: June 20, 2018, 10:47:54 PM »
On TC64
These dependencies are enough for vivaldi-stable-1.15.1147.47-1.x86_64.rpm
Code: [Select]
bash.tcz
gtk3.tcz
libXss.tcz
libXtst.tcz
libasound.tcz
libcups.tcz
nss.tcz

Xlib:  extension "XInputExtension" missing on display ":0.0".

What Xserver did you use ?

Offline neonix

  • Jr. Member
  • **
  • Posts: 65
Re: Vivaldi 1.15 doesn't work with TC 9.0
« Reply #2 on: June 21, 2018, 08:11:40 AM »
On TC64
These dependencies are enough for vivaldi-stable-1.15.1147.47-1.x86_64.rpm
Code: [Select]
bash.tcz
gtk3.tcz
libXss.tcz
libXtst.tcz
libasound.tcz
libcups.tcz
nss.tcz

Xlib:  extension "XInputExtension" missing on display ":0.0".

What Xserver did you use ?
Xfbdev.tcz but in TC 8.0 x86 everything works perfect with the same configuration and extensions.

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 9874
Re: Vivaldi 1.15 doesn't work with TC 9.0
« Reply #3 on: June 21, 2018, 10:25:38 AM »
Please double-check your 8.0 install. If Vivaldi requires OpenGL, it's not possible for it to have worked without Xorg.
The only barriers that can stop you are the ones you create yourself.

Offline neonix

  • Jr. Member
  • **
  • Posts: 65
Re: Vivaldi 1.15 doesn't work with TC 9.0
« Reply #4 on: June 22, 2018, 02:08:42 AM »
Please double-check your 8.0 install. If Vivaldi requires OpenGL, it's not possible for it to have worked without Xorg.

I installed Xorg, but it doesn't help. I tried to google this "Fontconfig error: Cannot load default config file" and it seems that in TC 9.0 x86 Vivaldi browser needs symlink from /usr/local/etc/fonts/ to /etc/fonts/ but in TC 8.0 x86, it doesn't require /usr/local/etc/fonts/fonts.conf at all.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10164
Re: Vivaldi 1.15 doesn't work with TC 9.0
« Reply #5 on: June 22, 2018, 02:58:05 AM »
Both Xlibs and Xprogs have been refactored recently, which might explain the font issue with the vivaldi rpm going from 8.x to 9.x