WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: rdesktop needs libXrandr.so.2  (Read 171 times)

Offline Hampelmann91

  • WikiUser
  • *
  • Posts: 22
rdesktop needs libXrandr.so.2
« on: April 25, 2018, 12:12:48 AM »
Hello,
when starting rdesktop on Tinycore 9.0 I get error message:
"error while loading shared libraries: libXrandr.so.2 cannot open shared object file: No such file or directory".
Is there a way to solve this problem?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9960
Re: rdesktop needs libXrandr.so.2
« Reply #1 on: April 25, 2018, 01:37:52 AM »
I believe the extension assumes you would have Xorg-7.7 loaded, in which case libXrandr would be present.

fyi, you can use the apps gui "provides" function to see which extension provides a specific file

dep file adjusted - thanks for reporting this.
« Last Edit: April 25, 2018, 02:03:50 AM by Juanito »

Offline Hampelmann91

  • WikiUser
  • *
  • Posts: 22
Re: rdesktop needs libXrandr.so.2
« Reply #2 on: April 25, 2018, 02:44:03 AM »
Yes,
Xorg-7.7 solve this problem.
Thank you!  :)