WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Where did my screenshot go?  (Read 202 times)

Offline PDP-8

  • Full Member
  • ***
  • Posts: 242
Where did my screenshot go?
« on: April 09, 2018, 07:11:11 PM »
Has anyone lost a screenshot using the Applications > screenshot menu?

(system - dCorePlus-Stretch64)

I've looked in my home directory, and scrounged the disk only to find some nice TC logos in png format, but the current screenshot seems to have gone awol.

I could have sworn I heard a tiny little scream when the screenshot file passed the event horizon of /dev/null. :)
cat -v Considered Harmful  -- Rob Pike

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5673
Re: Where did my screenshot go?
« Reply #1 on: April 09, 2018, 07:27:01 PM »
Hi PDP-8
Try running  screenshot.sh  from a terminal and see if any errors pop up.

Offline PDP-8

  • Full Member
  • ***
  • Posts: 242
Re: Where did my screenshot go?
« Reply #2 on: April 09, 2018, 09:41:15 PM »
Yessir - it's pretty simple.  I groped around /tmp/wm_errors and saw the error:

imlib2_grab: not found

Same error as running screenshot.sh

Not a showstopper, but would be nice to have.
cat -v Considered Harmful  -- Rob Pike

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5673
Re: Where did my screenshot go?
« Reply #3 on: April 09, 2018, 09:47:34 PM »
Hi PDP-8
I'm not sure how it works in dCore, but under Tinycore you would need  imlib2-bin.tcz.

Offline PDP-8

  • Full Member
  • ***
  • Posts: 242
Re: Where did my screenshot go?
« Reply #4 on: April 09, 2018, 11:24:25 PM »
I'm pretty sure I can just do an sce-import of imlib2 perhaps.  Or ask Jason nicely to bake it in for the future...
cat -v Considered Harmful  -- Rob Pike

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 2608
Re: Where did my screenshot go?
« Reply #5 on: April 09, 2018, 11:45:58 PM »
Hey PDP-8    Anytime you get a message like this
Code: [Select]
imlib2_grab: not found
You'll find it useful to search within the repo using APPS and it's "Provides" search function to find missing libraries.  If found then APPS will list the extension to install and resolve the situation.
If you'd rather use the command line then
Code: [Select]
tce-ab Then P (provides) when prompted

Good luck


Offline PDP-8

  • Full Member
  • ***
  • Posts: 242
Re: Where did my screenshot go?
« Reply #6 on: April 09, 2018, 11:57:11 PM »
For sure, that's awesome on TC!

But here, I just tried sce-importing both libimlib2 and libimlib2-dev, and dCore's screenshot wasn't happy.

Small potatoes for now. :)
cat -v Considered Harmful  -- Rob Pike

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 2608
Re: Where did my screenshot go?
« Reply #7 on: April 10, 2018, 01:02:33 AM »
For sure, that's awesome on TC!

But here, I just tried sce-importing both libimlib2 and libimlib2-dev, and dCore's screenshot wasn't happy.

Small potatoes for now. :)
Sure I don't know about dcore but the extension in tc is " imlib2-bin.tcz "  not libimlib2 or libimlib2-dev

;p

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9459
Re: Where did my screenshot go?
« Reply #8 on: April 10, 2018, 02:58:31 AM »
The x86 version of Xprogs has imlib2_grab in it, x86_64 does not.  I will put it in.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9459
Re: Where did my screenshot go?
« Reply #9 on: April 10, 2018, 03:18:56 AM »
Updated Xprogs posted, screenshot should work now.

Offline PDP-8

  • Full Member
  • ***
  • Posts: 242
Re: Where did my screenshot go?
« Reply #10 on: April 10, 2018, 01:21:10 PM »
Thanks Jason!  Works great now.

Believe it or not, I'll do a screenshot of some forum / Wiki items and pipe that into Dillo for later reference.  Crude, but effective - like me. :)

Seriously, tnx...
cat -v Considered Harmful  -- Rob Pike