WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Xvesa - disable virtual console switching?  (Read 1781 times)

Offline Alatun

  • WikiUser
  • *
  • Posts: 41
Xvesa - disable virtual console switching?
« on: September 02, 2015, 01:26:00 AM »
I've built a thin client boot environment using TC to start rdesktop and automatically connect to a Windows 2008 TS. This setup will be used with a dozen computers to do computer based training. To prevent participants doing bad things I'd like to get some kind of kiosk mode.

I already configured Xvesa with "-nozap" to prevent killing the X server, but it is still possible to do "ALT+F1" to switch to the first text console and do a "CTRL-C" to get to the linux shell. Any ideas how to prevent console switching? (I want to stay with Xvesa, because of the package size). I already searched the online docs, but was unsuccessful so far.

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 9862
Re: Xvesa - disable virtual console switching?
« Reply #1 on: September 02, 2015, 01:34:10 AM »
There's no support for that in tinyx currently, patches welcome. An alternative way is to grab the keys (alt, or all F-keys), which is done by screensavers, but then you can't use those keys in your other apps.
The only barriers that can stop you are the ones you create yourself.

Offline Alatun

  • WikiUser
  • *
  • Posts: 41
Re: Xvesa - disable virtual console switching?
« Reply #2 on: September 02, 2015, 02:01:53 AM »
Ok. Hard coded keyboard bindings .... not good.

But thanks for the info.

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5936
Re: Xvesa - disable virtual console switching?
« Reply #3 on: September 02, 2015, 09:35:12 AM »
Hi Alatun
Don't know if this would work, but what if you commented out the  tty1  line in  /etc/inittab? You would probably need to remaster
to make that change.

Offline hiro

  • Hero Member
  • *****
  • Posts: 1096
Re: Xvesa - disable virtual console switching?
« Reply #4 on: September 02, 2015, 10:09:53 AM »
you could exit after running Xvesa in the background. then people can switch to vts but can't ctrl-c.

Offline Alatun

  • WikiUser
  • *
  • Posts: 41
Re: Xvesa - disable virtual console switching?
« Reply #5 on: September 03, 2015, 03:00:24 AM »
Thanks for you input guys.

@Rich - I also was thinking about this solution, but removing tty1 from inittab would disable any possibility for console access. This should still be possible for diagnosis.

@hiro - I will try this. This looks like a simple solution for my problem.

Offline brunok

  • WikiUser
  • *
  • Posts: 28
Re: Xvesa - disable virtual console switching?
« Reply #6 on: April 04, 2018, 12:08:45 PM »
Hi!

Any solution for this?

Offline brunok

  • WikiUser
  • *
  • Posts: 28
Re: Xvesa - disable virtual console switching?
« Reply #7 on: April 04, 2018, 01:31:32 PM »
Already disabled tty1 on /etc/inittab, but, hangs on boot.

-nozap option running fine for CTRL + ALT + BACKSPACE and CTRL + ALT + DEL, but i need to disable CTRL + ALT + F1 too.

Xorg is not an option.

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5936
Re: Xvesa - disable virtual console switching?
« Reply #8 on: April 04, 2018, 09:40:07 PM »
Hi brunok
Install  Xlibs.tcz.  Then enter:
Code: [Select]
xmodmap -e "keycode  67 = F1 XF86Switch_VT_2 F1 XF86Switch_VT_2"Now hit:
Code: [Select]
CTRL + ALT + F1and let me know what happens.

Offline brunok

  • WikiUser
  • *
  • Posts: 28
Re: Xvesa - disable virtual console switching?
« Reply #9 on: April 05, 2018, 07:03:37 AM »
Hi Rich,

Not solved. Same issue.

Changes are made, but not solve.


Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5936
Re: Xvesa - disable virtual console switching?
« Reply #10 on: April 05, 2018, 07:08:52 AM »
Hi brunok
OK, execute:
Code: [Select]
xmodmap -pkeand post the lines for keycodes 67 and 68.

Offline brunok

  • WikiUser
  • *
  • Posts: 28
Re: Xvesa - disable virtual console switching?
« Reply #11 on: April 05, 2018, 07:14:04 AM »
Done. See attach.

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5936
Re: Xvesa - disable virtual console switching?
« Reply #12 on: April 05, 2018, 07:16:53 AM »
Hi brunok
See if this works:
Code: [Select]
xmodmap -e "keycode  67 = F2 F12"

Offline brunok

  • WikiUser
  • *
  • Posts: 28
Re: Xvesa - disable virtual console switching?
« Reply #13 on: April 05, 2018, 07:30:51 AM »
Hi brunok
See if this works:
Code: [Select]
xmodmap -e "keycode  67 = F2 F12"


YES!  ;D

It's awesome, my custom Thinclient's SO (TinyCore) are finished (fast and secure)!  8) 8) 8)

Thanks!

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5936
Re: Xvesa - disable virtual console switching?
« Reply #14 on: April 05, 2018, 07:36:18 AM »
Hi brunok
Glad to hear it worked, and thank you for participating in our little game of keycode shuffle. :)