WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: No sound from VT8233/A/8235/8237, Advice?  (Read 1152 times)

Offline binarydemon

  • WikiUser
  • *
  • Posts: 30
No sound from VT8233/A/8235/8237, Advice?
« on: March 16, 2018, 12:45:49 PM »
Hi,

Running TinyCore 9 x86.  alsa.tcz, alsa-config.tcz, alsa-modules-4.14.10-tinycore.tcz, alsa-plugins.tcz, alsaequal.tcz, and alsamixergui.tcz installed - but it simply doesnt detect the soundcard.

lspci-
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)

aplay -l
\aplay: device_list:272: no soundcards found....

The service alsasound doesnt start automatically, I'm guessing because it didnt find any soundcards.

Googling makes it seem like I need to do install the module snd-via82xx,  I tried modprobe snd-via82xx but it didnt work.

I tried blacklisting snd-hda-intel but nothing changed, I suspect that advice is more for systems with multiple sound cards.

I tried OSS but that was the same result, nothing detected.

Advice?
Check out DOSBox Distro - https://sites.google.com/site/dosboxdistro/

A tinycore LIVEUSB that makes playing your dos games anywhere very simple.

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 2729
Re: No sound from VT8233/A/8235/8237, Advice?
« Reply #1 on: March 16, 2018, 01:32:59 PM »
Welcome binarydemon

First read the instructions in the alsa.tcz info file

Offline binarydemon

  • WikiUser
  • *
  • Posts: 30
Re: No sound from VT8233/A/8235/8237, Advice?
« Reply #2 on: March 16, 2018, 07:53:17 PM »
On a hunch, I tried some older versions of TC and the alsa snd-via82xx detection works fine up to Tinycore 7.2.  So I'm guessing it's either a bug or it was obsoleted from newer kernels. It's a shame regressing Tinycore isn't as simple as upgrading it, but this is an acceptable workaround for me.
« Last Edit: March 16, 2018, 07:56:10 PM by binarydemon »
Check out DOSBox Distro - https://sites.google.com/site/dosboxdistro/

A tinycore LIVEUSB that makes playing your dos games anywhere very simple.

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 9862
Re: No sound from VT8233/A/8235/8237, Advice?
« Reply #3 on: March 17, 2018, 02:04:53 AM »
ALSA drivers do regress from time to time. Downgrading TC should be the exact same procedure as upgrading though: replace kernel and initrd, upgrade extensions, update deps.

edit: I think it's possible to run the older kernel with 9.x too, so you'd have access to newer apps. Download the modules with 7.x (tce-load -w original-modules-KERNEL) or via a browser, remaster the /lib/modules/4... directory into the 9.x initrd.
« Last Edit: March 17, 2018, 02:08:50 AM by curaga »
The only barriers that can stop you are the ones you create yourself.

Offline binarydemon

  • WikiUser
  • *
  • Posts: 30
Re: No sound from VT8233/A/8235/8237, Advice?
« Reply #4 on: March 17, 2018, 06:56:11 AM »
Thanks for the advice, I’ll do some testing. With some luck maybe TC 9.x will work with the 7.2 Alsa tcz’s.
Check out DOSBox Distro - https://sites.google.com/site/dosboxdistro/

A tinycore LIVEUSB that makes playing your dos games anywhere very simple.

Offline Lewis

  • WikiUser
  • *
  • Posts: 4
Re: No sound from VT8233/A/8235/8237, Advice?
« Reply #5 on: June 25, 2018, 08:48:04 AM »
I almost gave up on Tinycore because I had the same problem. The very same problem on audio so I went to USB audio and fixed the problem.

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5935
Re: No sound from VT8233/A/8235/8237, Advice?
« Reply #6 on: June 25, 2018, 11:26:00 AM »
Hi binarydemon
I just upgrade a machine to TC9 and struggled with Alsa myself. Unlike TC4, there is no  alsaconf  command to configure your
hardware. After some searching on the forum I found the following command:
Code: [Select]
alsactl initAfter that I had sound.

Offline binarydemon

  • WikiUser
  • *
  • Posts: 30
Re: No sound from VT8233/A/8235/8237, Advice?
« Reply #7 on: June 26, 2018, 11:57:49 AM »
Thanks Rich, that might prove useful.
Check out DOSBox Distro - https://sites.google.com/site/dosboxdistro/

A tinycore LIVEUSB that makes playing your dos games anywhere very simple.

Offline Lewis

  • WikiUser
  • *
  • Posts: 4
Re: No sound from VT8233/A/8235/8237, Advice?
« Reply #8 on: June 27, 2018, 12:13:00 AM »
Thanks Rich. I tried the alsactl init and it fixed the problem. Now I can use zmixer I compiled under Debian and retrovol for the tray. With USB I could only use alsamixer.

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5935
Re: No sound from VT8233/A/8235/8237, Advice?
« Reply #9 on: June 27, 2018, 05:22:56 AM »
Hi Lewis
Glad to hear it worked for you too. If anyone else has trouble setting up ALSA, these are the steps that worked for me:

 1. Install alsa-config.tcz
 2. Install alsa.tcz
 3. Install alsamixergui.tcz (optional)
 4. Set the volume control on the front of the speaker about 1/3 of the way up
 5. Run:
Code: [Select]
alsactl init    This produced a slight thump as the card was found and initialized. That command
    also unmuted the speakers and set the mixer volumes at sane levels.
 6. Run:
Code: [Select]
speaker-test [-Ddefault:1] -c2 -t wav -l1    If all went well, you should hear the phrases  "Front Left"  and  "Front Right"  from
    your left and right speakers respectively.
 7. Run:
Code: [Select]
sudo alsactl store 8. Run:
Code: [Select]
echo alsactl restore >> /opt/bootlocal.sh 9. Run:
Code: [Select]
echo usr/local/etc/alsa/asound.state >> /opt/.filetool.lst.10. Run a backup to save your setup.

Offline Lewis

  • WikiUser
  • *
  • Posts: 4
Re: No sound from VT8233/A/8235/8237, Advice?
« Reply #10 on: June 27, 2018, 08:59:55 PM »
Thanks again. I set up my system with JWM to mimick Puppy Linux. JWM has an execute on init within the .jwmrc file is where I put the alsctl command. I also added xload to  JWM. 

I have the original book on Damn Small Linux and had been a fan for years even when the project died. So I also ported over ideas from DSL. I run with JWM, Openbox, or Fluxbox with either the ROX desktop or idesk.

I need a better understanding of the boot sequence. I know about bootlocal, I used to use  .xnitrc  with Debian, so what is the relationship between bootlocal and .profile?

Offline polikuo

  • Sr. Member
  • ****
  • Posts: 350
Re: No sound from VT8233/A/8235/8237, Advice?
« Reply #11 on: June 27, 2018, 09:19:09 PM »
what is the relationship between bootlocal and .profile?

/opt/bootlocal.sh is executed as root for system management. (before user log-in)
~/.profile is executed as user (tc) when logging in.
~/.X.d/any_scripts are executed as user (tc) when the X server starts.

Offline Lewis

  • WikiUser
  • *
  • Posts: 4
Re: No sound from VT8233/A/8235/8237, Advice?
« Reply #12 on: July 03, 2018, 12:56:57 AM »
OK. Thank you.