WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: No sound from VT8233/A/8235/8237, Advice?  (Read 451 times)

Offline binarydemon

  • WikiUser
  • *
  • Posts: 28
No sound from VT8233/A/8235/8237, Advice?
« on: March 16, 2018, 12:45:49 PM »
Hi,

Running TinyCore 9 x86.  alsa.tcz, alsa-config.tcz, alsa-modules-4.14.10-tinycore.tcz, alsa-plugins.tcz, alsaequal.tcz, and alsamixergui.tcz installed - but it simply doesnt detect the soundcard.

lspci-
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)

aplay -l
\aplay: device_list:272: no soundcards found....

The service alsasound doesnt start automatically, I'm guessing because it didnt find any soundcards.

Googling makes it seem like I need to do install the module snd-via82xx,  I tried modprobe snd-via82xx but it didnt work.

I tried blacklisting snd-hda-intel but nothing changed, I suspect that advice is more for systems with multiple sound cards.

I tried OSS but that was the same result, nothing detected.

Advice?
Check out DOSBox Distro - https://sites.google.com/site/dosboxdistro/

A tinycore LIVEUSB that makes playing your dos games anywhere very simple.

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 2626
Re: No sound from VT8233/A/8235/8237, Advice?
« Reply #1 on: March 16, 2018, 01:32:59 PM »
Welcome binarydemon

First read the instructions in the alsa.tcz info file

Offline binarydemon

  • WikiUser
  • *
  • Posts: 28
Re: No sound from VT8233/A/8235/8237, Advice?
« Reply #2 on: March 16, 2018, 07:53:17 PM »
On a hunch, I tried some older versions of TC and the alsa snd-via82xx detection works fine up to Tinycore 7.2.  So I'm guessing it's either a bug or it was obsoleted from newer kernels. It's a shame regressing Tinycore isn't as simple as upgrading it, but this is an acceptable workaround for me.
« Last Edit: March 16, 2018, 07:56:10 PM by binarydemon »
Check out DOSBox Distro - https://sites.google.com/site/dosboxdistro/

A tinycore LIVEUSB that makes playing your dos games anywhere very simple.

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 9778
Re: No sound from VT8233/A/8235/8237, Advice?
« Reply #3 on: March 17, 2018, 02:04:53 AM »
ALSA drivers do regress from time to time. Downgrading TC should be the exact same procedure as upgrading though: replace kernel and initrd, upgrade extensions, update deps.

edit: I think it's possible to run the older kernel with 9.x too, so you'd have access to newer apps. Download the modules with 7.x (tce-load -w original-modules-KERNEL) or via a browser, remaster the /lib/modules/4... directory into the 9.x initrd.
« Last Edit: March 17, 2018, 02:08:50 AM by curaga »
The only barriers that can stop you are the ones you create yourself.

Offline binarydemon

  • WikiUser
  • *
  • Posts: 28
Re: No sound from VT8233/A/8235/8237, Advice?
« Reply #4 on: March 17, 2018, 06:56:11 AM »
Thanks for the advice, I’ll do some testing. With some luck maybe TC 9.x will work with the 7.2 Alsa tcz’s.
Check out DOSBox Distro - https://sites.google.com/site/dosboxdistro/

A tinycore LIVEUSB that makes playing your dos games anywhere very simple.