WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Printer Driver Updates for Tiny Core  (Read 824 times)

Offline Len E.

  • WikiUser
  • *
  • Posts: 16
Printer Driver Updates for Tiny Core
« on: March 06, 2018, 02:54:25 PM »
I'm curious if there are any printer driver updates scheduled for Tiny Core.

The current version of hplip, 3.13.11  supports my HP Photosmart Plus B210.
My HP Envy 7640 series printer was first supported in hplip version 3.14.10.

My Canon MX520 series printer requires Gutenprint version 5.2.11.

Len E.

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10105
Re: Printer Driver Updates for Tiny Core
« Reply #1 on: March 06, 2018, 10:21:02 PM »
I'll have a look at hplip

The gutenprint maintainer is no longer with us - would you like to take over maintaining the extension?

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10105
Re: Printer Driver Updates for Tiny Core
« Reply #2 on: March 07, 2018, 04:11:38 AM »
updated hplip posted

Note that cups automatically finds my networked printer and will print a cups test page

None of the hp-* commands would work with the cups printer created above, so I was obliged to do this:
Code: [Select]
$ hp-makeuri 192.168.1.170

HP Linux Imaging and Printing System (ver. 3.17.11)
Device URI Creation Utility ver. 5.0
...
Created directory: /var/net-snmp
Created directory: /var/net-snmp/mib_indexes
CUPS URI: hp:/net/Officejet_6700?ip=192.168.1.170
SANE URI: hpaio:/net/Officejet_6700?ip=192.168.1.170
HP Fax URI: hpfax:/net/Officejet_6700?ip=192.168.1.170

Done.

..and use the cups browser interface to create a printer at hp:/net/Officejet_6700?ip=192.168.1.170

..and then the hp-* commands worked (for example, hp-info, hp-testpage).

hp-scan will work if the pil extension is loaded.
« Last Edit: March 07, 2018, 04:32:22 AM by Juanito »

Offline Len E.

  • WikiUser
  • *
  • Posts: 16
Re: Printer Driver Updates for Tiny Core
« Reply #3 on: March 07, 2018, 05:26:40 PM »
Hi Juanito:     In response to your "updated hplip posted", I'm not sure how to
                     obtain the latest package.

                 When I use the Apps package in the normal way, the old version still comes up.

                 At http://distro.ibiblio.org/tinycorelinux/9.x/x86/tcz, there is
                      an hplip.tcz package for Version 3.17.11, but it is dated Jan. 4, 2018,
                      so I'm not sure that it is the latest one that you posted.

Please advise.

Len E.

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5928
Re: Printer Driver Updates for Tiny Core
« Reply #4 on: March 07, 2018, 06:23:04 PM »
Hi Len E.
It probably hasn't reached that mirror yet. Mirrors usually get updated once every 24 hours. If you need it sooner, you
can find it at:
http://tinycorelinux.net/9.x/x86/tcz

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10105
Re: Printer Driver Updates for Tiny Core
« Reply #5 on: March 07, 2018, 10:06:39 PM »
updated gutenprint also posted

Offline Len E.

  • WikiUser
  • *
  • Posts: 16
Re: Printer Driver Updates for Tiny Core
« Reply #6 on: March 07, 2018, 10:35:00 PM »
Hi Rich:

Yet some more things I don't understand ........

When I access the location I mentioned at 5:26 pm with a browser,
the tcz extensions are downloadable.

When I access the location you mentioned at 6:23 pm with a browser,
the tcz extensions are listed but not downloadable.

From the Apps package, the standard mirrors.tcz extension provides
a selection of mirrors to choose from, but Apps doesn't allow the location
you mentioned to be keyed in explicitly.

I don't know how to download an extension from the location you mentioned.

Len E.

Online coreplayer2

  • Hero Member
  • *****
  • Posts: 2722
Re: Printer Driver Updates for Tiny Core
« Reply #7 on: March 07, 2018, 10:46:19 PM »
I'm guessing this depends on the web browser you're using but typing this in the address bar in Firefox will summon the download feature..
http://tinycorelinux.net/9.x/x86/tcz/hplip.tcz

Know that you'll also need hplip.tcz.dep and hplip.tcz.md5.txt
http://tinycorelinux.net/9.x/x86/tcz/hplip.tcz.dep
http://tinycorelinux.net/9.x/x86/tcz/hplip.tcz.md5.txt (use the SaveAs option for this file)


You can also use
Code: [Select]
wget ...
to download directly, but I wouldn't recommend it..   Instead I'd recommend you select "tinycorelinux.net" as the source and use APPS, or one of the terminal options
« Last Edit: March 07, 2018, 10:49:35 PM by coreplayer2 »

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5928
Re: Printer Driver Updates for Tiny Core
« Reply #8 on: March 07, 2018, 10:53:58 PM »
Hi Len E.
Quote
From the Apps package, the standard mirrors.tcz extension provides
a selection of mirrors to choose from, but Apps doesn't allow the location
you mentioned to be keyed in explicitly.
If you change the content of  /opt/tcemirror  to  http://repo.tinycorelinux.net/  then  Apps  will be able to access it.

Offline Len E.

  • WikiUser
  • *
  • Posts: 16
Re: Printer Driver Updates for Tiny Core
« Reply #9 on: March 08, 2018, 02:52:08 PM »
Some good news and some bad news:

Having resumed my testing about 1 day later, the
updated hplip and gutenprint extensions were available
in the normal way from Apps.

hplip

The new extension wouldn't install.  It seemed to have
a dependency problem, because as soon as the repo was
accessed for dependencies, the install failed.

gutenprint

(An observation of no great significance:  although both my
 HP Envy 7640 and Canon PIXMA MX522 printers are networked,
 CUPS would only find the HP, not the Canon).

I installed the Canon using IPP addressing from CUPS.
The error log from the initial attempts to use it had a
message stating that the avahi daemon was not available.

Some Arch Linux documentation on the web stated that for
the avahi daemon to be active, the module nss-mdns is required.
I installed the extension, nss-mdns.tcz, and then the Canon
printer worked.

Getting there a little bit at a time ........

Len E.

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10105
Re: Printer Driver Updates for Tiny Core
« Reply #10 on: March 08, 2018, 08:58:19 PM »
hplip

The new extension wouldn't install.  It seemed to have
a dependency problem, because as soon as the repo was
accessed for dependencies, the install failed.
What error messages did you get? Does hplip work now?

Quote
Some Arch Linux documentation on the web stated that for
the avahi daemon to be active, the module nss-mdns is required.
I installed the extension, nss-mdns.tcz, and then the Canon
printer worked.
nss-mdns is a dependency of the avahi extension and would have been installed if you used the apps gui or "tce-load -wil"

Offline Len E.

  • WikiUser
  • *
  • Posts: 16
Re: Printer Driver Updates for Tiny Core
« Reply #11 on: March 09, 2018, 07:28:23 PM »
Hi Juanito:    hplip is now o.k.

When I retried the hplip install, I noticed that no dependencies were
being accessed, that hplip.tcz was being installed immediately, resulting
in the error message hplip.tcz failed.

In the midst of all my thrashing around, I might have installed the old hplip
previously, with the old dependencies in place.  I guessed that perhaps
that might be the cause of the failure.

On another one of my machines, I started from scratch, reinstalling a fresh
copy of CorePlus 9.0.  This time, hplip.tcz installed fine, loading a large
number of dependencies first, with hplip.tcz loaded as the last step.

My HP Envy 7640 was detected as a network printer; I installed it with the
HP Envy Photo 7100 driver as the closest match.  It works fine.

Many thanks to you, Rich, and coreplayer2 for guiding me through all this !!

Len E.

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 9862
Re: Printer Driver Updates for Tiny Core
« Reply #12 on: March 10, 2018, 01:00:36 AM »
If you have existing extensions, you can use Apps: build the db, update deps, fetch missing.
The only barriers that can stop you are the ones you create yourself.