WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Display issues  (Read 400 times)

Offline mike0

  • WikiUser
  • *
  • Posts: 5
Display issues
« on: March 01, 2018, 05:19:19 PM »
When I boot the tiny core iso in qemu, my mouse is not in sync.

Without networking the command is:
Quote
qemu-system-x86_64 -enable-kvm -m 512 -vnc :0 -cdrom tinycore.iso

As a work around I found a link on this forum saying to install Xorg. So I created a qcow2, installed tiny core to disk, installed Xorg from the package manager, and use the usb tablet device.

I can boot the virtual machine using:
Quote
qemu-system-x86_64 -enable-kvm -m 512 -usb -device usb-tablet -vnc :0 -hda tinycore.qcow

Now with Xorg when I connect using a vnc client my mouse is in sync, but the display is like I am looking through a view port. When I need to access the bottom part of my screen, I have to slide my mouse to the bottom and the screen slides down to showing me the bottom and hiding the top. It's like I'm trading one problem for another. Changing resolutions to something smaller than 1280x768 shrinks the view port even further. For example when I use xrandr and go to 1024x768 I can no longer access the right 30% of the screen.

Has anyone found a work around for this?

Offline mike0

  • WikiUser
  • *
  • Posts: 5
Re: Display issues
« Reply #1 on: March 01, 2018, 06:24:05 PM »
Forcing a vga resolution as an APPEND argument to the kernel fixed this for me.

Quote
sudo vi /mnt/sda1/tce/boot/extlinux/extlinux.conf
After quiet add:
Quote
vga=791

Other resolutions are on page 52 of the corebook.pdf

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5997
Re: Display issues
« Reply #2 on: March 01, 2018, 06:35:29 PM »
Hi mike0
Don't know if this applies to your situation, but I had the same problem with Xorg minus the Qemu part. Xorg would
misidentify my screen size resulting in a scrollable viewport. I had to add the  Virtual  line to the  Screen  section  of
my  /etc/X11/xorg.conf  file:
Code: [Select]
Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Virtual     1920 1080
        Depth       24
        Modes      "1920x1080" "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Offline mike0

  • WikiUser
  • *
  • Posts: 5
Re: Display issues
« Reply #3 on: March 01, 2018, 09:05:56 PM »
I may have done something wrong, all I could get was a screen that was the same color as the desktop, but all distorted.

I ran
Code: [Select]
ps aux | grep X
And killed the X server process

Code: [Select]
kill 2410
This dropped me to a terminal and allowed me to save the running config to /root/xorg.conf.new:
Code: [Select]
sudo Xorg -configure
Which I moved to /etc/X11/xorg.conf

I modified the file to have section "Screen" almost exactly like yours

Code: [Select]
Section "Screen"
    Identifier     "Screen0"
    Device         "Card0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Virtual     1024 768
        Depth       24
        Modes      "1024x768"
    EndSubSection
EndSection

I added /etc/X11/xorg.conf to /opt/.filetool.lst and ran

Code: [Select]
filetool.sh -b
Which saved all of my changes

On reboot the display garbled.
« Last Edit: March 01, 2018, 09:15:32 PM by mike0 »

Offline mike0

  • WikiUser
  • *
  • Posts: 5
Re: Display issues
« Reply #4 on: March 01, 2018, 09:44:19 PM »
I deleted the driver line from Section "Device" and got it working with what you said, thanks for the help.

Here's my full xorg.conf that worked for me for anyone that stumbles upon this in the future.

Quote
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   ModulePath   "/usr/local/lib/xorg/modules"
   FontPath     "/usr/local/lib/X11/fonts/misc/"
   FontPath     "/usr/local/lib/X11/fonts/TTF/"
   FontPath     "/usr/local/lib/X11/fonts/OTF/"
   FontPath     "/usr/local/lib/X11/fonts/Type1/"
   FontPath     "/usr/local/lib/X11/fonts/100dpi/"
   FontPath     "/usr/local/lib/X11/fonts/75dpi/"
EndSection

Section "Module"
   Load  "glx"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/input/mice"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
EndSection

Section "Device"
   Identifier  "Card0"
   BusID       "PCI:0:2:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   DefaultDepth   16
   SubSection "Display"
      Virtual 1024 768
      Depth   16
      Modes   "1024x768"      
   EndSubSection
EndSection

Setting the driver to vesa works too

Quote
Section "Device"
   Identifier  "Card0"
   Driver       "vesa"
   BusID       "PCI:0:2:0"
EndSection
« Last Edit: March 01, 2018, 09:52:45 PM by mike0 »