WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: pulseaudio error  (Read 343 times)

Offline jls

  • Hero Member
  • *****
  • Posts: 2079
    • Core17
pulseaudio error
« on: February 17, 2018, 08:30:54 AM »
Hi
see attachments
Code: [Select]
jls@pc1:~$ cat .X.d/pulseaudio
#!/bin/sh

pulseaudio --log-level=debug --log-target=stderr --log-time=true >> /var/log/pulse.log 2>&1

jls@pc1:~$ ps|grep pulse
jls       9904  9903  0 17:09 tty1     00:00:00 pulseaudio --log-level=debug --log-target=stderr --log-time=true
jls      12833 12229  0 17:23 pts/2    00:00:00 grep pulse
jls@pc1:~$
dCore user

Offline jls

  • Hero Member
  • *****
  • Posts: 2079
    • Core17
Re: pulseaudio error
« Reply #1 on: February 17, 2018, 09:07:46 AM »
Closing X and starting it again makes pulse working
dCore user

Offline jls

  • Hero Member
  • *****
  • Posts: 2079
    • Core17
Re: pulseaudio error
« Reply #2 on: February 17, 2018, 11:49:49 AM »
Hi
What I've noticed is that pulseaudio after a while of inactivity it closes, and while other applications are capable to start pulseaudio again ( for example terminology ), firefox can't, so if firefox is launched with pulseaudio running ok, otherwise no sound in firefox.
dCore user

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9511
Re: pulseaudio error
« Reply #3 on: February 17, 2018, 12:48:55 PM »
I also found that a pulseaudio startup script in ~/.X.d does not work on initial boot and X session, but after closing X and restarting it it works.  I was going to make the pulseaudio tce.installed startup script create a ~/.X.d/pulseaudio script to start pulseaudio when X starts, but as noted it does not work on boot.   Desktop environments like XFCE take care of pulseaudio and pulseaudio starts and works reliably in them.  The smaller window managers don't start pulseaudio, so it is left to the user.   

Offline jls

  • Hero Member
  • *****
  • Posts: 2079
    • Core17
Re: pulseaudio error
« Reply #4 on: February 17, 2018, 01:26:25 PM »
Hi
I think your startup script is still on the server.
Also Enlightenment take care of starting pulseaudio daemon.
The problem is that while in standard ubuntu the daemon stays alive even if no program uses it, in dCore the daemon dies after a while.
Some programs are able to autostart pulseaudio again but not firefox, so I modified
/etc/pulse/daemon.conf
setting:
exit-idle-time = -1
so the daemon stays always alive.

Ciao
dCore user

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9511
Re: pulseaudio error
« Reply #5 on: February 17, 2018, 01:46:46 PM »
Thanks, I will let the startup script set 'exit-idle-time = -1' in /etc/pulse/daemon.conf as the default since that would be the way most folks would like it to behave.