WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Kodi almost works, but crashing  (Read 520 times)

Offline Lassar

  • WikiUser
  • *
  • Posts: 19
Kodi almost works, but crashing
« on: February 04, 2018, 11:52:57 AM »
I manage to build a kodi tce from xenial deb packages and library files
copied from kodipup lite.

There is something about it's environment, that it does not like.

Here are parts of the kodi error log.


Code: [Select]
CAESinkALSA - Unable to open device "default" for playback
18:17:50.365 T:2294283072    INFO: CAESinkALSA - Unable to get a list of devices
18:17:54.920 T:2996078720   DEBUG: DeviceKit.Disks: org.freedesktop.DBus.Error.FileNotFound - Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory
18:17:54.926 T:2996078720   DEBUG: Selected UDev as storage provider
18:17:54.945 T:2996078720   ERROR: customConvert: iconv_open() for "CP1252" -> "UTF-8" failed, errno = 22 (Invalid argument)
18:17:54.945 T:2996078720   ERROR: CXRandR::Query - unable to open xrandr xml
18:17:54.945 T:2996078720    INFO: Available videomodes (xrandr):
18:17:54.945 T:2996078720  NOTICE: Checking resolution 16
18:17:54.946 T:2996078720   ERROR: Failed to find matching visual
18:17:54.946 T:2996078720    INFO: GL: Maximum texture width: 32768

I figured that I was missing some tz, so threw the kitchen sink at it.

It died not help any.

Anyone have any ideas?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10055
Re: Kodi almost works, but crashing
« Reply #1 on: February 04, 2018, 08:55:47 PM »
Did you try using Xorg-7.7-3d and with a locale set (for example, en_US.UTF-8)?

Offline Lassar

  • WikiUser
  • *
  • Posts: 19
Re: Kodi almost works, but crashing
« Reply #2 on: February 08, 2018, 09:52:51 AM »
Kodi extension available for testing here: [Deleted]

    [EDIT]: Link deleted due to forum policy violation.  Rich
« Last Edit: February 08, 2018, 10:04:34 AM by Rich »

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5780
Re: Kodi almost works, but crashing
« Reply #3 on: February 08, 2018, 10:02:32 AM »
Hi Lassar
Posting of extensions in the forum is not allowed. Instructions for submitting extensions can be found here:
http://wiki.tinycorelinux.net/wiki:creating_extensions

Offline Lassar

  • WikiUser
  • *
  • Posts: 19
Re: Kodi almost works, but crashing
« Reply #4 on: February 08, 2018, 10:18:12 AM »
Sorry did not know that.

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1652
Re: Kodi almost works, but crashing
« Reply #5 on: February 08, 2018, 10:05:37 PM »
Hi Lassar,
note that extensions that contain binaries from another distro shouldn't be submitted to the TC repo.
However, I have some personal extensions made from .deb packages or just copied strait from Debian, too.
If needed, which usually is the case, also containing dependencies and a script defining $LD_LIBRARY_PATH to point to additional libs gathered from the same Debian repo or installation. I'm running EmulationStation gathered from Debian/RetroPie on piCore since it is virtually impossible to compile on piCore as it tries to do a lot of Debian-Only stuff which is a shame. The important stuff works but a lot is broken. ;)
Download a copy and keep it handy: Core book ;)