WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Freerdp wont login  (Read 231 times)

Offline sarkye

  • WikiUser
  • *
  • Posts: 12
Freerdp wont login
« on: February 02, 2018, 01:25:12 AM »
Hi,

I'm trying to make a thin client (hp t5720) that can RDP into both my servers Windows 2008 & Windows 2012 R2 with NLA

Now i have freerdp running but with the Windows 2008 i seem to get kicked out immediately. ( if i'm also logged in with a other pc on this server i see i get kicked out, meaning that it logges in right)
I get the following on TC:

Code: [Select]
root@box:/home/tc# xfreerdp /u:Username /p:password /d:domein /sec:rdp /v:server -cert-ignore
error:
Code: [Select]
sh: xprop: not found
sh: xprop: not found
Warning xf_GetWindowProperty (177): Property (173 does not exist
connect to server:3389
Unable to detect time zone
XInput extension not available.
Xlib: extension :XVideo" missing on display "0.0".
Illegal instruction

for the Windows 2012 R2 with NLA server i put in the following.
Code: [Select]
root@box:/home/tc# xfreerdp /u:Username /p:password /d:domein /sec:nla /v:server -cert-ignore
error:
Code: [Select]
sh: xprop: not found
sh: xprop: not found
Warning xf_GetWindowProperty (177): Property (173 does not exist
connect to server:3389
creating directory /root/.config/freerdp/
creating directory /root/.config/freerdp/certs
creating directory /root/.config/freerdp/server
certificate_store_open: error opening [/root/.config/freerdp/known_hosts] for writing
SSL_read: Failure in SSL library (protocol error?)
SSL_read: error:24064064:random number generator:SSLEAY_RAND_BYTES:PRNG not seeded

I'm fairly new to linux and especially to TC on a thinclient.
Hopefully someone can help me, many thanks
« Last Edit: February 02, 2018, 01:29:43 AM by sarkye »

Offline sarkye

  • WikiUser
  • *
  • Posts: 12
Re: Freerdp wont login
« Reply #1 on: February 02, 2018, 01:56:42 AM »
Most importantly for me is getting the Windows 2012 R2 server with NLA working.

The otherone i can manage with rdesktop.  ::)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9802
Re: Freerdp wont login
« Reply #2 on: February 02, 2018, 04:16:54 AM »
Given that Xprop is provided by the Xorg-7.7-bin extension, do you need to be running Xorg-7.7 rather than Xvesa perhaps?

Offline sarkye

  • WikiUser
  • *
  • Posts: 12
Re: Freerdp wont login
« Reply #3 on: February 02, 2018, 04:41:37 AM »
I have both installed..

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9802
Re: Freerdp wont login
« Reply #4 on: February 02, 2018, 05:31:52 AM »
OK, but which one is running?

..and if both of them are loaded,  Xprop should be present...
« Last Edit: February 02, 2018, 05:36:39 AM by Juanito »

Offline sarkye

  • WikiUser
  • *
  • Posts: 12
Re: Freerdp wont login
« Reply #5 on: February 02, 2018, 06:57:28 AM »
is see both in the status list..

Code: [Select]
tce-status -i
how can i see which one is running?
I expect it's Xvesa because Xorg gets installed with freerdp..

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5587
Re: Freerdp wont login
« Reply #6 on: February 02, 2018, 07:00:47 AM »
Hi sarkye
Code: [Select]
root@box:/home/tc# xfreerdp /u:Username /p:password /d:domein /sec:rdp /v:server -cert-ignore
error:
Code: [Select]
sh: xprop: not found
sh: xprop: not found
Warning xf_GetWindowProperty (177): Property (173 does not exist
connect to server:3389
Unable to detect time zone
XInput extension not available.
Xlib: extension :XVideo" missing on display "0.0".
************* Illegal instruction ***************
While Tinycore is supposed to run on a  486,  sometimes incompatible programs slip by. That  Illegal instruction  message is
the CPU telling you it received an instruction that is not part of its instruction set, and can not run the program that provided it.


Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5587
Re: Freerdp wont login
« Reply #7 on: February 02, 2018, 07:19:47 AM »
Hi sarkye
... how can i see which one is running? ...
Execute:
Code: [Select]
cat .xsessionThe first line will tell you.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9802
Re: Freerdp wont login
« Reply #8 on: February 02, 2018, 07:20:56 AM »
how can i see which one is running?

Code: [Select]
$ ps aux | grep X
Does "tce-status -i" show Xorg-7.7-bin is loaded?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9802
Re: Freerdp wont login
« Reply #9 on: February 02, 2018, 07:22:46 AM »
The first line will tell you.

Hmm - not necessarily - what about if you load Xvesa, startx and then load Xorg-7.7?

Offline sarkye

  • WikiUser
  • *
  • Posts: 12
Re: Freerdp wont login
« Reply #10 on: February 02, 2018, 07:26:00 AM »
on the first line it tells me Xvesa

if i understand Rich it doesn't mater what i try it's not possible with this processor ?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9802
Re: Freerdp wont login
« Reply #11 on: February 02, 2018, 07:29:17 AM »
I'm not sure if it's the cpu or an instruction that Xvesa doesn't like.

Try running Xorg-7.7 rather than Xvesa

Offline sarkye

  • WikiUser
  • *
  • Posts: 12
Re: Freerdp wont login
« Reply #12 on: February 02, 2018, 07:36:40 AM »
I'm sorry really new to this.

i removed Xvesa from Onboot and added Xorg.

now i only get the text boot, i tried to startx.
But can't seem to find cat: can't open '/etc/sysconfig/Xserver': No such fle or directory

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9802
Re: Freerdp wont login
« Reply #13 on: February 02, 2018, 07:43:15 AM »
Did you download/load the Xorg-7.7 extension using "tce-load -i" or the apps gui?

The reason I ask is that it seems like you have Xorg-7.7, but not all of the extensions it depends on?

What does "tce-status -i | grep X" show?

Offline sarkye

  • WikiUser
  • *
  • Posts: 12
Re: Freerdp wont login
« Reply #14 on: February 02, 2018, 08:03:41 AM »
i got it from the apps gui...

how do i download it with terminal ?

on my "tce-status i" list it only shows Xorg-7.7-lib