WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Can not load uqmi.tcz needed for Huawei e3372  (Read 240 times)

Offline lotte67890

  • WikiUser
  • *
  • Posts: 15
Can not load uqmi.tcz needed for Huawei e3372
« on: January 30, 2018, 09:10:48 AM »
Hello, I´m quite new to picore and so to this forum. I´m building a router based on a RPI, an UMTS LTE Dongle (Huawei e3372), Wlan and of course PiCore.
Unfortunately I can not load the uqmi package which is described here: http://forum.tinycorelinux.net/index.php/topic,18820.msg115347.html#msg115347
When using tce-load uqmi I receive a ... not found... error, maybe related due to a not available ....md5.txt file.
Other files needed to install and downloaded either by tce-load or sear4cehd and installed via tce-ab worked flawless.

In the end I somehow need to bring the modem to dial... Some say wvdial shoud be used, but I assume that uqmi is my choice since modemswitch brought my device up as wwan0.

Anyone any hint?

Thanks in advance!

L

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5710
Re: Can not load uqmi.tcz needed for Huawei e3372
« Reply #1 on: January 30, 2018, 09:23:45 AM »
Hi lotte67890
Unfortunately I can not load the uqmi package which is described here: http://forum.tinycorelinux.net/index.php/topic,18820.msg115347.html#msg115347
When using tce-load uqmi I receive a ... not found... error, maybe related due to a not available ....md5.txt file.
That package was compiled for  X86  not  ARM.

Offline lotte67890

  • WikiUser
  • *
  • Posts: 15
Re: Can not load uqmi.tcz needed for Huawei e3372
« Reply #2 on: January 31, 2018, 12:40:17 AM »
Well, that explains a lot... any suggestion where I can download the source code and compile it myself? Or any suggestion of an alternate method to bring the Huawei e3372 to connect?

Thanks

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9968
« Last Edit: January 31, 2018, 02:03:09 AM by Juanito »

Offline lotte67890

  • WikiUser
  • *
  • Posts: 15
Re: Can not load uqmi.tcz needed for Huawei e3372
« Reply #4 on: January 31, 2018, 12:18:09 PM »
Thanks a lot! Successfully compiled... at least without any errors...

Next problem is that uqmi does not communicate with the device:
sudo uqmi -d /dev/cdc-wdm0 --get-signal-info
runs forever till ctrl^C
^C"Failed to connect to service"

sudo uqmi -d /dev/ttyUSBx --get-signal-info
runs forever till ctrl^C
^C"Unknown error"

What i know is that the stick is working, if I connect it to my ubuntu system, create a device, run through the setup, location, provider... press connect, voila works like charm.

Using Ubuntu the stick has the same product id as under picore, "1506", the devices created under picore and under Ubuntu /dev/cdc-wdmX, /dev/ttyUSB0 and /dev/ttyUSB1 seem identical

So maybe I´m missing something here. If anybody has a guess... please let me know...
Or if anybody has a another guess what I could use to communicate with the Huawei e3372h modem... or even better bring it to connect...

Btw. it´s flashed to a NonHilink Version and using ubuntu is not an option as well...

Merci

L