WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: [Newbie] - TC freeze at boot  (Read 1389 times)

Offline micka

  • WikiUser
  • *
  • Posts: 11
Re: [Newbie] - TC freeze at boot
« Reply #15 on: January 30, 2018, 05:09:24 AM »
For info, I just tried a live Debian kernel 4.9.0-4-amd64 and keyboard ok

Offline PDP-8

  • Full Member
  • ***
  • Posts: 242
Re: [Newbie] - TC freeze at boot
« Reply #16 on: March 14, 2018, 01:32:38 AM »
Ok, so TC's not debian, but have you tried using any of these boot parameters alone or together temporarily (ie, pressing TAB at the initial boot to change / add them...

nolapic     <--- usually my first light duty option
noapic
noacpi     <----- overkill usually.  Not recommended unless you KNOW you need it.

acpi_os=       <--- yep, nothing after the = sign

acpi_os=\"Linux\"      <----  yep, all that escaping and quotes are in the proper place...

(to see if the acpi_os Linux is accepted, also use "syslog" as a boot parameter too and look at /var/log/message


There are many more generic linux options you can try.  Those above are my most go-to options for cranky hardware.  Just throwing this out in case it helps. 

« Last Edit: March 14, 2018, 01:39:41 AM by PDP-8 »
cat -v Considered Harmful  -- Rob Pike

Offline PDP-8

  • Full Member
  • ***
  • Posts: 242
Re: [Newbie] - TC freeze at boot
« Reply #17 on: March 15, 2018, 01:49:43 AM »
My apologies for some errors here...

I inadvertently dropped the "i" from the acpi lines.  Thus one of the above lines should read:

Code: [Select]
acpi_osi=
And, as tested again with TC none of that fancy escaping is needed either if you add a specific osi like:

Code: [Select]
acpi_osi=Linux
And if you also use the syslog kernel parameter at boot time, the results can be found in /var/log/messages.  I left off the trailing s in the filename.

Sorry about that - had to clean it up.  I'll direct a generic query about this in a different thread....

cat -v Considered Harmful  -- Rob Pike