WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: [SOLVED] Prevent HDMI from sleeping  (Read 337 times)

Offline Chau

  • WikiUser
  • *
  • Posts: 13
[SOLVED] Prevent HDMI from sleeping
« on: January 25, 2018, 11:54:46 AM »
Having setup my PI with a simple image viewer (http://forum.tinycorelinux.net/index.php/topic,21566.0.html) I now face the problem, that my screen turns off after a few minutes. I guess picore thinks that since I do not interact with it, it can safely turn off the screen.

I found this post http://forum.tinycorelinux.net/index.php/topic,21118.msg132038.html#msg132038 which seem to discuss the same issue.

I don't have Xorg installed, so
Code: [Select]
xset should be irrelevant for me. It tried the other method
Code: [Select]
setterm -blank 0 but I get the error message:

Code: [Select]
setterm: terminal vt102 does not support --blank
Are there some configuration options that I can set to prevent the PI from sleeping due to inactivity?
« Last Edit: January 25, 2018, 01:33:56 PM by Rich »

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5844
Re: Prevent HDMI from sleeping
« Reply #1 on: January 25, 2018, 12:46:43 PM »

Offline Chau

  • WikiUser
  • *
  • Posts: 13
Re: Prevent HDMI from sleeping
« Reply #2 on: January 25, 2018, 01:20:33 PM »
Hi Chau
Did you try this:
http://forum.tinycorelinux.net/index.php/topic,20382.msg126916.html#msg126916

Hi Rich

No I haven't seen that post, but it seems to do just what I want.

For future reference, this is what I put into /home/tc/.profile:

Code: [Select]
echo -e '\033[9;0]'
Thanks for pointing me in that direction!

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5844
Re: Prevent HDMI from sleeping
« Reply #3 on: January 25, 2018, 01:33:15 PM »
Hi Chau
Glad to hear it worked. I'll mark this thread as solved.