WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: CorePlus doesn't boot into X GUI if boot options 'base' 'norestore' used  (Read 460 times)

Offline rhermsen

  • WikiUser
  • *
  • Posts: 13
Is it expected that CorePlus 8.2.1 (frugal install) doesn't boot with  X GUI if I use the boot options 'base' 'norestore'?

I added the boot options to /mnt/vda1/tce/boot/extlinux/extlinux.conf, and after a reboot it boots into cli only.

Code: [Select]
$ dmesg | grep command
Kernel command line: BOOT_IMAGE=/tce/boot/vmlinuz quiet base norestore vga=789 waitusb=5:UUID=...


If I boot tcl (CD boot) with the 'base' and 'norestore' boot options I still have the GUI after a boot.

Also if I boot tcl64 (CD boot) with the 'base' and 'norestore' boot options I still have the GUI after a boot.

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5705
Re: CorePlus doesn't boot into X GUI if boot options 'base' 'norestore' used
« Reply #1 on: January 24, 2018, 01:17:32 PM »
Hi rhermsen
Base  says not to load any extensions. If your GUI comes from an extension (Xvesa or Xorg) then you'll boot to the command line.
« Last Edit: January 25, 2018, 09:55:36 AM by Rich »

Offline rhermsen

  • WikiUser
  • *
  • Posts: 13
Re: CorePlus doesn't boot into X GUI if boot options 'base' 'norestore' used
« Reply #2 on: January 25, 2018, 09:51:32 AM »
Hi Rich,

Xvesa is indeed located in /mnt/vda1/tce/optional.
I'm using a CorePLus installation as my build environment, and just found it odd to behave differently with these boot parameter added, compared to the other TCL VM's.

Thanks

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 9758
Re: CorePlus doesn't boot into X GUI if boot options 'base' 'norestore' used
« Reply #3 on: January 25, 2018, 10:35:47 AM »
The base bootcode affects writable tce directories, but not the read-only cde dir on cds.
The only barriers that can stop you are the ones you create yourself.