WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Black border around the screen  (Read 428 times)

Offline Chau

  • WikiUser
  • *
  • Posts: 13
Black border around the screen
« on: January 10, 2018, 12:13:25 PM »
Having installed a fresh copy of piCore 9.0.3 and compiled fbv (see http://forum.tinycorelinux.net/index.php/topic,21566.0.html) I am now facing a new problem.

I am showing a FHD image on my FHD monitor (using HDMI) and I get a black border around the image. The width of the border is approximately 50 pixels. When booting my pi the colorfull square shown before piCore takes over is drawn so it touches both the top and the bottom of the monitor. But as soon as piCore displays everything is inside the 50 pixel margin (apparently including what fbv displays).

Is it possible to remove the black margin? I am not using X-server.
« Last Edit: January 10, 2018, 12:17:56 PM by Chau »

Offline Paul_123

  • Sr. Member
  • ****
  • Posts: 430
Re: Black border around the screen
« Reply #1 on: January 10, 2018, 05:23:09 PM »
Adjust the overscan settings in the boot config.

The config settings are described here

https://www.raspberrypi.org/documentation/configuration/config-txt/README.md

Offline Chau

  • WikiUser
  • *
  • Posts: 13
Re: Black border around the screen
« Reply #2 on: January 11, 2018, 09:21:58 AM »
Adjust the overscan settings in the boot config.

The config settings are described here

https://www.raspberrypi.org/documentation/configuration/config-txt/README.md

Hi Paul

Thanks for your reply. It lead me to find the correct values to change.

For others to find (myself in the future!):

The config.txt is located on the unmounted partition mmcblk0p1 which can be mounted using:

Code: [Select]
sudo mount /dev/mmcblk0p1
You can then find config.txt in /mnt/mmcblk0p1/config.txt

I removed the '#' in front of the line #disable_overscan=1 and it did the trick.

Reboot to see if it works.