WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: How to mount floppy in cloud mode  (Read 268 times)

Offline schober

  • WikiUser
  • *
  • Posts: 7
How to mount floppy in cloud mode
« on: December 06, 2017, 12:42:58 PM »
I want to use a floppy on a 20y old computer (P166 & 64mb ram) in cloud mode
TCL is on a cd
TCL  fails to find the floppy and cant be mounted
The cdrom and partitions on the hd all mount fine
THere is no fd0 entry in fstab

I'v read through this -
http://forum.tinycorelinux.net/index.php/topic,7965.30.html
and tried a few things without success!

for eaxample
echo 'modprobe vfat'  >>/opt/bootlocal.sh
mount -t vfat /dev/fd0 /mnt/fd0

The floppy is formatted and has a file on it; it works fine in puppy linux and W98

Any suggestions?

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1595
Re: How to mount floppy in cloud mode
« Reply #1 on: December 06, 2017, 07:45:18 PM »
I'm just noticing that I never attempted to mount a floppy drive on Tiny Core but I'm pretty sure needed modules come with the base system and it should be supported out of the box. (I really don't need it but I could install a floppy drive to check things)
Nevertheless, I think providing information on how you have attempted to access your floppy drive, the commands you have used, and and what error messages that might have came up, would make the next reader realize more quickly what the problem might be.
Download a copy and keep it handy: Core book ;)

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5495
Re: How to mount floppy in cloud mode
« Reply #2 on: December 06, 2017, 08:16:11 PM »
Hi schober
Quote
mount -t vfat /dev/fd0 /mnt/fd0
If  fd0  is not listed in  fstab,  then  /mnt/fd0  won't exist either. Did you create it? You probably also need to use  sudo  f  fd0  is not
listed in  fstab:
Code: [Select]
sudo mount -t vfat /dev/fd0 /mnt/fd0Also, does  /dev/fd0  exist? Please post the output from the following command:
Code: [Select]
showbootcodes

Offline polikuo

  • Sr. Member
  • ****
  • Posts: 250
Re: How to mount floppy in cloud mode
« Reply #3 on: December 06, 2017, 09:43:53 PM »
There is no fd0 entry in fstab

The floppy is formatted and has a file on it; it works fine in puppy linux and W98

Did you test these operating systems on the same computer ?

Did you accidentally turn off the floppy support in your CMOS setting ?

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 9625
Re: How to mount floppy in cloud mode
« Reply #4 on: December 07, 2017, 12:29:50 AM »
Floppies are not autoscanned because it causes significant delay and noise. Thus they won't appear in fstab.
The only barriers that can stop you are the ones you create yourself.

Offline schober

  • WikiUser
  • *
  • Posts: 7
Re: How to mount floppy in cloud mode
« Reply #5 on: December 07, 2017, 01:39:28 AM »
The floppy can be read and the file opened in W98 on the old computer; so no bios or floppy problems imho ( I did change the boot order to cd,hd,fd in order to boot from the cd)

"sudo mount -t vfat /dev/fd0 /mnt/fd0"  results in
mount: mounting /dev/fd0 on /mnt/fd0 failed: no such file or directory

"showbootcodes" gives
initrd=/boot/core.gz loglevel=3 cde xsetup core BOOT_IMAGE=/boot/vmlinuz

At the boot screen I press TAB and then enter "xsetup core" in order to use a serial mouse

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5495
Re: How to mount floppy in cloud mode
« Reply #6 on: December 07, 2017, 04:48:21 AM »
Hi schober
What happens if you do this:
Code: [Select]
sudo mkdir /mnt/fd0
sudo mount -t vfat /dev/fd0 /mnt/fd0

Offline schober

  • WikiUser
  • *
  • Posts: 7
Re: How to mount floppy in cloud mode
« Reply #7 on: December 07, 2017, 07:04:50 AM »
It worked!
Floppy mounted and file was read using cat filename
Thanks alot Rich (and anyone else who replied)
Schober

Offline schober

  • WikiUser
  • *
  • Posts: 7
Re: How to mount floppy in cloud mode
« Reply #8 on: December 07, 2017, 11:00:15 AM »
Oh dear; not out of the woods yet!
I can read from the floppy but cant write anything  to it
The write protect slider is in the closed position

The cp command doesnt work and I cant save from Leafpad

The floppy can be written to in Puppy on another computer

This is the output of ls
 ls -l /mnt/fd0
total 2
-rwxr-xr-x 1 root root 1452 2017-12-06 17:59 cdr_info

These permissions afaiaa apply to the file cdr_info and not to the disc

How can the disc be made writable?

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5495
Re: How to mount floppy in cloud mode
« Reply #9 on: December 07, 2017, 11:12:15 AM »
Hi schober
Try:
Code: [Select]
sudo chown tc:staff /mnt/fd0

Offline schober

  • WikiUser
  • *
  • Posts: 7
Re: How to mount floppy in cloud mode
« Reply #10 on: December 07, 2017, 11:52:03 AM »
"sudo chown tc:staff /mnt/fd0" gave the result
chown: /mnt/fd0: operation not permitted

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5495
Re: How to mount floppy in cloud mode
« Reply #11 on: December 07, 2017, 02:12:48 PM »
Hi schober
Maybe you need to unmount it first, then  chown , and then mount the floppy again?

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 9625
Re: How to mount floppy in cloud mode
« Reply #12 on: December 08, 2017, 01:27:38 AM »
Fat32 doesn't support Linux ownership. You can use the uid/gid mount options, or alternatively edit your file as root.
The only barriers that can stop you are the ones you create yourself.

Offline schober

  • WikiUser
  • *
  • Posts: 7
Re: How to mount floppy in cloud mode
« Reply #13 on: December 08, 2017, 02:43:15 AM »
Using Rich's idea didn't work
Trying to copy file watch to fd0
cp /mnt/sda5 ...../watch /mnt/fd0
results in
cp: overwrite '/mnt/fd0/watch' ?
entering y gives
cp: cant create '/mnt/fd0/watch' : permission denied

The floppy works fine in Puppy linux - no problems reading or saving
How do I use uid/gid options?
Would it be better to format it to ext3?
 

Offline schober

  • WikiUser
  • *
  • Posts: 7
Re: How to mount floppy in cloud mode
« Reply #14 on: December 08, 2017, 11:51:16 AM »
Some success! This works
sudo mkdir /mnt/fd0
sudo mount -t vfat /dev/fd0 /mnt/fd0
sudo cp /mnt/sda5/usr/local/bin/watch /mnt/fd0

Strangely using the ls -al command on puppy gives
brw-rw-r-- 1 root floppy 2, 0 2001-02-13 20:40 /dev
but on tcl i get
brw-rw---- 1 root staff 2, 0 2001-02-13 20:40 /dev

Presumably sudo chmod 626 /mnt/fd0 will make it writable by everyone?