WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: virtualbox-qt-5.1.30-stretch64  (Read 732 times)

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9512
virtualbox-qt-5.1.30-stretch64
« on: October 29, 2017, 02:45:38 PM »
virtualbox-qt-5.2.0-stretch is available, what is different than in x86 is you may need to enable VT-x in your BIOS if you have an Intel, or AMD-v if you have an AMD processor.  These may be disabled by default esp in older machines.

This is also mentioned in the README:

http://tinycorelinux.net/dCore/x86_64/README/README-virtualbox-qt-5.2.0-stretch.txt
« Last Edit: January 19, 2018, 01:08:10 PM by Jason W »

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9512
Re: virtualbox-qt-5.2.0-stretch
« Reply #1 on: October 29, 2017, 06:01:26 PM »
Virtualbox has been reverted to version 5.1.30 in dCore-stretch64 as there are issues with the guest additions in Virtualbox 5.2.0 with recent kernels described below, as well as those guest additions modules would not all build on dCore-stretch64:

https://www.virtualbox.org/wiki/Downloads

The README file remains basically the same:

http://tinycorelinux.net/dCore/x86_64/README/README-virtualbox-qt-5.1.30-stretch.txt

If booting a dCore ISO image in Virtualbox and the ethernet network is not available, then use the below bootcode in Virtualbox:

dc waitusb=8

Or however long that is needed, 8 seconds should be more than enough.

« Last Edit: October 29, 2017, 06:45:41 PM by Jason W »

Offline Onyarian

  • Sr. Member
  • ****
  • Posts: 336
Re: virtualbox-qt-5.2.0-stretch
« Reply #2 on: October 30, 2017, 10:01:47 AM »
Hi Jason,

Quote
tc@dC-st64:~$ sce-load virtualbox-qt-5.1.30-stretch
* Using nice level 19.
* Integrity and md5sum check virtualbox-qt-5.1.30-stretch.
* Mount /tmp/tcloop/virtualbox-qt-5.1.30-stretch/.
* Update system:
  virtualbox-qt-5.1.30-stretch
* Loaded virtualbox-qt-5.1.30-stretch.sce.
tc@dC-st64:~$ virtualbox
/usr/bin/virtualbox: line 89: awk: not found
VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/usr/lib/virtualbox/VirtualBox.so",) failed: libQt5X11Extras.so.5: cannot open shared object file: No such file or directory
tc@dC-st64:~$

Offline patrikg

  • Sr. Member
  • ****
  • Posts: 323
Re: virtualbox-qt-5.2.0-stretch
« Reply #3 on: October 30, 2017, 10:43:28 AM »
Code: (bash) [Select]
/usr/bin/virtualbox: line 89: awk: not found

Have you tried to install gawk.tcz before you execute virtualbox command.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9512
Re: virtualbox-qt-5.2.0-stretch
« Reply #4 on: October 30, 2017, 12:41:56 PM »
I thought I had the deps covered, apparently not.  Added missing deps, tested Virtualbox with only icewm, xorg-all, and kernel-all-4.8.17-tinycore64.  Should be good now.   Also corrected the deps for the x86 dCore-stretch virtualbox-qt package.

« Last Edit: November 04, 2017, 11:31:44 AM by Jason W »

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9512
Re: virtualbox-qt-5.1.30-stretch64
« Reply #5 on: January 19, 2018, 01:07:43 PM »
virtualbox-qt-5.1.30-stretch has been renamed in the x86_64 repo of dCore to virtualbox-qt-5.1.30-stretch64 to avoid confusion.