WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Wiringpi.tcz not working on 9.0.3  (Read 418 times)

Offline xciollax

  • WikiUser
  • *
  • Posts: 1
Wiringpi.tcz not working on 9.0.3
« on: September 25, 2017, 02:52:10 AM »
Hi,
I noticed that the version of wiringpi I got off the repository doesn't work with kernel versions greater than 4.8.
I get a
"Unable to determine hardware version. I see: Hardware   : BCM2835 - expecting BCM2708 or BCM2709." error
whenever I start the library.
The latest version of the wiringpi library I downloaded and compiled from source works correctly.
I'm on version 9.0.3 of picore.

Time to refresh the ol' repo? ;)

Cheers
Marco

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9635
Re: Wiringpi.tcz not working on 9.0.3
« Reply #1 on: September 25, 2017, 04:12:50 AM »
please go ahead and submit an updated extension(s)

Offline polikuo

  • Sr. Member
  • ****
  • Posts: 251
Re: Wiringpi.tcz not working on 9.0.3
« Reply #2 on: September 25, 2017, 04:15:46 AM »
The instructions can be found here.  ;)
http://wiki.tinycorelinux.net/wiki:creating_extensions

Offline Paul_123

  • Sr. Member
  • ****
  • Posts: 397
Re: Wiringpi.tcz not working on 9.0.3
« Reply #3 on: September 25, 2017, 05:30:53 PM »
I created the last one, I already have it packaged.   I thought I submitted this a while ago.   Just resubmitted.
« Last Edit: September 25, 2017, 05:53:44 PM by Paul_123 »

Offline toomyem

  • WikiUser
  • *
  • Posts: 1
Re: Wiringpi.tcz not working on 9.0.3
« Reply #4 on: October 15, 2017, 11:44:44 AM »
Hi,

Did you guys managed to get it working on rpi zero? I loaded wiringpi package via 'tce-load -wi wiringpi' and it is not recognizing hardware:

> gpio -v
gpio version: 2.32
Copyright (c) 2012-2015 Gordon Henderson
This is free software with ABSOLUTELY NO WARRANTY.
For details type: gpio -warranty

Unable to determine hardware version. I see: Hardware   : BCM2835
,
 - expecting BCM2708 or BCM2709.

As you can see this is version 2.32. On my another pi (this time it is rpi 3) I installed it via 'apt-get install wiringpi' and I got 2.44 version which works fine.

Thanks for reply
toomyem

Offline Paul_123

  • Sr. Member
  • ****
  • Posts: 397
Re: Wiringpi.tcz not working on 9.0.3
« Reply #5 on: October 20, 2017, 11:58:38 AM »
The updated extension was submitted, it just has not found it's way to the repo.