WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Can't install usb-serial application  (Read 462 times)

Offline capke

  • WikiUser
  • *
  • Posts: 3
Can't install usb-serial application
« on: August 04, 2017, 08:00:28 AM »
Hey everyone,

I am a very new user trying to feel my way through using PiCore for the first time, and I have hit a rather annoying roadblock. I'm trying to install the usb-serial-4.8.17-tinycore.tcz to my Pi3, but when I use the command tce-load -wi usb-serial-4.8.17-tinycore.tcz, I get the following message:

tc@box:~$ tce-load -wi usb-serial-4.8.17-tinycore.tcz
Downloading: usb-serial-4.8.17-tinycore.tcz
Connecting to repo.tinycorelinux.net (89.22.99.37:80)
wget: server returned error: HTTP/1.1 404 Not Found
md5sum: usb-serial-4.8.17-tinycore.tcz.md5.txt: No such file or directory
Error on usb-serial-4.8.17-tinycore.tcz

I can see the usb-serial driver in the tcz repository ( newbielink:http://distro.ibiblio.org/tinycorelinux/8.x/x86/tcz/ [nonactive]), but maybe I am using the wrong one? I took this one directly from the Core website. I'm hoping this driver will let me use my USB to serial device I have, but without being able to download, I'm not able to find out. Any advice would be greatly appreciated!

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5470
Re: Can't install usb-serial application
« Reply #1 on: August 04, 2017, 08:04:32 AM »
Hi capke
That's the x86 repository, the one for Pi is here:
http://tinycorelinux.net/8.x/armv6/tcz/

Offline capke

  • WikiUser
  • *
  • Posts: 3
Re: Can't install usb-serial application
« Reply #2 on: August 04, 2017, 08:20:56 AM »
Ah, I see where I went wrong!

I attempted the new command with the proper usb-serial driver in your link, but I had the same error. I did a little investigating and found the 9.x repo, which I'm guessing is where the tce-load command dives into on the 9.0.3 piCore, and there is no usb-serial driver. Any chance this will be updated soon, or better yet, are there instructions on how to load from an old repo?

Thank you very much for your help! I like being able to see how this is supposed to work!

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5470
Re: Can't install usb-serial application
« Reply #3 on: August 04, 2017, 08:41:43 AM »
Hi capke
I doubt you could use one from the old repo. The numbers you see in the extension name (4.8.17) refer to the kernel
version it was compiled against. Since the version numbers don't match I think might even refuse to load.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9607
Re: Can't install usb-serial application
« Reply #4 on: August 05, 2017, 01:08:02 AM »
usb-serial extensions posted to piCore 9.x repos.

Note that you might be better off to download the extension like this:
Code: [Select]
$ tce-load -w usb-serial-KERNEL..which will download the correct extension for the version of piCore you are using.

Offline capke

  • WikiUser
  • *
  • Posts: 3
Re: Can't install usb-serial application
« Reply #5 on: August 13, 2017, 08:17:16 AM »
Thanks Juanito, I was able to install the driver. Unfortunately, I still can't find a ttyUSB connection. When I search using lsusb, it recognizes the usb device, but not that it is a serial port (I'm using 'dmesg | grep tty' to check for the converter). I have a XS885 from usconverters, and it uses the ftdi chipset. I made sure to download the libftdi, and after reboot, still no luck. Any advice would be greatly appreciated. Thanks again for your fast replies!

Offline patrikg

  • Sr. Member
  • ****
  • Posts: 287
Re: Can't install usb-serial application
« Reply #6 on: August 13, 2017, 10:43:11 PM »
Have you tried to monitor the udev ??
Try to run this command to see what the udev manager does to the sub event.

Code: (bash) [Select]
udevadm monitor

Offline flixxi

  • WikiUser
  • *
  • Posts: 4
Re: Can't install usb-serial application
« Reply #7 on: September 14, 2017, 03:02:03 PM »
I think I have the same problem here.

My Kernel version is 4.9.35-pcpCore (armv6l GNU/Linux), and from what I understood I should install something like  "usb-serial-4.9.35-pcpCore".
Is that assumption correct?

There is, of course, only "usb-serial-4.4.39-piCore+.tcz" available - I tried to install it but it didn't help.

What can I do to use my CH340 usb2serial interface? Were you able to solve the issue, capke?


Offline Greg Erskine

  • Full Member
  • ***
  • Posts: 198
Re: Can't install usb-serial application
« Reply #8 on: September 14, 2017, 05:12:04 PM »
Hi flixxi,

When you see "pcpCore" rather than "piCore" you know you are not using the standard release of piCore. You can not ask questions about piCorePlayer here, as the piCore developers will get upset. Better to ask at the squeezebox forum.

piCorePlayer doesn't always use the same kernel versions as piCore.

So, you need to go to the [Main Page] > [Extensions] web page, change the "Current repository" to "piCorePlayer sourceforge repository", then select the appropriate extension.

Sorry for going off topic piCore developers.

regards
Greg




Offline flixxi

  • WikiUser
  • *
  • Posts: 4
Re: Can't install usb-serial application
« Reply #9 on: September 15, 2017, 01:28:47 AM »
Hi Greg,

prior to my experiments with piCorePlayer I've never been in contact with piCore, and I assumed my system was standard piCore with only a few extra packages/scripts on top.
Sorry! And thank you for your help; I haven't tried yet but I strongly suspect that this is the clue that I needed to resolve the issue.
Best regards
Walter
« Last Edit: September 15, 2017, 01:32:59 AM by flixxi »