WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: 'user=' boot option broken by missing symlink in piCore 9.0.3.gz  (Read 171 times)

Offline cochon

  • WikiUser
  • *
  • Posts: 10
'user=' boot option broken by missing symlink in piCore 9.0.3.gz
« on: September 08, 2017, 01:26:51 PM »
The 'user=' boot option is processed by tc-config which explicitly calls /bin/adduser to add the user record, but this symlink to busybox is missing in 9.0.3.gz and the user is not added.

The link /bin/adduser -> busybox exists in the x86 branch, and both branches have /usr/sbin/adduser -> busybox, but this isn't called by tc-config. /bin/addgroup is affected similarly.

Cheers,

Phil.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9452
Re: 'user=' boot option broken by missing symlink in piCore 9.0.3.gz
« Reply #1 on: September 08, 2017, 11:23:19 PM »
/bin/addgroup isn't called in tc-config?

Offline cochon

  • WikiUser
  • *
  • Posts: 10
Re: 'user=' boot option broken by missing symlink in piCore 9.0.3.gz
« Reply #2 on: September 08, 2017, 11:52:33 PM »
Indeed no, but they tend to go hand in hand, and both are present in x86 but missing from pi, so I thought I'd mention it in case there was a knock on effect I'd not discovered.

I can contrive to put the user record and profile in persistent mydata.tgz, but the boot process runs tce-bootload as the missing user, so no extensions get loaded, which makes things hard on a headless pi :)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9452
Re: 'user=' boot option broken by missing symlink in piCore 9.0.3.gz
« Reply #3 on: September 09, 2017, 02:51:50 AM »
from piCore-9.0.3:
Code: [Select]
$ which adduser
/usr/sbin/adduser
$ which addgroup
/usr/sbin/addgroup
$ grep adduser /etc/init.d/tc-config
/bin/adduser -s /bin/sh -G staff -D "$USER"

..which would tend to indicate that tc-config needs adjusting

Offline cochon

  • WikiUser
  • *
  • Posts: 10
Re: 'user=' boot option broken by missing symlink in piCore 9.0.3.gz
« Reply #4 on: September 11, 2017, 08:37:21 AM »
That seems the most obvious fix, and as I've just discovered, the issue actually affects the recent 8.1.1 branch of x86 as well. I was still using 8.0.

So it's not a piCore specific problem at all. I assume that will filter over from this forum section to the main branch developers, if indeed they're not one and the same.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9452
Re: 'user=' boot option broken by missing symlink in piCore 9.0.3.gz
« Reply #5 on: September 11, 2017, 08:46:43 AM »
tc-config is already adjusted in tinycore git and tc-8.1.2 was ready to go with the fix, but now there's a busybox issue to sort out  :(