WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: How to avoid an automatic backup during logout?  (Read 318 times)

Offline mbertrand

  • Full Member
  • ***
  • Posts: 225
How to avoid an automatic backup during logout?
« on: September 06, 2017, 06:54:12 AM »
I know this topic was posted but it's been a long time ago. I've noticed that when I restart or shutdown that the default option is to do a backup first. I would like to default to NONE.
I've added a long time ago export BACKUP=0 in my .profile to make these changes but it does not seem to work?

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5471
Re: How to avoid an automatic backup during logout?
« Reply #1 on: September 06, 2017, 06:58:21 AM »
Hi mbertrand
If your home directory is not persistent, did you remember to backup your  .profile  file?

Offline mbertrand

  • Full Member
  • ***
  • Posts: 225
Re: How to avoid an automatic backup during logout?
« Reply #2 on: September 06, 2017, 07:11:11 AM »
Yes my .profile is backed up for sure

Offline polikuo

  • Full Member
  • ***
  • Posts: 245
Re: How to avoid an automatic backup during logout?
« Reply #3 on: September 06, 2017, 08:57:23 AM »
Which arch/version are you using ?

I just test it on PiCore 9 and it's just fine.

The exittc checks for the environment variable "BACKUP", are you sure you've exported it in your .profile ?

exittc.cxx
Code: [Select]
string backupDefault="1";
if ( getenv("BACKUP"))
backupDefault = getenv("BACKUP");

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5471
Re: How to avoid an automatic backup during logout?
« Reply #4 on: September 06, 2017, 09:06:29 AM »
Hi mbertrand
I just realized you said:
I've added a long time ago export BACKUP=0 in my .profile to make these changes but it does not seem to work?
If this is really true, you should have replaced  export BACKUP=1  with  export BACKUP=0  in your  .profile  file since that
export already exists.

Offline mbertrand

  • Full Member
  • ***
  • Posts: 225
Re: How to avoid an automatic backup during logout?
« Reply #5 on: September 06, 2017, 09:18:04 AM »
I've replaced with BACKUP=0 years ago and never realized when it stopped working until recently. I must add that we are still only at version TC 5.4.
If  I echo $BACKUP I get '0'.

Offline mbertrand

  • Full Member
  • ***
  • Posts: 225
Re: How to avoid an automatic backup during logout?
« Reply #6 on: September 06, 2017, 09:43:47 AM »
Ummmm..... I decided to take chance and compile the latest exittc hoping I would not have any problem with newer dependencies. I was able to compile.
Still have the same problem. I'm executing it from a terminal and I can see that the BACKUP=0 .

Offline mbertrand

  • Full Member
  • ***
  • Posts: 225
Re: How to avoid an automatic backup during logout?
« Reply #7 on: September 06, 2017, 10:26:11 AM »
Ok I know what is going on we have added the bootcode 'safebackup' a couple of years ago and exittc is looking for that and setting the backup option to 'safe'.