WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: sce-upadte indicate wrong updates  (Read 307 times)

Offline jls

  • Hero Member
  • *****
  • Posts: 2028
    • Core17
sce-upadte indicate wrong updates
« on: September 04, 2017, 12:55:34 PM »
Hi
Running sce-update I see
Code: [Select]
====  base updates  ====
alsa-modules-4.8.17-tinycore   dCore custom prebuilt
input-joystick-4.8.17-tinycore   dCore custom prebuilt

while in base I don't have those files and base has no .dep file

running
Code: [Select]
sce-update kernel-all-4.8.17-tinycore.sce
there are no updates
dCore user

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9326
Re: sce-upadte indicate wrong updates
« Reply #1 on: September 04, 2017, 02:43:11 PM »
I think the triggering an update or addition of alsa-modules-$kernel and input-joystick-$kernel is correct if you imported base.sce before I added alsa-modules-$kernel as a dep of alsa-utils, and alsa-modules-$kernel has input-joystick-$kernel listed as a dep of it.  I imported the same base.sce you have with the same /opt/debextra as part of testing enlightenment, and it contains alsa-utils and was also imported before I added the alsa modules as a dep of alsa-utils.  My base.sce did not contain the kernel module packages, but sce-update listed them in /tmp/updateavailable as updates, and updating base.sce installed those packages.  And running "sce-update base" after that saw no needed package updates. 

Re-import base.sce or update it and after rebooting run "sce-update base" to make sure you see no need for updates.  I am very interested in sce-update or any other dCore functions being 100% error free, thanks for testing and reporting.


Offline jls

  • Hero Member
  • *****
  • Posts: 2028
    • Core17
Re: sce-upadte indicate wrong updates
« Reply #2 on: September 05, 2017, 12:10:50 PM »
Hi
Code: [Select]
sce-update base
indicates no updates available, so it's ok.
thanks
dCore user

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9326
Re: sce-upadte indicate wrong updates
« Reply #3 on: September 05, 2017, 03:40:30 PM »
I have updated sce-update to behave like the following, it means the removing of the Recommends and Suggests option during sce-import.  I will not even take a poll on keeping the Recommends and Suggests options as they were a test of concept, but they are completely not in keeping with the dCore way.  They simply turned what would be a 20 or 30 megabyte SCE into one that was about a Gigabyte that included many unrelated packages and it is not in keeping with the dCore way.  Though I am not criticizing those options for a Debian/Ubuntu hard drive install.  And by trimming the Recommends and Suggests from the DEBINX data, sce-import and sce-update will see better performance.

If base.sce does not have alsa-modules-4.18.7-tinycore and a it has been added in the dependencies on the server, the running sce-update on base.sce would produce the following in /tmp/updateavailable:

Code: [Select]
====  base updates  ====
alsa-modules-4.8.17-tinycore   dCore custom prebuilt is missing in base.sce or it's SCE deps.
input-joystick-4.8.17-tinycore   dCore custom prebuilt is missing in base.sce or it's SCE deps.

And once updating with that info, if those dependencies are removed on the server but contained in base.sce, then running sce-update on base.sce would show the below:

Code: [Select]
====  base updates  ====
alsa-modules-4.8.17-tinycore   is no longer needed by base.sce or it's SCE deps.
input-joystick-4.8.17-tinycore   is no longer needed by base.sce or it's SCE deps.

This would be the case whether prebuilt, extra repo, main repo, etc.  It should help save confusion on sce-update by giving more specific info in /tmp/updateavailabe.  I will test this more and upload tomorrow.  And the Recommends and Suggests option is now removed.

Offline jls

  • Hero Member
  • *****
  • Posts: 2028
    • Core17
Re: sce-upadte indicate wrong updates
« Reply #4 on: September 06, 2017, 03:34:14 AM »
Hello
The missing info means that it will be auto imported I guess
dCore user

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9326
Re: sce-upadte indicate wrong updates
« Reply #5 on: September 06, 2017, 06:42:06 AM »
Actually, the wording will be like below to make it more clear:

Code: [Select]
====  base updates  ====
alsa-modules-4.8.17-tinycore    dCore custom prebuilt    is a new dependency in base.sce or it's SCE deps.
input-joystick-4.8.17-tinycore    dCore custom prebuilt    is a new dependency in base.sce or it's SCE deps.

Code: [Select]
====  base updates  ====
alsa-modules-4.8.17-tinycore    dCore custom prebuilt    has been removed as a dependency in base.sce or it's SCE deps.
input-joystick-4.8.17-tinycore    dCore custom prebuilt    has been removed as a dependency in base.sce or it's SCE deps.