WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: My first TCZ bilding.  (Read 526 times)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9550
Re: My first TCZ bilding.
« Reply #15 on: August 10, 2017, 07:00:53 AM »
hostapd posted in case you'd like to test it

Offline bonbob

  • Jr. Member
  • **
  • Posts: 53
Re: My first TCZ bilding.
« Reply #16 on: August 12, 2017, 12:52:31 AM »
Another errors has appeared using your CONFIG.
Code: [Select]
../src/drivers/driver_nl80211.o: In function `nl80211_handle_destroy':
/home/tc/hostapd-2.6/hostapd/../src/drivers/driver_nl80211.c:80: undefined reference to `nl_handle_destroy'
../src/drivers/driver_nl80211.o: In function `nl80211_handle_alloc':
/home/tc/hostapd-2.6/hostapd/../src/drivers/driver_nl80211.c:58: undefined reference to `nl_handle_alloc_cb'
../src/ap/hw_features.o: In function `hostapd_check_chans':
/home/tc/hostapd-2.6/hostapd/../src/ap/hw_features.c:820: undefined reference to `acs_init'
collect2: error: ld returned 1 exit status
make: *** [Makefile:1063: hostapd] Error 1

Leave this problem and don't waste time on it. I already have hostapd-2.6 with N-mode support and this enough for me.
« Last Edit: August 12, 2017, 12:59:45 AM by bonbob »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9550
Re: My first TCZ bilding.
« Reply #17 on: August 12, 2017, 02:30:01 AM »
That looks like it's trying to use the incorrect libnl?

Anyway, as mentioned, I posted hostapd(2.6) to the tc8.x x86 repo, you can try it if you like.

Offline bonbob

  • Jr. Member
  • **
  • Posts: 53
Re: My first TCZ bilding.
« Reply #18 on: August 12, 2017, 05:43:49 AM »
The real error is
Code: [Select]
make: *** No rule to make target '/home/tc/hostapd-2.6/src/netlink/genl/genl.h', needed by '../src/drivers/driver_nl80211.o'.  Stop.

Even with your config. Errors i have posted before became by my mistake. I did not deleted folder scr/netlink.
After deleting compiler still searching genl.h, but i see it really present in the system by path /usr/local/include/libnl3/netlink/genl/.
I don't know why compiler don't see this include-path.

This lines ignoring too:
Code: [Select]
CFLAGS += -I/usr/local/include/libnl3
LIBS += -L/usr/local/lib

I already installed new extension and use it. Working good. Except one little thing. It does not show any information duiring launch process. No errors answer, no success answer. Just Empty line. Your newer will know why your hostapd not launch and where mistake is in config file.