WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Busybox is using an older version, or a custom version of wget.  (Read 267 times)

Offline bonbob

  • Jr. Member
  • **
  • Posts: 56
Busybox is using an older version, or a custom version of wget that does not have the -r option.

wget not have "recursive" option. TCL ver.8.0 32 bit.

How it may be fixed without any recompiles?

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5472
Re: Busybox is using an older version, or a custom version of wget.
« Reply #1 on: August 04, 2017, 06:32:03 AM »
Hi bonbob
Then you may just have to install  wget.tcz.

Offline bonbob

  • Jr. Member
  • **
  • Posts: 56
Re: Busybox is using an older version, or a custom version of wget.
« Reply #2 on: August 04, 2017, 06:34:29 AM »
Already done. Result is the same.

Quote
wget: invalid option -- 'r'
BusyBox v1.25.1 (2016-11-15 12:14:29 UTC) multi-call binary.

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 2532
Re: Busybox is using an older version, or a custom version of wget.
« Reply #3 on: August 04, 2017, 07:13:33 AM »
You may have installed gnu wget but are perhaps still calling busybox version. ?



Offline bonbob

  • Jr. Member
  • **
  • Posts: 56
Re: Busybox is using an older version, or a custom version of wget.
« Reply #4 on: August 04, 2017, 07:36:56 AM »
That is right. I reconnect from my ssh console and another wget has appeared. With -r option. Thanks.

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 2532
Re: Busybox is using an older version, or a custom version of wget.
« Reply #5 on: August 04, 2017, 07:48:21 AM »
Using the path to a program along with the command will resolve this issue