WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Firefox: "Illegal instruction" "trap invalid opcode" error  (Read 348 times)

Offline joespr

  • WikiUser
  • *
  • Posts: 6
Firefox: "Illegal instruction" "trap invalid opcode" error
« on: July 31, 2017, 07:26:26 AM »
Hi TinyCore,

Happily reinstalled Tiny Core 8.0 onto the PC's HD. Downloaded and ran firefox-getLatest. Seemingly installed successfully. Even created a Firefox icon in the toolbar! Added firefox.tcz to my onboot.lst file, rebooted.

But when I try to launch Firefox, I get the following.
1. Clicking the icon, does not launch.

2. Attempting to launch from Terminal command line gets "Illegal instruction" message.

3. dmesg shows the following:
  traps: firefox[9248] trap invalid opcode ip:8066b91 sp:bfd8a2d0 error:0 in firefox[8048000+29000]

where the four digit number in the first square brackets, and the sp: value vary.

I seem to have gtk3 installed ok.

Any advice or feedback?

Thank you for your time.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9634
Re: Firefox: "Illegal instruction" "trap invalid opcode" error
« Reply #1 on: July 31, 2017, 07:28:18 AM »
What processor do you have?

I'd guess that firefox or one of its deps has a limit of i586 or i686.

Does the fifth browser extension work OK?

Offline joespr

  • WikiUser
  • *
  • Posts: 6
Re: Firefox: "Illegal instruction" "trap invalid opcode" error
« Reply #2 on: July 31, 2017, 08:31:55 AM »
Thanks for the quick reply.
Intel Celeron (32 bit), 512 MB RAM, Speed 1300 MHz.

>>Does the fifth browser extension work OK?
I dont know what this means. What is "fifth browser extension"?

According to the info about firefox-getLatest as displayed in the Apps Installer, firefox-getLatest includes both x86 and x86_64, so it should be ok. But I am not sure if I need to do something different after install ...

Offline polikuo

  • Sr. Member
  • ****
  • Posts: 251
Re: Firefox: "Illegal instruction" "trap invalid opcode" error
« Reply #3 on: July 31, 2017, 09:08:24 AM »
>>Does the fifth browser extension work OK?
I dont know what this means. What is "fifth browser extension"?

fifth is literally a web browser, just like firefox, but much lighter.

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 9625
Re: Firefox: "Illegal instruction" "trap invalid opcode" error
« Reply #4 on: July 31, 2017, 09:14:22 AM »
Firefox requires* SSE2 nowadays. Your cpu is too old to run it.

*unless you build it yourself, but that option will go away sometime too
The only barriers that can stop you are the ones you create yourself.

Offline joespr

  • WikiUser
  • *
  • Posts: 6
Re: Firefox: "Illegal instruction" "trap invalid opcode" error
« Reply #5 on: July 31, 2017, 09:47:08 AM »
Thank you. That clarifies things.
I was able install and use Opera9 and Dillo. Will try fifth later.

Case closed.