WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: truecrypt strange problem on dismount  (Read 279 times)

Offline aug

  • Jr. Member
  • **
  • Posts: 74
truecrypt strange problem on dismount
« on: July 23, 2017, 09:09:49 AM »
Hi,
i have installed truecrypt - works fine, i can create and mount volumes and perform all file/folder operations without and problem. During mount tc creates two folders (/mnt/dm-0 and /mnt/truecrypt1) with the same content. When i try to dismount a volume a popup pops up with the message "device-mapper: remove ioctl failed: Device or resource busy Command failed" ... so what's wrong?

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5472
Re: truecrypt strange problem on dismount
« Reply #1 on: July 23, 2017, 11:07:24 AM »
Hi aug
That  message indicates that something on that volume is still in use. It could be a file open in an editor. A terminal whose
prompt points to that volume. Possibly a program or script from that volume is executing. Midnight Commander open on
a directory in that volume would also cause it.

Offline aug

  • Jr. Member
  • **
  • Posts: 74
Re: truecrypt strange problem on dismount
« Reply #2 on: July 23, 2017, 11:38:20 AM »
Hi aug
That  message indicates that something on that volume is still in use. It could be a file open in an editor. A terminal whose
prompt points to that volume. Possibly a program or script from that volume is executing. Midnight Commander open on
a directory in that volume would also cause it.
No closed everything before tried to dismount.... ps shows a process dmcrypt_write which can't be killed (even not with sudo) think it has something to do with dmcrypt. I also did not understand why two identical folders under /mnt are created.. and i see that after i try to dismount the truecrypt1 folder has vanished and only the dm-0 folder exists (complete with the content of the crypted volume).
User truecrypt for years now on differnet linux system but never saw this behaviour.

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5472
Re: truecrypt strange problem on dismount
« Reply #3 on: July 23, 2017, 03:53:15 PM »
Hi aug
Try running:
Code: [Select]
fuser -m /mnt/dm-0or
Code: [Select]
fuser -m mnt/truecrypt1to get a list of the processes accessing the volume.

Offline aug

  • Jr. Member
  • **
  • Posts: 74
Re: truecrypt strange problem on dismount
« Reply #4 on: July 24, 2017, 01:24:36 AM »
For /mnt/dm-0 it get a list of 13 processes, none for /mnt/truecrypt1. It seems to work (dismount) if i only access /mnt/truecrypt1 and never /mnt/dm-0. The problem is that after mounting pcmanfm only shows the dm-0 mount and not the truecrypt1 - very strange.

Offline aug

  • Jr. Member
  • **
  • Posts: 74
Re: truecrypt strange problem on dismount
« Reply #5 on: July 24, 2017, 01:28:09 AM »
Everything under /mnt is mounted as root/root only truecrypt1 is mounted as tc/staff and don't appear in pcmanfm.