WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Compiling error - missing ssl  (Read 172 times)

Offline remus

  • Sr. Member
  • ****
  • Posts: 320
Compiling error - missing ssl
« on: July 10, 2017, 09:13:27 PM »
Hi all,

I'm compiling mailsend on microcore 3.8.4 (Yes I know its old, but its worked flawlessly for us for a long time and I have no need to change atm)

Source : https://github.com/muquit/mailsend/releases
Docs : https://github.com/muquit/mailsend/blob/master/README.asc#linuxunixmac-os-x

My setup env so far
Code: [Select]
tce-load -wil compiletc.tcz
tce-load -wil squashfs-tools-4.x.tcz
tce-load -wil python-dev.tcz
tce-load -wil submitqc.tcz


export CFLAGS="-march=i486 -mtune=i686 -Os -pipe"
export CXXFLAGS="-march=i486 -mtune=i686 -Os -pipe -fno-exceptions -fno-rtti"
export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:/usr/lib/pkgconfig

Initial compile commands
Code: [Select]
wget --no-check-certificate https://github.com/muquit/mailsend/archive/1.19.tar.gz
tar -xzf 1.19
cd mailsend-1.19/
sh ./configure --with-openssl=/usr/local/etc --prefix=/usr/local/mailsend

I've tried a few different variations for --with-openssl= such as /usr /usr/local and /usr/local/lib but I keep getting the following output
Code: [Select]
checking for OpenSSL... no
Comments and suggestions welcome
Thank you.



Live long and prosper.

Offline remus

  • Sr. Member
  • ****
  • Posts: 320
[SOLVED] Re: Compiling error - missing ssl
« Reply #1 on: July 10, 2017, 09:46:08 PM »
Solved it

Had to install openssl dev tcz - openssl-0.9.8-dev.tcz

Thanks :)
Live long and prosper.