WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Mplayer either plays video or audio.  (Read 1178 times)

Offline tcFan

  • WikiUser
  • *
  • Posts: 36
Mplayer either plays video or audio.
« on: June 29, 2017, 09:12:42 AM »

compiled mplayer (with the get_mplayer ext). First time everything went fine, I chose the CLI option (1) and it ran great but complained about alsa.conf (not found). Since I didn`t want to configure alsa and already have pulseaudio working I proceeded to re-compile the thing but this time loading the pulse-dev ext, when prompted.

It detected and installed fine and it does play the audio (i can even control it from pavu) but the video never shows up. Tried downloading + loading libavcodecs to no avail.

The script does warn to manually add to .dep any libs/exts that might have been needed but, technically this was for forced --enable flags, right? It does complain of not finding libbz2 when I first run it but loading it is enough to get the sound playing. So maybe it is something else missing, because it crashes midway, as if it has given up, it never gets to displaying the usual statistics or help commands when normally playing files.

The script also mentioned creating a config file for old hardware, I deleted the previous one to get this (even though I probably do not need it but it could be stuff laying around from previous attempts / installs).

Regular Mplayer, which was playing everything fine (only slow) also stopped working (same thing, the audio plays)

help? : -)
« Last Edit: June 29, 2017, 09:14:24 AM by tcFan »

Offline tcFan

  • WikiUser
  • *
  • Posts: 36
Re: Mplayer either plays video or audio.
« Reply #1 on: July 14, 2017, 04:22:26 PM »
okay, which steps should I take to purge the system of any files? (so I can try again, maybe if I try disabling alsa and forcing pulse? but first I`ll let it autodetect after loading everything)

Is removing the .mplayer dir, inside home, enough? (not sure if this was it, but the regular mplayer plays video now, but no sound)

I`m removing the regular mplayer too, maybe it thinks I`m trying to load it instead of running the other one?

Edit: OWAIT! It worked! .. I think it was the ".mplayer" directory... now we have a error message to work with, please take a look:

Code: [Select]
[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or directory
[AO_ALSA] alsa-lib: conf.c:3710:(snd_config_hook_load) cannot stat file/directory /usr/local/etc/alsa/cards/aliases.conf
[AO_ALSA] alsa-lib: pcm.c:2495:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.default
[AO_ALSA] Playback open error: No such file or directory
W: [pulseaudio] caps.c: Normally all extra capabilities would be dropped now, but that's impossible because this Pulseaudio was built without libcap support.
AO: [pulse] Init failed: Connection refused
DVB card number must be between 1 and 4

And indeed, it`s reverse now: the video plays but the audio don`t. The first message for ALSA was the same I mentioned earlier, which I don`t know how to config. But if we could figure why it`s trying to connect to pulse with a wrong card range, maybe that would fix it.

btw, nevermind that "caps" message, it also gives when browsers connect to pulse.
« Last Edit: July 14, 2017, 04:49:09 PM by tcFan »

Offline tcFan

  • WikiUser
  • *
  • Posts: 36
Re: Mplayer either plays video or audio.
« Reply #2 on: July 14, 2017, 05:03:19 PM »
WTH, it worked!

apparently, pulseaudio crashed somehow before that test. (maybe it was mplayer itself but the fact is that even pavu couldn`t connect)
Closed the browser and tested pavu again, it connected.. then mplayer was able to as well!

sorry for the pollution :)