WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: pavucontrol.tcz requires libGLESv2.tcz on its .dep file.  (Read 332 times)

Offline tcFan

  • WikiUser
  • *
  • Posts: 30
pavucontrol.tcz requires libGLESv2.tcz on its .dep file.
« on: June 22, 2017, 02:32:30 PM »
Apparently none of its deps require it either.

Loading manually (or adding it to the .dep of course) solves the issue.

Cheers.

Online coreplayer2

  • Hero Member
  • *****
  • Posts: 2502
Re: pavucontrol.tcz requires libGLESv2.tcz on its .dep file.
« Reply #1 on: June 22, 2017, 04:44:57 PM »
I couldn't help but wonder why an audio control app would need an OpenGL library..? 

so..
Code: [Select]
/usr/local/lib $ ldd libGLESv2.so
        linux-gate.so.1 (0xb771c000)
        libdrm.so.2 => /usr/local/lib/libdrm.so.2 (0xb76fc000)
        libm.so.6 => /lib/libm.so.6 (0xb76c1000)
        libdl.so.2 => /lib/libdl.so.2 (0xb76bd000)
        libglapi.so.0 => /usr/local/lib/libglapi.so.0 (0xb76a2000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xb768a000)
        libc.so.6 => /lib/libc.so.6 (0xb7575000)
        /lib/ld-linux.so.2 (0x800b6000)
/usr/local/lib $
I don't see any dependency on libGLESv2??

What gives you this impression?

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5392
Re: pavucontrol.tcz requires libGLESv2.tcz on its .dep file.
« Reply #2 on: June 22, 2017, 05:09:30 PM »
Hi coreplayer2
Running  ldd  on  libGLESv2.so  won't return a dependency on  libGLESv2.so. Maybe you meant:
Code: [Select]
ldd /usr/local/bin/pavucontrol

Online coreplayer2

  • Hero Member
  • *****
  • Posts: 2502
Re: pavucontrol.tcz requires libGLESv2.tcz on its .dep file.
« Reply #3 on: June 22, 2017, 05:23:52 PM »
LOL   yes, what was I thinking??

Code: [Select]
ldd /usr/local/bin/pavucontrol | grep libGLESv2
« Last Edit: June 22, 2017, 05:30:21 PM by coreplayer2 »

Online coreplayer2

  • Hero Member
  • *****
  • Posts: 2502
Re: pavucontrol.tcz requires libGLESv2.tcz on its .dep file.
« Reply #4 on: June 22, 2017, 07:52:29 PM »
I'm still curious why OpenGL would be required..

However in TC-8 ldd reports libGLESv2 is required, whilst in TC-7 (where I was looking.) it is not.


« Last Edit: June 22, 2017, 08:01:38 PM by coreplayer2 »

Offline tcFan

  • WikiUser
  • *
  • Posts: 30
Re: pavucontrol.tcz requires libGLESv2.tcz on its .dep file.
« Reply #5 on: June 23, 2017, 01:22:24 PM »
All I know is that it complained and failed to start.

I could speculate and say it may be for some graphics function, which is still weird as they should use gtk3 for everything? No idea. lol : -)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9465
Re: pavucontrol.tcz requires libGLESv2.tcz on its .dep file.
« Reply #6 on: June 24, 2017, 05:03:52 AM »
libGLESv2 is in the tree file for pavucontrol - I would guess that your version of cairo or cairo's dep file needs updating?

Offline tcFan

  • WikiUser
  • *
  • Posts: 30
Re: pavucontrol.tcz requires libGLESv2.tcz on its .dep file.
« Reply #7 on: June 24, 2017, 02:28:45 PM »
It's not out of the realm of possibility that I tested this before I updated everything, yes.. ^.^

Online coreplayer2

  • Hero Member
  • *****
  • Posts: 2502
Re: pavucontrol.tcz requires libGLESv2.tcz on its .dep file.
« Reply #8 on: June 25, 2017, 01:57:43 PM »
I'm also thinking a dep file needs updating or a dependency extension which would eventually lead to libGLESv2 has not loaded, because in tc-8 cairo was built against libGLESv2.

For what it's worth:
In 7.x/x86 repo:
 libcairo.so was not built against libGLESv2  (libGLESv2 is optional) as a result pavucontrol does not require libGLESv2

However, in these repo's
7.x/x86_64
8.x/x86_64
8.x/x86

libcairo.so was compiled with libGLESv2 support.

If you follow the dep tree either pavucontrol or pulseaudio lists:
 gtkmm/gtk3
  pango
   cairo
    libGLESv2
as dependencies

:)
« Last Edit: June 25, 2017, 01:59:16 PM by coreplayer2 »