WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: VT8237A/VT8251 No Sound  (Read 1423 times)

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4243
Re: VT8237A/VT8251 No Sound
« Reply #15 on: June 13, 2017, 09:29:49 AM »
Check your mixer settings.

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1553
Re: VT8237A/VT8251 No Sound
« Reply #16 on: June 13, 2017, 09:31:47 AM »
Quote
After click wifi icon to connect to WLAN, go to /etc to find a file called wpa_supplicant.conf, copy it to /opt so it becomes persistent, this file contains credentials of your WLAN, it's generated every time you click the icon to connect.
I don't understand why this should be necessary.
WiFi credentials are stored in  ~/wifi.db  and the first entry is used for auto-connecting via  wifi.sh -a .

Since you mentioned you would make a new start, is pulseaudio installed again?
You don't need Pulseaudio for MPlayer if you're not doing anything special.
Download a copy and keep it handy: Core book ;)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9465
Re: VT8237A/VT8251 No Sound
« Reply #17 on: June 13, 2017, 09:54:55 AM »
Trying
$ speaker-test -Ddefault:0 -c2 -t wav -l1

... no sound.

Did you get an error message?, did you try -Ddefault:1, what did "aplay -l" give?

Offline evertvaningen

  • Jr. Member
  • **
  • Posts: 60
Re: VT8237A/VT8251 No Sound
« Reply #18 on: June 13, 2017, 10:15:18 AM »
Quote
After click wifi icon to connect to WLAN, go to /etc to find a file called wpa_supplicant.conf, copy it to /opt so it becomes persistent, this file contains credentials of your WLAN, it's generated every time you click the icon to connect.
I don't understand why this should be necessary.
WiFi credentials are stored in  ~/wifi.db  and the first entry is used for auto-connecting via  wifi.sh -a .

Since you mentioned you would make a new start, is pulseaudio installed again?
You don't need Pulseaudio for MPlayer if you're not doing anything special.

How would you do that part?
I don't know what i'm doing and no Pulseaudio is not installed.

Offline evertvaningen

  • Jr. Member
  • **
  • Posts: 60
Re: VT8237A/VT8251 No Sound
« Reply #19 on: June 13, 2017, 10:18:22 AM »
Trying
$ speaker-test -Ddefault:0 -c2 -t wav -l1

... no sound.

Did you get an error message?, did you try -Ddefault:1, what did "aplay -l" give?

tc@box:~$ speaker-test -D default:0 -c 2 -t wav -l1

speaker-test 1.1.3

Playback device is default:0
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 2048 to 8192
Period size range from 1024 to 1024
Using max buffer size 8192
Periods = 4
was set period_size = 1024
was set buffer_size = 8192
 0 - Front Left
 1 - Front Right
Time per period = 2.855988

tc@box:~$ aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
default:CARD=VT82xx
    HDA VIA VT82xx, VT1708S Analog
    Default Audio Device
sysdefault:CARD=VT82xx
    HDA VIA VT82xx, VT1708S Analog
    Default Audio Device
front:CARD=VT82xx,DEV=0
    HDA VIA VT82xx, VT1708S Analog
    Front speakers
surround21:CARD=VT82xx,DEV=0
    HDA VIA VT82xx, VT1708S Analog
    2.1 Surround output to Front and Subwoofer speakers
surround40:CARD=VT82xx,DEV=0
    HDA VIA VT82xx, VT1708S Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=VT82xx,DEV=0
    HDA VIA VT82xx, VT1708S Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=VT82xx,DEV=0
    HDA VIA VT82xx, VT1708S Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=VT82xx,DEV=0
    HDA VIA VT82xx, VT1708S Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=VT82xx,DEV=0
    HDA VIA VT82xx, VT1708S Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers

Offline evertvaningen

  • Jr. Member
  • **
  • Posts: 60
Re: VT8237A/VT8251 No Sound
« Reply #20 on: June 13, 2017, 10:45:32 AM »
Here there talking about a bug for my hardware...

https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1033299


Is this alarming?

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1553
Re: VT8237A/VT8251 No Sound
« Reply #21 on: June 13, 2017, 11:08:14 AM »
How would you do that part?

When a connection to a WIFI network is successfully established via  wifi.sh , an entry is created in  ~/wifi.db , containing SSID and key. The first entry is used for auto-connect.
Download a copy and keep it handy: Core book ;)

Offline evertvaningen

  • Jr. Member
  • **
  • Posts: 60
Re: VT8237A/VT8251 No Sound
« Reply #22 on: June 13, 2017, 12:04:13 PM »
How can I get this Hardware to generate sound waves?  :'(

It did work but after reboot it's gone...


I really appreciate your attention to this matter ❤️

Offline evertvaningen

  • Jr. Member
  • **
  • Posts: 60
Re: VT8237A/VT8251 No Sound
« Reply #23 on: June 13, 2017, 12:36:53 PM »
I'll reinstall and try PulseAudio this time.

Installing PulseAudio and pavucontrol worked for me but I needed first to do what was mentioned in the description of PulseAudio.
« Last Edit: June 13, 2017, 01:09:44 PM by evertvaningen »

Offline evertvaningen

  • Jr. Member
  • **
  • Posts: 60
Re: VT8237A/VT8251 No Sound
« Reply #24 on: June 13, 2017, 01:15:10 PM »
This is so weird:

After reboot I click on Pavucontrol... unmute Analog Output... set's audio volume to 100%

Why do I need to do this?
Can this be automated on boot?
« Last Edit: June 13, 2017, 01:20:19 PM by evertvaningen »

Offline evertvaningen

  • Jr. Member
  • **
  • Posts: 60
Re: VT8237A/VT8251 No Sound
« Reply #25 on: June 13, 2017, 01:51:04 PM »
I used Alsamixer and try to disable the Auto-mute but the option isn't there to store with...

sudo alsactl store 0

Even when everything is unmuted and volume at 100% I can get sound with the speaker-test.
When reboot it is auto-muted again, please help.

Online coreplayer2

  • Hero Member
  • *****
  • Posts: 2502
Re: VT8237A/VT8251 No Sound
« Reply #26 on: June 13, 2017, 02:59:52 PM »
Hello

Assuming you made a backup of the asound.state which failed to restore the master on reboot, then you might need to set the desired volume as I did since I've not had any luck using alsactl command since I bought new hardware..


Also assuming only the master volume requires unmuting, otherwise we may need to add more unmute commands
Code: [Select]
echo "amixer set "Master" 80 unmute" > ~/.X.d/alsaunmute
add  ~/.X.d/alsaunmute  to backup unless home is also on persistent storage

80% is my desired volume on reboot

good luck
« Last Edit: June 13, 2017, 03:01:30 PM by coreplayer2 »

Offline evertvaningen

  • Jr. Member
  • **
  • Posts: 60
Re: VT8237A/VT8251 No Sound
« Reply #27 on: June 13, 2017, 03:01:53 PM »
AlsaMixer is unable keep settings :s I did get to save the unmute.

I tried editing the config file for the settings but still on reboot it resets.

Online coreplayer2

  • Hero Member
  • *****
  • Posts: 2502
Re: VT8237A/VT8251 No Sound
« Reply #28 on: June 13, 2017, 03:04:13 PM »
yes but did you execute the command as explained..?

Quote
AlsaMixer is unable keep settings
  With this method we don't really care,
because here we're not asking alsamixer to save any settings..   alsamixer will unmute and set the master volume on reboot

amixer set "Master" 80 unmute  is instructing alsamixer to set the volume and unmute after boot.  It's a different approach to saving the settings before you reboot


PS, this method may require you to remove the asound.state from your backup
« Last Edit: June 13, 2017, 03:15:02 PM by coreplayer2 »

Offline evertvaningen

  • Jr. Member
  • **
  • Posts: 60
Re: VT8237A/VT8251 No Sound
« Reply #29 on: June 13, 2017, 03:17:20 PM »
Quote
Also assuming only the master volume requires unmuting, otherwise we may need to add more unmute commands

echo "amixer set "Master" 80 unmute" > ~/.X.d/alsaunmute

add  ~/.X.d/alsaunmute  to backup unless home is also on persistent storage

80% is my desired volume on reboot

I'll try that in the morning, Thank you :P

Quote
With this method we don't really care
Well excuse me, princess