WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: VT8237A/VT8251 No Sound  (Read 1136 times)

Offline evertvaningen

  • Jr. Member
  • **
  • Posts: 60
VT8237A/VT8251 No Sound
« on: June 13, 2017, 05:04:49 AM »
lspci output: Audio device: VIA Tecknologies, Inc. VT8237A/VT8251 HDA Controller (rev 20)
Installed: pulseaudio.tcz, mpg123.tcz and mplayer.tcz

[I did this - from pulseaudio description]
howto:
                alsa needs to be working for whatever sound device you have
                exit to console
                create ~/.X.d/dbus containing:
                "dbus-launch --sh-syntax --exit-with-session"
                startx
                $ pulseaudio -vv [to test]
                create ~/.X.d/pulseaudio containing:
                "pulseaudio -D" [once tested]

Opened Mplayer with http://91.221.151.155:80/;?.mp3 in terminal.

It goes streaming but not sound, what do I need to do to get this working?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9282
Re: VT8237A/VT8251 No Sound
« Reply #1 on: June 13, 2017, 05:16:52 AM »
It might be a good idea to load pavucontrol and check where the sound output is routed to.

Online Misalf

  • Hero Member
  • *****
  • Posts: 1528
Re: VT8237A/VT8251 No Sound
« Reply #2 on: June 13, 2017, 05:19:27 AM »
Or maybe loading only  alsa.tcz  isn't enough.
Code: [Select]
tce-load -w alsa-config.tcz
and manually add  alsa-config.tcz  just before  alsa.tcz  in your onboot list file. Then reboot.
Download a copy and keep it handy: Core book ;)

Offline evertvaningen

  • Jr. Member
  • **
  • Posts: 60
Re: VT8237A/VT8251 No Sound
« Reply #3 on: June 13, 2017, 05:26:46 AM »
It might be a good idea to load pavucontrol and check where the sound output is routed to.

Build-in Audio Analog Stereo
Port: Analog Output

Only Analog Output is selectable.

Offline evertvaningen

  • Jr. Member
  • **
  • Posts: 60
Re: VT8237A/VT8251 No Sound
« Reply #4 on: June 13, 2017, 05:36:12 AM »
Or maybe loading only  alsa.tcz  isn't enough.
Code: [Select]
tce-load -w alsa-config.tcz
and manually add  alsa-config.tcz  just before  alsa.tcz  in your onboot list file. Then reboot.

That is the location of the onboot list file?

Online Misalf

  • Hero Member
  • *****
  • Posts: 1528
Re: VT8237A/VT8251 No Sound
« Reply #5 on: June 13, 2017, 05:45:11 AM »
/etc/sysconfig/tcedir/onboot.lst
http://tinycorelinux.net/book.html
Download a copy and keep it handy: Core book ;)

Offline evertvaningen

  • Jr. Member
  • **
  • Posts: 60
Re: VT8237A/VT8251 No Sound
« Reply #6 on: June 13, 2017, 05:58:36 AM »
Or maybe loading only  alsa.tcz  isn't enough.
Code: [Select]
tce-load -w alsa-config.tcz
and manually add  alsa-config.tcz  just before  alsa.tcz  in your onboot list file. Then reboot.

It worked!

pavucontrol of not effected, I cant change the volume <- how to fix?


I am writing a project for a Internet Radio on a HP t510. When it's done can I post it here on the form for everyone to enjoy?


After reboot, audio not working again.
« Last Edit: June 13, 2017, 06:09:29 AM by evertvaningen »

Online Misalf

  • Hero Member
  • *****
  • Posts: 1528
Re: VT8237A/VT8251 No Sound
« Reply #7 on: June 13, 2017, 06:20:54 AM »
I'm not using Pulse, so can't tell much about that one.
However, to save ALSA settings, run
Code: [Select]
sudo alsactl store

... and to make this persist across reboots, run
Code: [Select]
echo "usr/local/etc/alsa/asound.state" >> /opt/.filetool.lst
... and, of course, make a backup
Code: [Select]
filetool.sh -b
Download a copy and keep it handy: Core book ;)

Offline evertvaningen

  • Jr. Member
  • **
  • Posts: 60
Re: VT8237A/VT8251 No Sound
« Reply #8 on: June 13, 2017, 07:00:58 AM »
I'm not using Pulse, so can't tell much about that one.
However, to save ALSA settings, run
Code: [Select]
sudo alsactl store

... and to make this persist across reboots, run
Code: [Select]
echo "usr/local/etc/alsa/asound.state" >> /opt/.filetool.lst
... and, of course, make a backup
Code: [Select]
filetool.sh -b

I rebooted after that and put mplayer http://91.221.151.155:80/;?.mp3 into terminal...

No sound :(

tc@box:~$ mplayer http://91.221.151.155:80/;?.mp3
MPlayer 1.1-4.9.1 (C) 2000-2012 MPlayer Team
MMX supported but disabled
MMX2 supported but disabled
SSE supported but disabled
SSE2 supported but disabled

Playing http://91.221.151.155:80/.
Connecting to server 91.221.151.155[91.221.151.155]: 80...

Name   : Arrow Classic Rock
Genre  : Rock
Website: http://www.arrow.nl
Public : no
Bitrate: 128kbit/s
Cache size set to 320 KBytes
Cache fill:  0.00% (0 bytes)   

Audio only file format detected.
=========================================================
Requested audio codec family [mpg123] (afm=mpg123) not available.
Enable it at compilation.
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
libavcodec version 54.23.100 (internal)
AUDIO: 44100 Hz, 2 ch, floatle, 128.0 kbit/4.54% (ratio: 16000->352800)
Selected audio codec: [ffmp3float] afm: ffmpeg (FFmpeg MPEG layer-3 audio)
=========================================================
[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or directory
AO: [alsa] 48000Hz 2ch floatle (4 bytes per sample)
Video: no video
Starting playback...
/bin/sh: ?.mp3: not foundnknown)  3.9% 18%
« Last Edit: June 13, 2017, 07:04:55 AM by evertvaningen »

Online Misalf

  • Hero Member
  • *****
  • Posts: 1528
Re: VT8237A/VT8251 No Sound
« Reply #9 on: June 13, 2017, 07:12:33 AM »
Quote
/bin/sh: ?.mp3: not foundnknown)  3.9% 18%
Use quotes for URLs
Code: [Select]
mplayer "http://91.221.151.155:80/;?.mp3"
Download a copy and keep it handy: Core book ;)

Offline evertvaningen

  • Jr. Member
  • **
  • Posts: 60
Re: VT8237A/VT8251 No Sound
« Reply #10 on: June 13, 2017, 07:30:03 AM »
Quote
/bin/sh: ?.mp3: not foundnknown)  3.9% 18%

This is what you get after you pressed Ctrl + Z, it does work without the "..."

Offline evertvaningen

  • Jr. Member
  • **
  • Posts: 60
Re: VT8237A/VT8251 No Sound
« Reply #11 on: June 13, 2017, 08:01:58 AM »
I am writing me the things I need to do to get things working.
I'll reinstall and begin a new.

When I'm at this point again I'll report back ;)

Offline evertvaningen

  • Jr. Member
  • **
  • Posts: 60
Re: VT8237A/VT8251 No Sound
« Reply #12 on: June 13, 2017, 08:53:48 AM »
What I did:

1: Installing BCM4328 driver:
http://forum.tinycorelinux.net/index.php/topic,21138.0.html

Install WL modules first then nano in order to edit the config file to make the WL modules work.
nano /etc/sysconfig/tcedir/boot/extlinux/extlinux.conf and add "blacklist=b43,ssb,bcma"  to boot conf file.


2: Write Script to make device auto connect to Wifi SSID with WPA2 protection:

Source: http://forum.tinycorelinux.net/index.php?topic=12441.0
After click wifi icon to connect to WLAN, go to /etc to find a file called wpa_supplicant.conf, copy it to /opt so it becomes persistent, this file contains credentials of your WLAN, it's generated every time you click the icon to connect.

Source: http://distro.ibiblio.org/tinycorelinux/dCore/armv7/GK802/README-wifi.txt
Once wifi is operational, then to automate connection at boot perform the following:
Edit the onboot list to add the following two items:
    $ nano /etc/sysconfig/tcedir/onboot.lst
         wifi.tcz

Edit the bootlocal file to attempt connection at boot time (optional)
    $ nano /opt/bootlocal.sh
         /usr/local/bin/wifi.sh -a 2>&1 > /tmp/wifi.log

Finally be sure to backup before poweroff or reboot.
    $ backup
    $ sudo poweroff


3: Get Sound working

Install alsa.tcz
Install alsa-config.tcz

and manually add  alsa-config.tcz  just before  alsa.tcz  in your onboot list file (/etc/sysconfig/tcedir/onboot.lst)

to save ALSA settings, run

sudo alsactl store

... and to make this persist across reboots, run

echo "usr/local/etc/alsa/asound.state" >> /opt/.filetool.lst

... and, of course, make a backup

filetool.sh -b

 Then reboot.


Installed mplayer and mpg123
After that

run

mplayer http://91.221.151.155:80/;?.mp3


Still no audio... :(

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9282
Re: VT8237A/VT8251 No Sound
« Reply #13 on: June 13, 2017, 09:18:49 AM »
You need to load alsa-config before alsa

It might be easier to use the following to test if sound works:
Code: [Select]
$ speaker-test -Ddefault:0 -c2 -t wav -l1
[change default to suit multiple cards]

Also, if the following shows that you have an HDMI audio device, you might need to load the graphics-KERNEL and Xorg-7.7 extensions before alsa-config and alsa:
Code: [Select]
$ aplay -l
« Last Edit: June 13, 2017, 09:22:00 AM by Juanito »

Offline evertvaningen

  • Jr. Member
  • **
  • Posts: 60
Re: VT8237A/VT8251 No Sound
« Reply #14 on: June 13, 2017, 09:24:14 AM »
You need to load alsa-config before alsa

It might be easier to use the following to test if sound works:
Code: [Select]
$ speaker-test -Ddefault:0 -c2 -t wav -l1
[change default to suit multiple cards]

Also, if the following shows that you have an HDMI audio device, you might need to load the graphics-KERNEL and Xorg-7.7 extensions before alsa-config and alsa:
Code: [Select]
$ aplay -l

In the onboot.lst
alsa-config.tcz is listed above alsa.tcz


Trying
$ speaker-test -Ddefault:0 -c2 -t wav -l1

... no sound.
« Last Edit: June 13, 2017, 09:25:47 AM by evertvaningen »