WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: XPM support in PHP  (Read 73 times)

Offline andyj

  • Sr. Member
  • ****
  • Posts: 420
XPM support in PHP
« on: June 06, 2017, 08:25:52 PM »
I'm in the process of testing PHP 7.1 and supporting extensions for submission to the 8.x 64-bit repository. One of the features I noticed in the latest libwebp and libgd is that they require a pretty serious number of X libraries just to support the XPM image format and GL, neither of which seem necessary for a web server. Are there any users of the LAMP stack that require either of these for PHP that I should retain them? If not then I can submit no-X versions of these two libraries which would not depend on X libraries. Also, as of PHP 7.1 libmcrypt is deprecated. Is anyone still using this?