WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: ZILE editor for X86_64  (Read 435 times)

Offline wksilva

  • WikiUser
  • *
  • Posts: 8
ZILE editor for X86_64
« on: May 17, 2017, 07:01:58 PM »
Trying to compile ZILE for x86_64, but ./configure show this error:

--------------8<---------------
checking for LIBGC... no
configure: error: Package requirements (bdw-gc >= 7.2) were not met:

No package 'bdw-gc' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBGC_CFLAGS
and LIBGC_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
--------------8<---------------

I installed gc.tcz but something is still missing.


Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5471
Re: ZILE editor for X86_64
« Reply #1 on: May 17, 2017, 08:05:20 PM »
Hi wksilva
The first question that comes to mind when someone has compilation issues is did you install  compiletc.tcz?
The other package you might need is  gc-dev.tcz.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9608
Re: ZILE editor for X86_64
« Reply #2 on: May 17, 2017, 09:04:30 PM »
configure: error: Package requirements (bdw-gc >= 7.2) were not met:
No package 'bdw-gc' found

When you get an error like this, it means that the pkg-config file bdw-gc.pc cannot be found.

If you use the "provides" feature of the apps gui, you can see that bdw-gc.pc is provided by the gc-dev extension.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9608
Re: ZILE editor for X86_64
« Reply #3 on: June 19, 2017, 02:22:03 AM »
zile posted